E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-09-2011, 06:49 PM   #1
Gus330vrum
Registered User
 
Join Date: Mar 2011
Location: atlanta
Posts: 1,498
My Ride: 330ci
Running on the highway! suddenly it dies

okay guys.... driving on my 325xi 03 on the highway 65+ when my car with 50miles/ gas yellow light on...... the car suddenly starts to feel weak like it lost gas and i had to pull over... i try to start the car... it would start but then diee quickly....

i figured something that has to do with the lvl of fuel...!


so i remember there i was a thread back then about driving w low fuel... well it happen too me..


i went a bought 1 gallon of gas... put it in.. and the car started normal...


i still feel like the engine is doing kinda of hiccups when stop/ NEUTRAL /5 SPEED....

from inside the car... i feel like the engine does hiccups as if it was losing power then back to normal again.... (( very light ))

WHAT COULD I BE?

I GOT A NEW FUEL FILTER! pelicanparts.com
Gus330vrum is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-09-2011, 08:30 PM   #2
SamDoe1
Registered User
 
Join Date: Oct 2010
Location: Minnesnowta
Posts: 3,576
My Ride: Clubs baby seals
Fuel pump.
SamDoe1 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use