E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-03-2011, 11:22 PM   #1
jogfrogjog
Registered User
 
Join Date: Mar 2011
Location: PA/VA/CA
Posts: 55
My Ride: car e46 330xi
Idle issue

I noticed an issue with my 330xi that if I leave it idle for a while when I come to drive it kind of bogs down and won't rev up, if I turn off the car and start it back it's fine... any ideas?
jogfrogjog is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-05-2011, 10:26 PM   #2
latitude39
Registered User
 
Join Date: Jan 2010
Location: United States/Colorado
Posts: 139
My Ride: 2002 325xi
Quote:
Originally Posted by jogfrogjog View Post
I noticed an issue with my 330xi that if I leave it idle for a while when I come to drive it kind of bogs down and won't rev up, if I turn off the car and start it back it's fine... any ideas?
I had a similar problem with my 325xi at 125k miles. My problem was the intake camshaft position sensor. I replaced it and now it runs fine. Be sure to get the genuine BMW part for ~$120, not the Febi, which is half that price.
latitude39 is offline   Reply With Quote
Old 09-11-2011, 01:43 AM   #3
eeleaj
Registered User
 
Join Date: Aug 2007
Location: san bernardino
Posts: 132
My Ride: Boost 325xi
just out of curiosity why not go for the febi over the genuine bmw?? are they known to go out or something?
__________________
eeleaj is offline   Reply With Quote
Old 10-09-2011, 11:24 PM   #4
jogfrogjog
Registered User
 
Join Date: Mar 2011
Location: PA/VA/CA
Posts: 55
My Ride: car e46 330xi
Quote:
Originally Posted by eeleaj View Post
just out of curiosity why not go for the febi over the genuine bmw?? are they known to go out or something?
+1 why not the febi?
jogfrogjog is offline   Reply With Quote
Old 10-10-2011, 10:00 AM   #5
SamDoe1
Registered User
 
Join Date: Oct 2010
Location: Minnesnowta
Posts: 3,485
My Ride: Clubs baby seals
Because you'll likely have to replace it again. Buy genuine parts for key components like this and you'll be happy you did. The only Febi part I have on my car is for the headlight washers and that one stays unplugged anyway.
SamDoe1 is offline   Reply With Quote
Old 10-10-2011, 11:29 AM   #6
Rickna
Registered User
 
Join Date: Nov 2008
Location: West Haven, CT, USA
Posts: 1,980
My Ride: '02 330xi AT
Send a message via ICQ to Rickna Send a message via AIM to Rickna Send a message via MSN to Rickna Send a message via Yahoo to Rickna
Sam-what do you think of Uro parts, just curious.
__________________

238 years of democracy has died, and with thunderous applause

My_Mods_&_Stuff
Rickna is offline   Reply With Quote
Old 10-10-2011, 12:06 PM   #7
redbull 325is
Registered User
 
Join Date: Jul 2006
Location: NC
Posts: 699
My Ride: 325xit/6
Send a message via AIM to redbull 325is
AFAIK Febi is OEM, uroparts is junk
__________________
Royal Elite Club of 6 Speed Tourings - founder
redbull 325is is offline   Reply With Quote
Old 10-10-2011, 02:00 PM   #8
SamDoe1
Registered User
 
Join Date: Oct 2010
Location: Minnesnowta
Posts: 3,485
My Ride: Clubs baby seals
Quote:
Originally Posted by redbull 325is View Post
AFAIK Febi is OEM, uroparts is junk
Quote:
Originally Posted by Rickna View Post
Sam-what do you think of Uro parts, just curious.
Uroparts is the same thing. Use it for non-critical parts and I'm sure it'll all be fine. Use OE (BMW) parts for stuff like sensors and other critical components. I try to use OE (BMW) parts or OEM (OE manufacturer) parts as much as possible just to keep the car as original as I can, never know if it'll eventually be a collector right?

I don't think Febi is an OEM part. It's probably an OEM replacement part. AFAIK, Febi was not a supplier to BMW but I could be wrong.
SamDoe1 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use