E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-11-2011, 12:46 AM   #1
rosshc44
Registered User
 
Join Date: Oct 2011
Location: Toronto
Posts: 9
My Ride: 2004 325xi
Rough Idle In Cold

Hey,

This is my first post on these forums, but i have been helped countless times by many of these threads.
I have a 2004 325xi with 185000 kilometers on it.
When starting the car from a cold start the car has a rough and noisy idle and the rpm gage sits at the 1k. As the car warms up, the rpms go down to where they normally idle (600) and the cars idle becomes smooth and less noisy.This is especially true when starting the car after it has been outside overnight in chilly fall evenings and not in the garage.

I have no engine light codes and recently i took it to the shop who replaced my secondary air pump, spark-plugs and drive belt after which the problem seemed to have gone away. Recently with the colder nights, it has started doing it again in the morning.

Any help would be greatly appreciated.

Cheers,

RHC
rosshc44 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-11-2011, 12:50 AM   #2
CSL323
Registered User
 
Join Date: Oct 2011
Location: Keilor East, VIC
Posts: 906
My Ride: '05 330Cic
Send a message via Skype™ to CSL323
Exactly like mine...

The 1K RPMS on cold is fine. The engine runs fine here too...

I don't get any bobbing on my gauge, it's very steady, but when it's being started for the first time on a cold day, I get a noisy idle like the one you describe...

I'm in need of a new belt and sparkies myself.

Interested in a response.
__________________

2005 BMW 330Cic Individual
CSL323 is offline   Reply With Quote
Old 10-11-2011, 11:21 AM   #3
redbull 325is
Registered User
 
Join Date: Jul 2006
Location: NC
Posts: 704
My Ride: 325xit/6
Send a message via AIM to redbull 325is
vanos seals
__________________
Royal Elite Club of 6 Speed Tourings - founder
redbull 325is is offline   Reply With Quote
Old 10-11-2011, 11:32 AM   #4
Kubica
Registered User
 
Join Date: Apr 2008
Location: Boston
Posts: 4,475
My Ride: 2003 325xi
Check the DISA first.
Kubica is offline   Reply With Quote
Old 10-11-2011, 01:54 PM   #5
rosshc44
Registered User
 
Join Date: Oct 2011
Location: Toronto
Posts: 9
My Ride: 2004 325xi
I thought i might have been the vanos seals but the shop says it would throw an engine code if it was. If it is the vanos, is it absolutely necessary to fix or is it something that can be lived with for now?

What is the DISA?
rosshc44 is offline   Reply With Quote
Old 10-11-2011, 03:05 PM   #6
jasonbimmer
Registered User
 
Join Date: Sep 2011
Location: Omaha, NE
Posts: 5,686
My Ride: 2001 BMW 330xi
noisy cold engine is nothing uncommon on an old car. I would suggest checking the oil level and use proper oil weight. however, you need to find where the noise is coming from.
vanos seals even very worn wont give a code cuz I replaced mine and I know it.
you can live with worn vanos but your power and mpg will suffer besides it very easy to do when you plan to replace the valve cover gasket.
DISA is the little box that contains a flap near the top of the engine on the driver side.
when its worn, it will make a grinding sound. you can test it by unplugging the plug when engine is running and observe the sound change.
__________________
2009 Mazda RX-8 R3
2013 Toyota FJ Cruiser
2008 YAMAHA YZF-R6
jasonbimmer is offline   Reply With Quote
Reply

Tags
325xi, high rpms, idle, noisy, rough idle

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use