E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-24-2009, 11:44 AM   #21
c_lespier
Registered User
 
Join Date: Dec 2008
Location: Savannah Ga
Posts: 1
My Ride: 2000 323ci
I have the same problem ans i replaced it and it's happening again! Wonder what could it be?
c_lespier is offline   Reply With Quote
Old 12-07-2009, 07:47 PM   #22
barnis
Registered User
 
Join Date: Jun 2009
Location: boulder, co
Posts: 12
My Ride: 2002 330xi, 2001 X5
could be leaking head gasket? low preasure...

i have this issue where the yelow light comes on after 10 minutes of driving but only on my way home from work...i guess it could be the sesor or something related to the extremely cold weather we are having...I'll get the oil changed and have the diagnose the sensor then...i'm afraid i might have to replace the head gasket tho...
barnis is offline   Reply With Quote
Old 10-14-2011, 12:30 PM   #23
Adanali
Registered User
 
Join Date: Sep 2004
Location: Santa Clara, CA
Posts: 176
My Ride: 2002 330ci 5spd mt
My oil light (yellow) comes on and goes off after a few seconds. Oil level is good. It has been a few months since the oil was changed, so it cannot be due to Dinan tech leaving the ignition on while changing the oil. Does this mean it is the gasket? Can anybody confirm head gasket can cause this too?

Quote:
Originally Posted by barnis View Post
could be leaking head gasket? low preasure...

i have this issue where the yelow light comes on after 10 minutes of driving but only on my way home from work...i guess it could be the sesor or something related to the extremely cold weather we are having...I'll get the oil changed and have the diagnose the sensor then...i'm afraid i might have to replace the head gasket tho...
Adanali is offline   Reply With Quote
Old 10-14-2011, 06:29 PM   #24
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,789
My Ride: '99 328i 1.04646 mu
Quote:
Originally Posted by Adanali View Post
My oil light (yellow) comes on and goes off after a few seconds. Oil level is good. It has been a few months since the oil was changed, so it cannot be due to Dinan tech leaving the ignition on while changing the oil. Does this mean it is the gasket? Can anybody confirm head gasket can cause this too?
If the oil light comes on 10 secs. after you start the car and then goes off 15 secs. after that, it's just a bad oil level sensor. The Dinan tech might have left on the ignition while doing an oil change, but the sensors go bad anyway. It's a part; they break; sometimes randomly.

I can confirm it isn't caused by head gasket...your sensor is bad is all. No emergency, no issue driving; just check oil in the a.m. on level ground...frequently(ish)
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set

dmax on the radio every Wednesday 7-9 p.m. NYC time. Call in! (661) 449-9340 watsonnwatson.com
dmax is offline   Reply With Quote
Old 10-14-2011, 06:38 PM   #25
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 6,698
My Ride: '94 325iC & '00 323i
Quote:
Originally Posted by dmax View Post
If the oil light comes on 10 secs. after you start the car and then goes off 15 secs. after that, it's just a bad oil level sensor. The Dinan tech might have left on the ignition while doing an oil change, but the sensors go bad anyway. It's a part; they break; sometimes randomly.

I can confirm it isn't caused by head gasket...your sensor is bad is all. No emergency, no issue driving; just check oil in the a.m. on level ground...frequently(ish)
What he said...
jdstrickland is offline   Reply With Quote
Old 10-14-2011, 07:16 PM   #26
Adanali
Registered User
 
Join Date: Sep 2004
Location: Santa Clara, CA
Posts: 176
My Ride: 2002 330ci 5spd mt
Thanks dmax, jdstrickland, yeah it comes on 10 seconds after I start the car and it goes of 15 seconds later. It is good to know the cause is the sensor. Last time the light came on, I poured in a quart of 5w30. But the next time I drove the car it came on again. Then I checked the oil, it is little more then what it should be. So yeah I will be checking the oil level and topping it if needed. On next oil change I will have the sensor replaced.

Quote:
Originally Posted by dmax View Post
If the oil light comes on 10 secs. after you start the car and then goes off 15 secs. after that, it's just a bad oil level sensor. The Dinan tech might have left on the ignition while doing an oil change, but the sensors go bad anyway. It's a part; they break; sometimes randomly.

I can confirm it isn't caused by head gasket...your sensor is bad is all. No emergency, no issue driving; just check oil in the a.m. on level ground...frequently(ish)
Adanali is offline   Reply With Quote
Old 10-14-2011, 07:18 PM   #27
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,789
My Ride: '99 328i 1.04646 mu
I hope that 5/30 was LL-01, otherwise I'm duty bound to report you to the authorities! LOL
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set

dmax on the radio every Wednesday 7-9 p.m. NYC time. Call in! (661) 449-9340 watsonnwatson.com
dmax is offline   Reply With Quote
Old 10-14-2011, 07:24 PM   #28
Adanali
Registered User
 
Join Date: Sep 2004
Location: Santa Clara, CA
Posts: 176
My Ride: 2002 330ci 5spd mt
No it was Mobile 5w30 full synthetic shhh

Quote:
Originally Posted by dmax View Post
I hope that 5/30 was LL-01, otherwise I'm duty bound to report you to the authorities! LOL
Adanali is offline   Reply With Quote
Old 10-14-2011, 08:05 PM   #29
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,789
My Ride: '99 328i 1.04646 mu
Quote:
Originally Posted by Adanali View Post
No it was Mobile 5w30 full synthetic shhh
You want a laugh...read my baptism here...search me and M1 5w/30 in the title!

I ran that for 40K miles or so before I knew how stupid I'd been!

You can fix that the next oil change and I'd recommend you do...just coz I said so!
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set

dmax on the radio every Wednesday 7-9 p.m. NYC time. Call in! (661) 449-9340 watsonnwatson.com
dmax is offline   Reply With Quote
Old 10-15-2011, 09:44 AM   #30
Adanali
Registered User
 
Join Date: Sep 2004
Location: Santa Clara, CA
Posts: 176
My Ride: 2002 330ci 5spd mt
Haha, now I know why you said it.

I hope Dinan used LL01 when they changed my oil last. I only topped up with M1 5w/30. By the way I always thought the whole recommend oil to use oil from BMW was so that they can sell it and make profit. But let's not start another heated discussion on that

Quote:
Originally Posted by dmax View Post
You want a laugh...read my baptism here...search me and M1 5w/30 in the title!

I ran that for 40K miles or so before I knew how stupid I'd been!

You can fix that the next oil change and I'd recommend you do...just coz I said so!
Adanali is offline   Reply With Quote
Old 10-15-2011, 11:32 AM   #31
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 1,146
My Ride: 2001 330Ci
I see you have an 2001 330Ci. You'll need to remove the large chassis brace under the engine to replace the sensor. You MUST replace the bolts that attach the brace to the chassis. DO NOT RE-USE the old bolts. Also, these bolts must be tightened in accordance with the repair manual.
markusmarkus is offline   Reply With Quote
Old 10-17-2011, 02:08 PM   #32
Adanali
Registered User
 
Join Date: Sep 2004
Location: Santa Clara, CA
Posts: 176
My Ride: 2002 330ci 5spd mt
Well I have a 2002 330Ci, but I will have it done by Dinan or Rennweks over here anyway. I hope and expect they know what they are doing. Sounds like you replaced it yourself and learned the hard way?

Quote:
Originally Posted by markusmarkus View Post
I see you have an 2001 330Ci. You'll need to remove the large chassis brace under the engine to replace the sensor. You MUST replace the bolts that attach the brace to the chassis. DO NOT RE-USE the old bolts. Also, these bolts must be tightened in accordance with the repair manual.
Adanali is offline   Reply With Quote
Old 10-17-2011, 02:48 PM   #33
eneka
Registered User
 
Join Date: May 2007
Location: SoCal
Posts: 1,777
My Ride: 2003 325i
Quote:
Originally Posted by eggman88888 View Post
^ haha I dont think so

Red light means all of your oil pressure is gone and if you continue to operate the vehicle you risk catastrophic engine damage

the red light stays on for about ~2 second after I start the car...is that normal?
If i restart the car right after shutting the engine down, the light goes off with all the other lights.
__________________
eneka is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use