E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-17-2011, 07:37 PM   #1
cdseven95
Registered User
 
Join Date: Apr 2011
Location: MA
Posts: 157
My Ride: 328
All the problems with my E46 need input

All this happened in the last month

149k
FIXED
Cleaned throttle body (fixed eml light, throttle temp stuck code)
Replaced the CCV (fixed the "Chewbacca" noise)
Replaced starter
Replaced diff bushings ... Fixed clunk


Current issues
1)When I start the car the brake lights out indictator turns on for 5 seconds then turns off... All the light work correctly (I have a coupe)


2)I get like a slight hesitation... In first and reverse..
Only at slow speeds... If I accelerate faster I do not have the issue.

3)ABS Brake DSC lights on . I have no spedo, odo, or mpgs
I read the code and it is CAN to DME and both rear speed sensors
I assume the issue is the CAN to DME and the speed sensors codes are false

4) If I start the car cold and let it idle. The RPMs will dip

5) I have a cel for mass air flow and o2 deviation
Cleaned MAF with no success looks new..

6) I have the correct coolant level as indicated but the coolant light comes on when I turn the heat on...

7) The heat blows cool when I am stopped. Gets hot once I press the gas
__________________

Last edited by cdseven95; 10-17-2011 at 09:00 PM.
cdseven95 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use