E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-16-2011, 08:57 PM   #1
coolbimmer
Registered User
 
Join Date: Feb 2007
Location: Brazil, Sao Paulo
Posts: 7
My Ride: BMW 323
ASC+ABS+Brake warning lights AND other "Activation, Solenoid, Fuel" errors! HELP!!

Hello from Brazil!


Before explaining all these thinks below I have already searched on this forum for my problem and could not found a solution or same problematic as Iím experiencing and I think it should help someone if we discuss and find a solution.

Iím almost giving up of my car, but I think someone here could help me.


Information of the car:

- BMW 323i automatic steptronic transmission (Euro spec)
- I have already replaced many parts and sensors already (before buying the scanner)
- Car has already done the vanos fix
- Already changed MAF sensor
- I already all sort of problems with the car, mainly about suspension because roads in Brazil are not good and the car is armored so it is 200kg heavier.
- The car is running great on take-offs
- Front brake sensor was recently changed. (left front wheel).. The one from the right rear wheel seemed to be ok, and I donít got any error concerning this sensor.
- I have BMW Scanner (1.4.0) and below are the errors I got so far.

Errors scanned:


DME -> Shadow-memory:
32/14 - Activation, solenoid valve, fuel-circuit changeover
85/08 - Signal, CAN ASC 3
23/12 - Activation, relay, secondary-air pump
3E/12 - Activation, solenoid valve, secondary air
7E/12 - Activation, solenoid valve, tank-leak diagnosis pump
7F/02 - Activation, solenoid valve, suction-jet pump
34/02 - Activation, solenoid valve, exhaust flap

(errors P1453 P0412 P1470 P1145)

IKE -> BF/C8 - Internal fault, EEPROM checksum, coding incorrect/incomplete

1rst problem

asc + abs + brake warning lights . It is a Random problem.

2nd problem

Sometimes the car shuts down at random speeds after is on for 30-40 minutes. It happens usually when it is already hot. It kind of stall, shuts off and right away on very fast.

The exterior temperature goes up very very fast after the car is hot after 30-40 minutes, and it increases even more if I turn on the Air Conditioning. And after all this it causes that stall thing and can even shut down the car for a while. But the engine temperature stays normal all the time.

After getting the car hot I have tested the auxiliar fan and it is working perfectly as it turns on normally right after I turn on the A/C. So I think the car is not actually getting hot and maybe it is just the exterior temp sensor that is crazy. (I already bought a new one and Im about to put it on the car).


3rd problem


My old mechanic, the one that I stop taking the car because I think he was a liar, after all the parts that he make me buy and spend on the car told me that the problem should be Throttle body. Does anyone know that this could really be it considering the errors I got?

He already cleaned the Throttle body on the car, but he said that it could be an interior computer fault of the part.


4th problem

After I received my BMW scanner I was trying everything I could do with it, and I went to the IKE and tried to reset oil service and was not able to do it. So I have changed the parameters of days of service, and now I could not even reset with the oil service reset tool and got that - X KM remaining for service. When I reset with the normal oil/inspection reset tool I got on the cluster a 0 KM blinking when I turn on the car! Does anyone that has the BMW Scanner tool could help me telling me what the original parameters are as described on the print screen attached?


Parts that I bought and still did not put on the car until now:


1. Exterior temp sensor (I think it should be faulty or the cable)
2. Throtle body sensor (I bought one used and in good conditions on ebay).
3. ABS Speed sensor. (But Im not considering to put on the car since it does not show error related to it)


My own conclusions:


1. Im not sure if the ASC error and abs + asc + brake warning lights have anything to do with the stall problem.
2. Maybe the car is not actually getting hot and the problem is the exterior temperature sensor that is faulty.
3. Maybe the exterior temperature cable is plugged to the engine temperature sensor (thermostat) and it the engine is actually getting hot.
4. About that solenoid error I donít have any clue of what could be. I have already checked all the relays and fuses and it is everything ok. And the car probably would not be working correct if anything at the fuel system was faulty right?

Please help!
Attached Thumbnails
Click image for larger version

Name:	bmw - DME before cleaning errors.jpg
Views:	196
Size:	143.8 KB
ID:	421212   Click image for larger version

Name:	bmw - DME after cleaning errors.jpg
Views:	179
Size:	172.7 KB
ID:	421213   Click image for larger version

Name:	bmw - EGS before cleaning errors.jpg
Views:	162
Size:	224.7 KB
ID:	421214   Click image for larger version

Name:	bmw - cluster information.jpg
Views:	216
Size:	160.8 KB
ID:	421215  

coolbimmer is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-25-2011, 08:42 PM   #2
locomexicano
Registered User
 
Join Date: Apr 2008
Location: California
Posts: 46
My Ride: E46 330ci
Send a message via MSN to locomexicano
Dude i had that same problem, did you try taking out all the air in your radiator sometimes their is air trap inside the engine. Run your water hose to your radiator and take the presure valve off fill it with water, Their should be only water comming out from the presure valve. Turn on car and turn the heater on, Something like that. Good luck.
locomexicano is offline   Reply With Quote
Reply

Tags
abs, asc, brake warning lights, fuel, solenoid

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use