E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-01-2011, 05:10 PM   #1
Patrick Davis
Registered User
 
Join Date: Nov 2011
Location: virginia
Posts: 3
My Ride: bmw325i
Cool bigboy

i have a problem with my 2004 325i, lookin to get some help on cause of problem
Patrick Davis is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-01-2011, 05:45 PM   #2
Patrick Davis
Registered User
 
Join Date: Nov 2011
Location: virginia
Posts: 3
My Ride: bmw325i
Cool 2004 325i possible vaccum leak !

I have a 2004 325i that acts like it is going to stall when it is stopped at a light or stop sign, but when i accellerate it responds with plenty of power. I have had a vaccum hose replaced, not sure which one. If there is any info or suggestions i would greatly appreciate it !
Patrick Davis is offline   Reply With Quote
Old 11-01-2011, 06:20 PM   #3
Kevin03
Registered User
 
Join Date: Mar 2011
Location: Orlando, FL
Posts: 55
My Ride: 2003 325i
I'm sure many others on here who know bmws beter than me will b better able to help.
With my past cars that would lead to the idle air control valve being worn or dirty. I assume bmw has them too. Try removing n cleaning first then replace if that doesn't help.
Again I'm newer to bmws so might not b the correct answer but that is what it sounds like.
Kevin
Kevin03 is offline   Reply With Quote
Old 11-01-2011, 09:18 PM   #4
LA Prince
Banned User
 
Join Date: Aug 2011
Location: Not Your Business
Posts: 971
My Ride: Not Your Business


Umm...I think you have to tell us your problem first.
LA Prince is offline   Reply With Quote
Old 11-02-2011, 05:58 AM   #5
Patrick Davis
Registered User
 
Join Date: Nov 2011
Location: virginia
Posts: 3
My Ride: bmw325i
Cool 2004 325i problrm

My 2004 325i has a problem, gets ready to die when sitting still or ideling, but whe n step on accellerator responds fine with plenty of power. had a vaccum hose replaced that had a hole, but still persists. there seems to be an exaust problem that is causing it, when starting up in the a.m there is some smoke coming from exaust pipe and a burning smell and sounds like a chokong issue from exaust. any suggestions would be greatly appreciated, i would rather try and fix myself as dealers are very expensive, thank you
Patrick Davis is offline   Reply With Quote
Old 11-02-2011, 08:45 AM   #6
tim330i
Owner/Admin
 
tim330i's Avatar
 
Join Date: Dec 1969
Location: Boston
Posts: 11,148
My Ride: 03 Ti Silver M3
You don't need to make a new thread about your problem each day, simply update your existing thread. I've merged your three threads together for you now.

Is it possible you have another vacuum leak? Is your check engine light on? If so go to autozone and get the codes pulled.

Tim
tim330i is offline   Reply With Quote
Old 11-02-2011, 11:21 AM   #7
jasonbimmer
Registered User
 
Join Date: Sep 2011
Location: Omaha, NE
Posts: 5,686
My Ride: 2001 BMW 330xi
I am thinking maybe the CCV is cracked causing a vacuum leak?
or maybe one of the CCV hoses.
__________________
2009 Mazda RX-8 R3
2013 Toyota FJ Cruiser
2008 YAMAHA YZF-R6
jasonbimmer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use