E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-24-2011, 12:59 PM   #1
bmwforce
Registered User
 
Join Date: Mar 2008
Location: Burlington, ON
Posts: 4
My Ride: 04 325i, 01 330CI
Strange problem

hoping someone here may be able to explain the problem.
I have an issue with my 2001 BMW 330CI automatic.

Sometimes as I drive there is a bang that comes from the transmission, like someone hit the car from behind. The car drives OK for a few seconds but then the trouble light (exclamation mark) shows up on the dash and the car goes into Limp Mode, like only the 3rd and 4th gear work. Very sluggish. Then I put the car in park, turn off and turn back on, the trouble light disappears and the car drives fine, until this whole thing happens again, usually within a couple of weeks. I have a small code reader, but it does not find the trouble, since the trouble light is out I guess (the code note stored)?
I have the code reader with me, but when this happens, I am usually at a place where I can't just stop and read the code...bummer. Hope someone else has had a run in with this that can help me.
Thanks.

Last edited by bmwforce; 11-24-2011 at 01:04 PM.
bmwforce is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-01-2011, 05:30 PM   #2
Nightmare5336
Registered User
 
Join Date: Jan 2010
Location: South Jersey
Posts: 741
My Ride: e46 with a slushy
Same symptoms but my torque converter went
__________________

Quote:
Originally Posted by jdc336 View Post
DUMB YOUR MOM.
Nightmare5336 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 04:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use