E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-07-2011, 02:15 AM   #1
odf_jeff
Registered User
 
Join Date: Jul 2009
Location: Cincinnati, Ohio
Posts: 11
My Ride: 2003 325xi
Help!!!!

So I got in my car tonight and as soon as I started driving my check engine light came on. The car wasn't doing anything funny at first but when I started driving up a very small incline it started to putt like it was running out of gas but it has a full tank. Once it leveled out it drove fine. I made it home and turned the car off, let it sit for a minute, and tried to start it again and it did, but started putting right away and cut off. Anyone have any ideas of what this could be?
odf_jeff is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-07-2011, 03:13 AM   #2
bernie21614
Registered User
 
Join Date: Apr 2010
Location: Glendale, AZ
Posts: 327
My Ride: 01 330i
Same thing Happened to me a while ago except fort the incline part, my car was sputtering like crazy then it went away and it drove fine, then it started sputtered again and eventually died. made the mistake of taking it to a dealership because the car was still fairly new to me. The dealer replaced the crank case vent valve(all components) and the lower intake boot. You might have a vacuum leak somewhere, get the codes read and post what codes you have.

Sent from my SAMSUNG-SGH-I997 using Bimmer
bernie21614 is offline   Reply With Quote
Old 12-07-2011, 07:29 AM   #3
Mark M
Registered User
 
Join Date: Sep 2009
Location: Lancaster, PA
Posts: 420
My Ride: e30 M3 / e90 335d
Without reading the code and seeing the car to perform a real diagnosis.....

It sounds most like a failing fuel pump, clogged fuel filter, or failing coil packs.

You need to have the codes read to find out for sure. Take into account, not all codes are the root cause of the failure mode. Some codes are symptoms of something failing upstream. (aka...on the e46 there is no code for a failing fuel pump)
__________________
Mark M is offline   Reply With Quote
Old 12-07-2011, 08:06 AM   #4
jasonbimmer
Registered User
 
Join Date: Sep 2011
Location: Omaha, NE
Posts: 5,686
My Ride: 2001 BMW 330xi
get the code read.
that should be done before even posting this thread.
__________________
2009 Mazda RX-8 R3
2013 Toyota FJ Cruiser
2008 YAMAHA YZF-R6
jasonbimmer is offline   Reply With Quote
Old 12-07-2011, 11:10 AM   #5
Gus330vrum
Registered User
 
Join Date: Mar 2011
Location: atlanta
Posts: 1,320
My Ride: 330ci
[QUOTE=jasonbimmer;13869023]get the code read.
that should be done before even posting this thread.[/QUOTE.
Try checking your fuel pressure on top of your manifold "double check location on realoem.com w Vin #.. I have a thread on fuel pump! I recently changed... I knew it was fuel pump bec I been on preventive maintenance schedule hehe.. I had new ignition coils,fuel filter,spark plugs.. Good luck! ------Video camera would help us and you a lot more lol...
Gus330vrum is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use