Service Engine light wont go away - Bank 1 & 2 too lean? - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

 
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Prev Previous Post   Next Post Next
Old 12-13-2011, 06:24 PM   #1
Sean172
Registered User
 
Join Date: Jul 2009
Location: Mahopac, NY
Posts: 26
My Ride: 03' 330i
Service Engine light wont go away - Bank 1 & 2 too lean?

Help!! My engine began running rough and the service engine light has been on. I have cleaned my Mass Air Flow sensor, been throught a dozen bottles of injector cleaner, and I just replaced the two upstream oxygen sonsors. The engine still idles rough and the OBD code shows Bank 1 sytem too lean, Bank 2 system too lean, as well as a slew of random misfire codes. What the hell!!! What should I do next? Any suggestions
Thanks
Sean172 is offline   Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF



All times are GMT -5. The time now is 06:03 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - VerticalScope Inc. All rights reserved.