E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-13-2012, 08:32 AM   #1
stankins
Registered User
 
Join Date: Apr 2011
Location: nj
Posts: 23
My Ride: 325ci
Bad powersteering pump noise not the power steering pump

Hi, I purchased a 03 330 on the cheap, it had a bad whine like a power steering pump was empty so after flushing it to no avail I replaced it and the noise didn't go away!!! Is it possible that it is my alternator??? Has anyone heard a bad alternator sound like a bad powersteering pump? Please help.
Sent from my Desire HD using Bimmer
stankins is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-13-2012, 09:35 AM   #2
TxZHP04
Registered User
 
Join Date: Feb 2006
Location: DFW
Posts: 5,728
My Ride: ESS TS2+ ZHP
What makes you think that it's not still the power steering pump? If the pump is bad, a flush isn't going to fix it.
__________________
04 IR 330i ZHP | ESS TS2+ SC | MagnaFlow "headers" | KMS 3.64 LSD | AST 4100 550/650| APEX ARC-8 18x9 | H&R front sway bar | Vorshlag camber plates, RTAB limiters | TMS subframe & swaybar reinforcements | UUC SSK & DSSR | UUC TM & TME | BW motor mounts | Dinan strut & shock tower bars | vaio 4-bolt oil pump
TxZHP04 is offline   Reply With Quote
Old 01-13-2012, 09:51 AM   #3
BMWCaptain
Registered User
 
Join Date: Sep 2011
Location: TEXAS - Where I give Real World advice and don't just criticize others. People here need to RESPECT other's opinions!
Posts: 1,656
My Ride: 03 325iT SportWagon
Could be the belt tensioner or idler pulley.
BMWCaptain is online now   Reply With Quote
Old 01-13-2012, 11:12 AM   #4
stankins
Registered User
 
Join Date: Apr 2011
Location: nj
Posts: 23
My Ride: 325ci
Ahhh forgot to mention that I replaced The pump the noise is obnoxious and resembles a dry resivoir. The alternator or tensioner pulley are Tue only things close to the sound....

Sent from my Desire HD using Bimmer
stankins is offline   Reply With Quote
Old 01-13-2012, 11:47 AM   #5
darksideracer69
Registered User
 
Join Date: Jan 2008
Location: TX
Posts: 2,886
My Ride: 01 325ci
Quote:
Originally Posted by stankins View Post
Ahhh forgot to mention that I replaced The pump the noise is obnoxious and resembles a dry resivoir. The alternator or tensioner pulley are Tue only things close to the sound....

Sent from my Desire HD using Bimmer
Ive heard and alternator make a high pitched squeal, damn it was annoying. Get a good piece of hose and try to pinpoint where the sound is coming from.
__________________
Quote:
Originally Posted by dmax View Post
If she ever yells 'oh god, oh god' just say, 'no, just Doug.'


IMAG02051
darksideracer69 is offline   Reply With Quote
Old 01-13-2012, 11:52 AM   #6
BMWCaptain
Registered User
 
Join Date: Sep 2011
Location: TEXAS - Where I give Real World advice and don't just criticize others. People here need to RESPECT other's opinions!
Posts: 1,656
My Ride: 03 325iT SportWagon
Check your coolant level. Mine was low and the wp made a weird noise, but you could not tell where it was coming from.
BMWCaptain is online now   Reply With Quote
Old 01-13-2012, 11:55 AM   #7
BigDRick323
OEM ///Member
 
BigDRick323's Avatar
 
Join Date: Apr 2004
Location: Dallas TX
Posts: 1,426
My Ride: 2000 323i
Mine was smelling like burning oil, tried to go get it fixed, I will try again tonight and if I can't get it done will be taking it to Jim's Car Care tomorrow. I have to get an ampbezel put in in Garland anyways. I drove it maybe 5 miles and it smelled awful. Thoughts? I'm pretty sure I did not reattach hose tight enough.
__________________

-1983 Grey 528e (Given to Charity) -1995 Champagne Toyota 4Runner (Friend Totaled) -2000 Black 323i (From DD to Project Car) -2011 Black Toyota Prius III (DD)
http://www.cardomain.com/ride/780058
BigDRick323 is offline   Reply With Quote
Old 01-14-2012, 10:41 AM   #8
jacobs323i
Registered User
 
Join Date: Jul 2008
Location: saint paul
Posts: 786
My Ride: blown 323i
Quote:
Originally Posted by stankins View Post
Ahhh forgot to mention that I replaced The pump the noise is obnoxious and resembles a dry resivoir. The alternator or tensioner pulley are Tue only things close to the sound....

Sent from my Desire HD using Bimmer
Same thing happened to me, BMW tech said it was a bad resivoir
jacobs323i is offline   Reply With Quote
Old 01-14-2012, 11:09 AM   #9
LivesNearCostco
Registered User
 
Join Date: Jan 2010
Location: Silicon Valley
Posts: 768
My Ride: 2003 ZHP 6MT
The P/S fluid reservoir has a built-in filter which can get clogged in high-mileage cars. But I don't know if it filters fluid going to the pump or fluid coming back from the cooling coil.
__________________
Lowering my car's resale value one track day at a time...
LivesNearCostco is offline   Reply With Quote
Old 01-15-2012, 08:25 PM   #10
BMWtech122
Registered User
 
Join Date: Jan 2012
Location: Boston
Posts: 2
My Ride: 330xi
Stankins, I think I can help you out. It is possible but less likely the P/S pump is causing your noise. Often the idler and tensioner pulleys start to go and make a whine that even to an experienced tech can sound like a P/S pump. What you should do is get a long screwdriver and start your engine (remove the intake duct that blocks the view of the belts if necessary). CAREFULLY put the tip of the screwdriver close to where each pulley bolts to the motor, and on the alternator itself. If you put your ear up to the screwdriver handle it will act as a stethoscope of sorts. You will easily be able to pinpoint the location of the noise. You can also remove the belts and spin each pulley individually while listening to pinpoint it further. I hope this helps you find your noise, any questions feel free to PM.
BMWtech122 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 08:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use