E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-17-2012, 03:05 PM   #1
robwallace
Registered User
 
Join Date: Jan 2012
Location: West Sussex
Posts: 9
My Ride: 2001 330Ci
330Ci intermittent lack of power & hesitant starting...HELP!

Hi there, I have had my 2001 (51 UK plate) 330Ci for a couple of months and it has been great. Today however I was driving around as normal this morning, parked up for an hour then went back out to the car and it was hesitant to start which has never happened before. I noticed the EML light come on whilst I was attempting to start it. Once it did start, performance was down and it wasn't wanting to accelerate where normally it pulls like a train. I took it to my local garage and they put in on a scanner and it came back with nothing. I then drove it again for around 15 minutes this evening and initially it seemed fine, then again the lack of power started again. I had to park up for a couple of minutes to go into a shop and then after it was reluctant to start again and when it did it smelt like a burning smell. Just wondering if anyone has had this problem before and/or can shed any light on it, it's going back to the garage tomorrow but would like to have an idea beforehand!

Thank you! :-)
robwallace is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-17-2012, 05:01 PM   #2
jasonbimmer
Registered User
 
Join Date: Sep 2011
Location: Omaha, NE
Posts: 5,686
My Ride: 2001 BMW 330xi
EML means theres something wrong with your drive-by-wire system ( throttle pedal, throttle body, idle control valve).
__________________
2009 Mazda RX-8 R3
2013 Toyota FJ Cruiser
2008 YAMAHA YZF-R6
jasonbimmer is offline   Reply With Quote
Old 01-18-2012, 11:02 AM   #3
hummer
Registered User
 
Join Date: Apr 2003
Location: Haverhill, MA
Posts: 3,323
My Ride: 2001 330CI
If the light came on, there should be a stored code. Maybe your mech just can't read it? The symptoms are similar to cam or crank position sensor failures which was intermittent on mine at first and then more severe. Could also be a fuel delivery issue with a clogged filter or failing fuel pump. My failing pump did not result in codes.

Last edited by hummer; 01-18-2012 at 11:05 AM.
hummer is offline   Reply With Quote
Old 01-18-2012, 11:47 AM   #4
robwallace
Registered User
 
Join Date: Jan 2012
Location: West Sussex
Posts: 9
My Ride: 2001 330Ci
Hi, thank you for the replies. I have had the car scanned again and it came back with a P0360 which indicates ignition coil? When the problems started, the car only went in to have the levels topped up and we checked it on the scanner and it had a P0340 and a P0160 which are cam position sensor and 02 sensor (rear one)? I don't know why it would be chucking up different codes every time. Will drive it again tonight and tomorrow and see what happens and have it scanned for a third time I guess, very odd!
robwallace is offline   Reply With Quote
Old 01-18-2012, 02:44 PM   #5
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 1,237
My Ride: 2001 330Ci
Ecu

Whenever a car is throwing a range of codes, two issues come to mind:
1. Is the code scanner capable of reading BMW-specific codes? If it is not it will give you seemingly unrelated codes when in fact the BMW-specific codes point to the problem.
2. Does the ECU's software require a reflash? This can happen when the electrical system isn't up to snuff. How old is the battery?

markusmarkus is offline   Reply With Quote
Old 01-19-2012, 11:22 AM   #6
hummer
Registered User
 
Join Date: Apr 2003
Location: Haverhill, MA
Posts: 3,323
My Ride: 2001 330CI
I believe if you were using a BMW specific reader, the bad coil/cylinder would be identified? Intake or exhaust sensor?

Last edited by hummer; 01-19-2012 at 11:26 AM.
hummer is offline   Reply With Quote
Reply

Tags
330ci, power, problem, starting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use