E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 02-16-2012, 08:21 AM   #1
sshah261
Registered User
 
Join Date: Oct 2007
Location: Northbrook,IL
Posts: 41
My Ride: 2002 325i
Send a message via AIM to sshah261
Business CD player not working! helpppp

Hey guys im sorry but i did some research on the forums and couldnt find anyone with this particular problem so i had to post it.... so about a week ago i turned on my car, and my bmw business cd/radio just stopped working. I turned the car on in the morning and it just wouldnt work. so then i bought a used Business CD/Radio player off someone from these forums to see maybe it could have been something wrong with the player itself, but when i got it yesterday it still doesnt work. The lights of the player turn on (for all the buttons) illuminate when i turn my headights on at night but the screen itself isnt, its black and no sound nothing comes. Any ideas on what it could be?
sshah261 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-16-2012, 08:21 PM   #2
sshah261
Registered User
 
Join Date: Oct 2007
Location: Northbrook,IL
Posts: 41
My Ride: 2002 325i
Send a message via AIM to sshah261
bump!!!
sshah261 is offline   Reply With Quote
Old 02-16-2012, 08:38 PM   #3
forzam
Registered User
 
Join Date: Apr 2007
Location: East Coast
Posts: 374
My Ride: 04 325Ci
My knowledge is very limited here. Only things I can suggest would be to 1) check the wires in the back - both the connections and use a volt meter to check if there are signals in the wires and 2) hook up to the radio module and see if there are any errors.

Last edited by forzam; 02-16-2012 at 08:39 PM.
forzam is offline   Reply With Quote
Old 09-03-2012, 01:16 PM   #4
EmmamedEee
Registered User
 
Join Date: Sep 2012
Location: Kurravaara -Kiruna - Sweden
Posts: 1
My Ride: BMW 328i -00 e46
Cool +1

Quote:
Originally Posted by sshah261 View Post
Hey guys im sorry but i did some research on the forums and couldnt find anyone with this particular problem so i had to post it.... so about a week ago i turned on my car, and my bmw business cd/radio just stopped working. I turned the car on in the morning and it just wouldnt work. so then i bought a used Business CD/Radio player off someone from these forums to see maybe it could have been something wrong with the player itself, but when i got it yesterday it still doesnt work. The lights of the player turn on (for all the buttons) illuminate when i turn my headights on at night but the screen itself isnt, its black and no sound nothing comes. Any ideas on what it could be?

Got the exact same problem, did you find a resolution for it?
EmmamedEee is offline   Reply With Quote
Old 12-09-2012, 12:52 PM   #5
dp08
Registered User
 
Join Date: Oct 2011
Location: Wallington
Posts: 4
My Ride: 320d Touring
Im having the same problem. Did anyone ever got the solution? I also tried the aftermarket, but still nothing...
I check the boot as i read about amp not working anymore, but i dont seem to have an amp.
Someone told me there might not be enough power to get the speaker to work? anyone know anything about it??
dp08 is offline   Reply With Quote
Old 12-09-2012, 01:07 PM   #6
jmillsner
Registered User
 
Join Date: Nov 2012
Location: Chicago, IL
Posts: 422
My Ride: 330Ci 6 Spd, 335Cic
it could be just a fuse as well, dont quote me on that one though.

if you wanna sell that extra Business CD you have im in Glencoe, IL so feel free to PM me
jmillsner is online now   Reply With Quote
Old 12-09-2012, 01:17 PM   #7
RayPooley
Registered User
 
Join Date: Jul 2012
Location: Liverpool
Posts: 1,440
My Ride: 320i SE Coupe
Quote:
Originally Posted by sshah261 View Post
Hey guys im sorry but i did some research on the forums and couldnt find anyone with this particular problem so i had to post it.... so about a week ago i turned on my car, and my bmw business cd/radio just stopped working. I turned the car on in the morning and it just wouldnt work. so then i bought a used Business CD/Radio player off someone from these forums to see maybe it could have been something wrong with the player itself, but when i got it yesterday it still doesnt work. The lights of the player turn on (for all the buttons) illuminate when i turn my headights on at night but the screen itself isnt, its black and no sound nothing comes. Any ideas on what it could be?
Is there a seperate fuse for the carousel? Check it out. Fuses 7 and 41

Last edited by RayPooley; 12-09-2012 at 01:19 PM.
RayPooley is offline   Reply With Quote
Old 12-24-2012, 09:08 AM   #8
dp08
Registered User
 
Join Date: Oct 2011
Location: Wallington
Posts: 4
My Ride: 320d Touring
Checked the fuses, all working... this one is driving me mad... only one thing to do is to re wire the lot with my aftermarket head unit and get the speakers working through the amp.
dp08 is offline   Reply With Quote
Old 12-24-2012, 10:24 AM   #9
E46 4 Breakfast
Registered User
 
Join Date: Dec 2012
Location: Canada
Posts: 16
My Ride: 330XI
Did you remove the door panels, rough driving or drags lately? I had a similar problem, The speaker wire was touching the metal from the door, the radio was on, everything seemed alright but no sound was coming out, At first i though it was the Harmon Karmon Amp but it was actually the front driver door's twitter which the wire was exposed touching the door's metal, try putting a CD in and check to see if the timer of the sounds still goes on and if you can change songs, if you can actually change songs but no sound coming out you actually have a speaker wire that is touching the body of the car, check them one by one. Pretty long process but there's no other way to know which speaker it is.
E46 4 Breakfast is offline   Reply With Quote
Old 12-29-2012, 03:50 AM   #10
asdetail
Registered User
 
Join Date: Dec 2012
Location: brisbane australia
Posts: 269
My Ride: 2002 325ci coupe
Quote:
Originally Posted by dp08 View Post
Checked the fuses, all working... this one is driving me mad... only one thing to do is to re wire the lot with my aftermarket head unit and get the speakers working through the amp.
gotta be a power issue, either one of the fuses or perhaps in the fakra connection, check for power present at connection pins
asdetail is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use