E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 02-21-2012, 12:25 PM   #1
yash
Registered User
 
Join Date: Feb 2012
Location: Columbus
Posts: 6
My Ride: 325xi
Not just one problem(gas not getting into the tank etc.,)

Hi, sorry for the long story.
I have a 2002 325xi, it was running great. Went to get oil change(and coolant top off as coolant level is low) at a dealer and he recommended some things(rear brakes,outer cv boots, one tire, front stabilizer link, oil filter housing gasket, valve cover gasket). So after coming back, I went out of town for 4 days. By the time I got back that tire got flat. I have a spare so installed the spare and went to fill up the gas. After like a gallon the gas is not getting inside the tank. Tried at a diff. gas station but d same result.Now the coolant light came back again. I reached out to some mechanics so as to get the things done at less cost (I'm a student). I even ordered almost all the parts. But none of them showed up for two weeks. Now, the car is not evn starting. Its showing the low battery and "OIL" lights too. Please help.
yash is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Tags
325xi, 3series, coolant, e46, fuel

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use