E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-21-2012, 01:25 PM   #1
yash
Registered User
 
Join Date: Feb 2012
Location: Columbus
Posts: 6
My Ride: 325xi
Not just one problem(gas not getting into the tank etc.,)

Hi, sorry for the long story.
I have a 2002 325xi, it was running great. Went to get oil change(and coolant top off as coolant level is low) at a dealer and he recommended some things(rear brakes,outer cv boots, one tire, front stabilizer link, oil filter housing gasket, valve cover gasket). So after coming back, I went out of town for 4 days. By the time I got back that tire got flat. I have a spare so installed the spare and went to fill up the gas. After like a gallon the gas is not getting inside the tank. Tried at a diff. gas station but d same result.Now the coolant light came back again. I reached out to some mechanics so as to get the things done at less cost (I'm a student). I even ordered almost all the parts. But none of them showed up for two weeks. Now, the car is not evn starting. Its showing the low battery and "OIL" lights too. Please help.
yash is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-21-2012, 01:45 PM   #2
SamDoe1
Registered User
 
Join Date: Oct 2010
Location: Minnesnowta
Posts: 3,576
My Ride: Clubs baby seals
The gas isn't getting in the tank? Is it flowing out the top or leaking through the bottom? Never heard of this happening before...check for clogs in the fill tube I guess?

As far as the not starting, that might have to do with the lack of gas...

You should check your oil level to make sure you're not low. If you are, check for leaks. Chances are it's leaking from the valve cover gasket and oil filter housing amongst other places. Also check your coolant level to make sure you have enough. You will likely need to address the coolant issue ASAP so you don't blow your head gasket with an overheat. The coolant is likely leaking out of somewhere and a cooling system refresh seems like it's in your very near future.

I'm not sure what you have available to you to DIY stuff but it might be your best bet to save money. Also, don't ever take your car to the dealer for an oil change, you are getting ripped off.
SamDoe1 is offline   Reply With Quote
Old 02-21-2012, 02:51 PM   #3
yash
Registered User
 
Join Date: Feb 2012
Location: Columbus
Posts: 6
My Ride: 325xi
It(the fuel) is not getting in at all. I even tried to do that using a fuel can but even then the fuel is coming out. Now the fuel level is very low(I doubt it's even empty becoz the car is not crankng up). I am looking to try DIY (coz I got sick after waiting for 3 mechanics for 3 consecutive weeks), but the fuel problem sounds strange,....for CV boots and springs(I forgot tell about this) I need to buy another jack coz I jave just one to lift ther car up....please advise.....
yash is offline   Reply With Quote
Old 02-21-2012, 03:19 PM   #4
SamDoe1
Registered User
 
Join Date: Oct 2010
Location: Minnesnowta
Posts: 3,576
My Ride: Clubs baby seals
Quote:
Originally Posted by yash View Post
It(the fuel) is not getting in at all. I even tried to do that using a fuel can but even then the fuel is coming out. Now the fuel level is very low(I doubt it's even empty becoz the car is not crankng up). I am looking to try DIY (coz I got sick after waiting for 3 mechanics for 3 consecutive weeks), but the fuel problem sounds strange,....for CV boots and springs(I forgot tell about this) I need to buy another jack coz I jave just one to lift ther car up....please advise.....
The car isn't cranking at all? That might be a dead battery.

Look around the forum. There are DIY instructions for every one of the issues you noted. Except for the gas tank thing, that's just weird...maybe try to borescope the fill tube and see if something is stuck in there?
SamDoe1 is offline   Reply With Quote
Old 02-21-2012, 04:32 PM   #5
yash
Registered User
 
Join Date: Feb 2012
Location: Columbus
Posts: 6
My Ride: 325xi
Thanks for your time Sam.......willl see wht I can do......
yash is offline   Reply With Quote
Old 02-21-2012, 08:52 PM   #6
Rickna
Registered User
 
Join Date: Nov 2008
Location: West Haven, CT, USA
Posts: 1,995
My Ride: '01 330xi - '09 IS-F
Quote:
Originally Posted by SamDoe1 View Post
The car isn't cranking at all? That might be a dead battery.

Look around the forum. There are DIY instructions for every one of the issues you noted. Except for the gas tank thing, that's just weird...maybe try to borescope the fill tube and see if something is stuck in there?
Borescope-damn good idea!
__________________

2001 BMW 330xi
2009 Lexus IS-F
Rickna is online now   Reply With Quote
Old 02-21-2012, 09:43 PM   #7
Kubica
Registered User
 
Join Date: Apr 2008
Location: Boston
Posts: 4,486
My Ride: 2003 325xi
This sounds like the infamous spider's nest clogging the gas tank vent!
Kubica is offline   Reply With Quote
Old 02-21-2012, 09:44 PM   #8
White_Knuckles
Registered User
 
Join Date: May 2009
Location: Washington (the state)
Posts: 1,598
My Ride: 2003 325xi
Okay, how about being more descriptive with these issues? Can you send a thin tube down to the tank bottom such as 1/2" clear vinyl tubing? Go buy a 5' cutting and probe the fill neck path. Maybe someone stuffed a tennis ball in there? You don't need a scope just a simple hose to where you can feed it down and blow bubbles in the fuel. If the hose won't go down, an obstruction may be present. Don't try and ram it through!

You say it won't crank now? A simple battery charge may be in order. But you have to tell us the no start symptom with info like the lights dim when you hit the key. Or it's making a clicking noise. The oil and coolant indicators will come on with a slight amount down but you absolutely have to verify how far down things are. No low fluid condition will prevent cranking.

Longer posts with accurate info. are better then bits and pieces we have to try and assemble.
__________________
Anything made can be made Better

Last edited by White_Knuckles; 02-22-2012 at 12:28 AM.
White_Knuckles is offline   Reply With Quote
Old 02-22-2012, 09:05 AM   #9
yash
Registered User
 
Join Date: Feb 2012
Location: Columbus
Posts: 6
My Ride: 325xi
Yeah I can do that. The lights don't go dim but it's making a clicking noise while trying to start.The vehicle is out in the snow (our complex doesnt have any garages for cars). The mechanic told that the oil leak was very minimal and suggested to do the gaskets(oil filter housing and valve cover) within like 2 months(but this situation is like after 3 weeks and that too because the mechanics did not show up as said). As I said the coolant was topped off during the oil change. I checked the coolant level(knob) last sunday and its very low. I cant understand why everything shows up right after coming back from the oil change and vehicle inspection. As of now this is all the information I have. I will check the oil level today evening. Please guide me if I have to check anything else.
yash is offline   Reply With Quote
Old 02-22-2012, 09:09 AM   #10
jasonbimmer
Registered User
 
Join Date: Sep 2011
Location: Omaha, NE
Posts: 5,686
My Ride: 2001 BMW 330xi
Quote:
Originally Posted by yash View Post
Yeah I can do that. The lights don't go dim but it's making a clicking noise while trying to start.The vehicle is out in the snow (our complex doesnt have any garages for cars). The mechanic told that the oil leak was very minimal and suggested to do the gaskets(oil filter housing and valve cover) within like 2 months(but this situation is like after 3 weeks and that too because the mechanics did not show up as said). As I said the coolant was topped off during the oil change. I checked the coolant level(knob) last sunday and its very low. I cant understand why everything shows up right after coming back from the oil change and vehicle inspection. As of now this is all the information I have. I will check the oil level today evening. Please guide me if I have to check anything else.
you need to find whats leaking and fix it. ranting on here wont get you anywhere.
__________________
2009 Mazda RX-8 R3
2013 Toyota FJ Cruiser
2008 YAMAHA YZF-R6
jasonbimmer is offline   Reply With Quote
Old 02-22-2012, 11:47 AM   #11
yash
Registered User
 
Join Date: Feb 2012
Location: Columbus
Posts: 6
My Ride: 325xi
I wanted to know some things like, these problems are not connected (if anything in the engine activates the fuel shut-off or something like that) etc., If I can know right away about what to fix, I would n't be here. Excuse me guyz, if anyone feels like a ranting
yash is offline   Reply With Quote
Old 02-22-2012, 12:00 PM   #12
SamDoe1
Registered User
 
Join Date: Oct 2010
Location: Minnesnowta
Posts: 3,576
My Ride: Clubs baby seals
Quote:
Originally Posted by yash View Post
Yeah I can do that. The lights don't go dim but it's making a clicking noise while trying to start.The vehicle is out in the snow (our complex doesnt have any garages for cars). The mechanic told that the oil leak was very minimal and suggested to do the gaskets(oil filter housing and valve cover) within like 2 months(but this situation is like after 3 weeks and that too because the mechanics did not show up as said). As I said the coolant was topped off during the oil change. I checked the coolant level(knob) last sunday and its very low. I cant understand why everything shows up right after coming back from the oil change and vehicle inspection. As of now this is all the information I have. I will check the oil level today evening. Please guide me if I have to check anything else.
If your coolant is low after 3 weeks, you have a leak somewhere. Don't bother screwing around trying to find it in the cold, just replace the cooling system to be safe. It's ~$350 for parts plus whatever labor if you decide to take it to a shop. If you think that's expensive, you should see how much a new engine/head gasket + install costs...

Quote:
Originally Posted by yash View Post
I wanted to know some things like, these problems are not connected (if anything in the engine activates the fuel shut-off or something like that) etc., If I can know right away about what to fix, I would n't be here. Excuse me guyz, if anyone feels like a ranting
Yes, the rev limiter but I don't think that's the issue here...

Last edited by SamDoe1; 02-22-2012 at 12:02 PM.
SamDoe1 is offline   Reply With Quote
Old 02-22-2012, 01:10 PM   #13
yash
Registered User
 
Join Date: Feb 2012
Location: Columbus
Posts: 6
My Ride: 325xi
Hmm....will update after checking out everything(mainly including the probing of fill neck path) and trying out some DIY stuff......Thanks White Knuckles and Sam......
yash is offline   Reply With Quote
Reply

Tags
325xi, 3series, coolant, e46, fuel

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use