E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-13-2012, 02:15 AM   #1
iwannagofast
Registered User
 
Join Date: Sep 2008
Location: 858/305
Posts: 315
My Ride: 01 330ci
Send a message via AIM to iwannagofast
cold start ok? but when shut off and restarted......

the car will idle lower than normal and when i press the gas too fast the rpm's will drop and the car will want to stall before catching itself.... and sometimes stalling.......

it all started one night a couple months ago when i needed to get gas. the computer said i only had about 6 miles left to drive which was the lowest i have ever taken it. when i pull into the gas station (very cheap gas station) i put 3/4 tank 93 and attempt to restart my car... instantly the car hesitated to turn over and finally would idle really low and want to stall when the throttle was pushed too fast. even when i do pull out of first gear when i let the rpms drop just the slightest bit or when i "blip"the throttle to rev match the engine will "bog" and want to stall.....
i go back to the gas station and ask the guy of maybe there was a mistake with the lines because my car is running really ruff and i put the normal octane in. he says hes not sure and that it could be all 87 for all he knows...(2am and i am not going to argue with obviously just a night employee). get back in my car with it limping all the way home with no codes being thrown. the next day when i attempt to restart my car it starts right up like nothing happened...
i drive around and the car runs great, just like it always has. i go to the store to pick up dinner and after about 20 min i restart my car and it has the problem. I take the car to a indy bmw guy and he says it would throw codes if the fuel pump is faulty or if the fuel filter is clogged.no codes for my o2 sensors or a lean or too rich so no intake leaks. a fuel injector is not sticking or it would throw a code... we hooked it up and ran a scan any ways with nothing popping up.

i take it home with it limping.... attempt to restart it 5-6 hours later and it runs great... i instantly turn it off and restart it and it gets all fukced up. this is pretty much how it is all the time. sometimes when it is problematic and i have to drive it... not only does it want to stall if i get on the gas too quick like a quick "jab" at idle or to rev match at low rpm... but lets say if i am cruising at 25 mph in 2nd around 2500 rpm and i press the clutch quick and let the rpm's fall it will not stop at idle... the car will die... sometimes it will bounce once and then die... and sometimes it will hickup and go back to the ruff idle. I have had it die before on me a couple times while driving it somewhere and while after restarting the car 4 times and the engine has been hot for a while the car will run normal and show no signs of wanting to stall... this has only happened maybe 5 out of 100 stalls

now like i said though if it sits for a couple hours and i start the car it will run great. problematic when i start the car then turn it off and want to start it again within lets say 5 hours....

maybe a bunch of soot from my 130,000 mile tank got into the lines when i ran it that low but then why would it run ok after i let it sit for a couple hours?
i bought a new fuel filter and i am waiting to install it. will do it in the next couple days and report back...

any ideas though e46???? thank you guys


CLIFFS:
-got low on gas
-filled and car ran like shyt...went home
-next morning the car started as if nothing happened
-after getting groceries(20 min), i restart the car and it has its problems
-car will run ok if i let it sit for a couple hours (at least 5?) but will run like crap if i turn it off then on within that couple hour period.
- car throws no codes at all

SYMPTOMS:
- ruff idle
- rpms drop when gas is pressed to hard/fast
-when up to speed and i throw into neutral to let the rpms fall, it will sometimes stall/bounce then stall/ bounce and ruff idle


things i have replaced recently:
-intake boots
-disa/icv

i do have a oem fuel filter that i am going to replace in a day or 2... what other ideas?
__________________

xbox live: stopthisfall

Last edited by iwannagofast; 05-16-2012 at 10:23 AM.
iwannagofast is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 05-13-2012, 02:31 AM   #2
330i ZHP
Registered User
 
330i ZHP's Avatar
 
Join Date: Mar 2005
Location: Washington, DC
Posts: 21,755
My Ride: have 5 doors and FI
Send a message via AIM to 330i ZHP Send a message via Yahoo to 330i ZHP
rough idle - not a barking idle
__________________
/_________\
OO=[][]=OO
330i ZHP is offline   Reply With Quote
Old 05-13-2012, 06:26 AM   #3
j_block
Registered User
 
Join Date: Apr 2011
Location: SA TX
Posts: 1,239
My Ride: 2003 325i
How bout vano seals?

Sent from my SPH-D700 using Bimmer App
__________________
j_block is offline   Reply With Quote
Old 05-13-2012, 03:14 PM   #4
iwannagofast
Registered User
 
Join Date: Sep 2008
Location: 858/305
Posts: 315
My Ride: 01 330ci
Send a message via AIM to iwannagofast
what i have been thinking but wouldn't it throw a code if this many prob... i know i need to do it any ways but i dont want to throw a bunch of money into this thing at this moment to try and guestimate in fixing it.... might have to eventually. figured i would come here. fuel filter change on wed. i cant think of anything that would make my car run ok after it sits for 5 or so hours but then mess up if i try to restart it too soon
__________________

xbox live: stopthisfall
iwannagofast is offline   Reply With Quote
Old 05-15-2012, 01:17 PM   #5
aub
Registered User
 
Join Date: Jun 2007
Location: turkey
Posts: 5
My Ride: BMW 325ti
My 2002 325 has exactly the same problem. It ıs ok when I start at the morning. When I stop for about 5 min to 1 hour and restart the idle falls and sometimes it stalls. After a drive for 15 minutes it changes to normal.
Also another problem is I feel power loss below 3000 rpm. Over 3500 rpm ıt goes like 325 but below 3000 it is like 318
This weekend i will take it to BMW service.
I am thinking as my disa is faulty or ICV and throttle body needs to be cleaned. Or a vacuum leak may be the problem.
Let me know if you find the problem with your car.
aub is offline   Reply With Quote
Old 05-15-2012, 07:13 PM   #6
fastjasonbmw
Registered User
 
Join Date: Sep 2011
Location: CO
Posts: 244
My Ride: 330Xi
Could be a combination of icv and fuel pump.
fastjasonbmw is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 06:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use