E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-22-2012, 10:05 AM   #1
rainrcr32
Registered User
 
Join Date: Jun 2011
Location: North Hollywood
Posts: 82
My Ride: E46 M3
Sequential M Gearbox indicator light

Click image for larger version

Name:	Mbox.JPG
Views:	60
Size:	56.8 KB
ID:	452641

Hello Everyone,
Does anyone know some of the basic issues that happen when this light turns on. I read the Owners Manuel and it says it is my Sequential M Gearbox with Drivelogic. My car drives well still but this light came on and stays on while driving. What are some of the basic issues that occur with this? IS it a big problem $$$$? has anyone had this happen. its a E46 M3 smg


Please help guys,
Robert
__________________
rainrcr32 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 05-22-2012, 09:17 PM   #2
SL Blak Soldier
Registered User
 
Join Date: Oct 2006
Location: Woodland Hills < SFV < LA < SoCal
Posts: 27,358
My Ride: 2001 3 Pedal M54b30
Send a message via AIM to SL Blak Soldier
I can't say i know what the problem is, but i see you're in NoHo, give Mini Corsa a call and they'll be able to read the codes and tell you whats up. let them know Raj sent you.
__________________
SL Blak Soldier is offline   Reply With Quote
Old 05-24-2012, 01:12 AM   #3
lejeunebimmer
Registered User
 
Join Date: Oct 2009
Location: Oakdale, MN
Posts: 778
My Ride: 02' M3 SMG, 02' 330i
Only time I ever saw that light on mine was after about 20 minutes on the track. Gave it some time to cool down, and bam I W's good. So no real help there. Just go to a good Indy and get the code read from the smg software, that'll tell you what the problem is.
__________________
330i - AA Tuned, Headers, UUC Stage I LW FW, e36 M3 Clutch, UUC SS Clutch line, BMW Performance Intake, Evo Sport Pulleys, BMW Performance Cross-Drilled Rotors, Hawk HPS, BW SS Brake Lines, BW Solid Guide Bushings, BMW Performance CF Strut Brace, H&R Sways, H&R Sport Springs, Bilstein Sport Shocks, Powerflex Bushings, LED Tails, Clear Sides/Turns, Black Grill, Mtech 2, CF Splitters


M3 - Not enough room to list
lejeunebimmer is offline   Reply With Quote
Old 05-24-2012, 10:05 AM   #4
rainrcr32
Registered User
 
Join Date: Jun 2011
Location: North Hollywood
Posts: 82
My Ride: E46 M3
thank you very much for all the posts guy!!
I went to the mechanic and had the code read and it said 15-21 and when we looked it up it said something about a relay. then he dismissed the code and never turned on again. The mechanic thinks there might have been a shortage of power from my battery and it probably tripped the indicator on. I'm going to drive it a bit more and see if anything happens. but the car drives perfect still with/without indicator on.

I truly appreciate everyone for helping me out and being so cool!!
Thanks guys
Robert
__________________
rainrcr32 is offline   Reply With Quote
Old 02-11-2014, 12:41 AM   #5
M3 rebel
Registered User
 
Join Date: Dec 2012
Location: Walnut creek
Posts: 5
My Ride: M3
Hi everyone, this light went on in my car but it still drives good - I tried resetting driving at 50 mph. Shift to neutral and pull both paddles but it didn't do anything. I disconnected the battery for about 10 minutes and it didn't reset. I also read about the relay, but I'm not sure where it is- can someone help me with this?
Thank you!


Sent from BimmerApp mobile app
M3 rebel is offline   Reply With Quote
Old 03-19-2014, 10:36 PM   #6
nodnarbyakcam
Registered User
 
Join Date: Jul 2013
Location: Fort McMurray
Posts: 21
My Ride: 2005 E46 M3
Yeah sounds like the relay man. I just went through this with my car. If no codes are coming up for SMG pump pressure or anything its the relay. Super easy fix. Got mine sent to me in 2 days basically plug and play and Viola. Here's the relay you need. It installs in the drug bin.

http://www.ecstuning.com/ES31912/
nodnarbyakcam is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 08:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use