E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-27-2012, 03:16 PM   #1
farukh
Registered User
 
Join Date: Mar 2012
Location: Fort Myers, FL
Posts: 388
My Ride: BMW 325i 2002
Unhappy Engine knocking sounds... Please help!

Hey everyone!
I really need your help guys! Many times I posted my questions on BMW forums and always got the right answers.

Anyway, here is the video where you can hear these strange knocking sounds coming from my 325i 2002 engine:

It started yesterday after I changed the oil, oil filter, fixed valve gasket sealant, changed a boot on first coil and changed all the spark plugs.
The reason I had to open up the gasket is because I had a very bad oil leak into the first coil compartment. Turned out, my last mechanic did not properly place that rubber sealant piece on first three coils. So I fixed it and no more oil there now. Initially the car was misfiring really bad, so I thought that was the problem.

However, now the car misfiring even worse I got the denso irodium sprak plugs from Advance Auto Parts... They said that Bosch were discontinued (weird). Anyway, they told me that the gap in spark plugs should be 0.44, but then I found on the net that it should be only 0.32... I tried both combinations... But still a bad misfire and knocking noise.

And these are the codes that I have:
P0300
P0174
P1085
P1083
P1349
P1353
P1351
P0420

If you anyone had the same problem, please share your experience!
Thanks in advance!
farukh is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 05-27-2012, 03:37 PM   #2
jasonbimmer
Registered User
 
Join Date: Sep 2011
Location: Omaha, NE
Posts: 5,686
My Ride: 2001 BMW 330xi
sounds like a vacuum leak somewhere. the idle is pretty bad.
the knocking sound sounds like DISA or could be the engine backfiring.
also get yourself a set of NGK sparkplugs cuz they are OEM.
__________________
2009 Mazda RX-8 R3
2013 Toyota FJ Cruiser
2008 YAMAHA YZF-R6

Last edited by jasonbimmer; 05-27-2012 at 03:39 PM.
jasonbimmer is offline   Reply With Quote
Old 05-27-2012, 05:14 PM   #3
DDNPresident
Registered User
 
Join Date: Dec 2011
Location: Miami
Posts: 126
My Ride: 2004 325i (E46)
Send a message via AIM to DDNPresident
Vacuum leak if I had to take a guess. Happened to me once when I put on a new lower intake boot and it slipped off a bit. Only time I ever heard a sound like that. I could be wrong but I would check where a MAJOR vac leak could happen.
__________________
DDNPresident is offline   Reply With Quote
Old 05-27-2012, 07:08 PM   #4
farukh
Registered User
 
Join Date: Mar 2012
Location: Fort Myers, FL
Posts: 388
My Ride: BMW 325i 2002
Thanks for your fast responses guys! I just changed the spark plugs to NGKs... but it didn't solve the problem :/

One of the guys at Auto Parts said that it is back firing too... I don't know what that means.. gonna do my research now.

I also suspect that vacuum leak. What are the places where the vacuum leak is possible besides intake boot and intake tube?
farukh is offline   Reply With Quote
Old 05-27-2012, 07:51 PM   #5
jasonbimmer
Registered User
 
Join Date: Sep 2011
Location: Omaha, NE
Posts: 5,686
My Ride: 2001 BMW 330xi
Quote:
Originally Posted by farukh View Post
Thanks for your fast responses guys! I just changed the spark plugs to NGKs... but it didn't solve the problem :/

One of the guys at Auto Parts said that it is back firing too... I don't know what that means.. gonna do my research now.

I also suspect that vacuum leak. What are the places where the vacuum leak is possible besides intake boot and intake tube?
its back firing inside the intake manifold.
mostly either CCV or intake boot.
__________________
2009 Mazda RX-8 R3
2013 Toyota FJ Cruiser
2008 YAMAHA YZF-R6
jasonbimmer is offline   Reply With Quote
Old 05-27-2012, 07:54 PM   #6
brodaiga
Registered User
 
Join Date: Oct 2003
Location: FL
Posts: 1,517
My Ride: 330ci
you didn't drop a bolt somewhere in there right? And what are the error codes, did you look them up?
brodaiga is offline   Reply With Quote
Old 05-27-2012, 10:41 PM   #7
farukh
Registered User
 
Join Date: Mar 2012
Location: Fort Myers, FL
Posts: 388
My Ride: BMW 325i 2002
Quote:
Originally Posted by jasonbimmer View Post
its back firing inside the intake manifold.
mostly either CCV or intake boot.
Excuse my noob question... but what is CCV and where can I find it?
farukh is offline   Reply With Quote
Old 05-27-2012, 10:45 PM   #8
farukh
Registered User
 
Join Date: Mar 2012
Location: Fort Myers, FL
Posts: 388
My Ride: BMW 325i 2002
Quote:
Originally Posted by brodaiga View Post
you didn't drop a bolt somewhere in there right? And what are the error codes, did you look them up?
hehe that was my first reaction to that noise, like wtf did I left in there... But nah, I worked with gasket seals only, and the sounds comes out of the manifold.

I looked up all the codes! Most of them are about misfires. Others point to fuel mixture, vacuum leaks and O2 sensor.

So tomorrow I will definitely get to searching of vacuum leaks... Just wanted to get as many possible places where I can find them.
farukh is offline   Reply With Quote
Old 05-27-2012, 10:46 PM   #9
jasonbimmer
Registered User
 
Join Date: Sep 2011
Location: Omaha, NE
Posts: 5,686
My Ride: 2001 BMW 330xi
Quote:
Originally Posted by farukh View Post
Excuse my noob question... but what is CCV and where can I find it?
search
__________________
2009 Mazda RX-8 R3
2013 Toyota FJ Cruiser
2008 YAMAHA YZF-R6
jasonbimmer is offline   Reply With Quote
Old 05-27-2012, 10:48 PM   #10
brodaiga
Registered User
 
Join Date: Oct 2003
Location: FL
Posts: 1,517
My Ride: 330ci
with all those codes, I put my money on vacuum leak.
brodaiga is offline   Reply With Quote
Old 05-27-2012, 10:51 PM   #11
farukh
Registered User
 
Join Date: Mar 2012
Location: Fort Myers, FL
Posts: 388
My Ride: BMW 325i 2002
Another thing that is really bugging me... Why all these started after my fixes. I mean, if I had this vacuum leak before, why it became this noticeably bad just now after I changed oil, sparks etc... Weird.
farukh is offline   Reply With Quote
Old 05-27-2012, 10:52 PM   #12
farukh
Registered User
 
Join Date: Mar 2012
Location: Fort Myers, FL
Posts: 388
My Ride: BMW 325i 2002
Quote:
Originally Posted by jasonbimmer View Post
search
Just did lol Its an oil separator... Maybe the hose went bad...
farukh is offline   Reply With Quote
Old 05-27-2012, 10:54 PM   #13
jasonbimmer
Registered User
 
Join Date: Sep 2011
Location: Omaha, NE
Posts: 5,686
My Ride: 2001 BMW 330xi
Quote:
Originally Posted by farukh View Post
Another thing that is really bugging me... Why all these started after my fixes. I mean, if I had this vacuum leak before, why it became this noticeably bad just now after I changed oil, sparks etc... Weird.
its BMW. you will never have a problem free car.
__________________
2009 Mazda RX-8 R3
2013 Toyota FJ Cruiser
2008 YAMAHA YZF-R6

Last edited by jasonbimmer; 05-28-2012 at 09:38 AM.
jasonbimmer is offline   Reply With Quote
Old 05-27-2012, 10:56 PM   #14
brodaiga
Registered User
 
Join Date: Oct 2003
Location: FL
Posts: 1,517
My Ride: 330ci
Quote:
Originally Posted by farukh View Post
Another thing that is really bugging me... Why all these started after my fixes. I mean, if I had this vacuum leak before, why it became this noticeably bad just now after I changed oil, sparks etc... Weird.
oh god, how many times did I fix something and in the process discover something else that needs fixing, never ends
brodaiga is offline   Reply With Quote
Old 05-28-2012, 09:32 AM   #15
farukh
Registered User
 
Join Date: Mar 2012
Location: Fort Myers, FL
Posts: 388
My Ride: BMW 325i 2002
Just ordered intake boot and tube from my local dealer! Will go pick them up today and install right away! I hope that will solve my problems
farukh is offline   Reply With Quote
Old 05-28-2012, 09:36 AM   #16
farukh
Registered User
 
Join Date: Mar 2012
Location: Fort Myers, FL
Posts: 388
My Ride: BMW 325i 2002
Quote:
Originally Posted by jasonbimmer View Post
its BMW. you will have a problem free car.
You mean "you will NOT have a problem free car"??? lol
farukh is offline   Reply With Quote
Old 05-28-2012, 09:39 AM   #17
jasonbimmer
Registered User
 
Join Date: Sep 2011
Location: Omaha, NE
Posts: 5,686
My Ride: 2001 BMW 330xi
Quote:
Originally Posted by farukh View Post
You mean "you will NOT have a problem free car"??? lol
just fixed it.
__________________
2009 Mazda RX-8 R3
2013 Toyota FJ Cruiser
2008 YAMAHA YZF-R6
jasonbimmer is offline   Reply With Quote
Old 05-28-2012, 10:43 AM   #18
farukh
Registered User
 
Join Date: Mar 2012
Location: Fort Myers, FL
Posts: 388
My Ride: BMW 325i 2002
Quote:
Originally Posted by jasonbimmer View Post
just fixed it.
Maan... I was hoping... Oh well.

Anyway, I just came from dealership with new intake boots. I really hope this will solve my problem. Also, one weird thing, when I started my car today, it was horrible... and the way to dealership was miserable... Every light my car was almost stalling... But after I left dealership on the way back, it was driving like nothing ever happened. Don't see any logic to that I mean, if that was a leak, wouldn't it drive the same all the time?
farukh is offline   Reply With Quote
Old 05-28-2012, 11:00 AM   #19
Gus330vrum
Registered User
 
Join Date: Mar 2011
Location: atlanta
Posts: 1,347
My Ride: 330ci
Quote:
Originally Posted by farukh View Post
Maan... I was hoping... Oh well.

Anyway, I just came from dealership with new intake boots. I really hope this will solve my problem. Also, one weird thing, when I started my car today, it was horrible... and the way to dealership was miserable... Every light my car was almost stalling... But after I left dealership on the way back, it was driving like nothing ever happened. Don't see any logic to that I mean, if that was a leak, wouldn't it drive the same all the time?
LOL! how much did u pay dealer change your DUE old boots that's cost less then $20 and 10min of your time..

Also it would had been a lot cheaper to clean DISA,ICV with brake cleaner and replace lower+upper boots+ valve cover gasket can cause vaccum leak including then vaccum
Lines running from 2nd air pump to the back manifold
Gus330vrum is offline   Reply With Quote
Old 05-28-2012, 02:02 PM   #20
farukh
Registered User
 
Join Date: Mar 2012
Location: Fort Myers, FL
Posts: 388
My Ride: BMW 325i 2002
Quote:
Originally Posted by mrlatexxx View Post
LOL! how much did u pay dealer change your DUE old boots that's cost less then $20 and 10min of your time..

Also it would had been a lot cheaper to clean DISA,ICV with brake cleaner and replace lower+upper boots+ valve cover gasket can cause vaccum leak including then vaccum
Lines running from 2nd air pump to the back manifold
Hey, I did myself aright! lol I wish I had that much money to just go to dealership and let them fix it all...

But anyway, you guys want to laugh? I found the damn problem. The cover gasket is missing one of the bolt/studs with rubber thingy. So it is sucking in the air like crazy. Do you guys know any place online where I can buy it? Or part number?
farukh is offline   Reply With Quote
Reply

Tags
engine, knocking, noise

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use