E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 06-09-2012, 05:21 PM   #1
FightingSioux
Registered User
 
Join Date: Jun 2012
Location: GA, USA
Posts: 6
My Ride: 2005 330Ci
Exclamation 05 330ci headlight out

My recently purchased 05 330ci has stock HID xenon with autolevel and the lights turn when I turn (whatever that is called). Driver side low and high went out with error light on the dash and fog lights came on automatically. Took to dealer and they swapped xenon lamp control modules (ballast?) between driver and passenger side. Now passenger side was out but driver side was working, confirming xenon Control module (ballast) problem. They wanted $1,000 for new module and labor. Found posts on here to DIY, ordered used part and have done the following:

Driver side was working and passenger side was out when I left the dealer and started the below process.

Put new Control part on passenger side. It works fine and error on dash is gone but immediately the driver side is now out and has the error on dash. I didn't touch the driver side at all and it was working up to the point I put the part on the passenger side.

Swapped current Modules between driver and passenger side but driver side still out and passenger works. Both Modules work on passenger, neither on driver.

Swapped igniters and both work on passenger, neither on driver.

Installed new bulbs, passenger works, driver still out.

Every component seems to work on passenger side, but nothing on driver side.

Checked fuse 9 and 32, both seem fine.

Is there an error code or setting that needs to be reset in the electronics? If so why did the passenger side work after I replaced the original bad Module?

Sorry for the long post, but wanted to give as much info as possible.

Thanks for your help.

Last edited by FightingSioux; 06-09-2012 at 09:33 PM. Reason: Changed part terminology
FightingSioux is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Tags
ballast, hid, light, module, xenon

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use