E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 06-27-2012, 09:34 PM   #1
BusinessDrive
Registered User
 
Join Date: Jun 2012
Location: Canada
Posts: 9
My Ride: 2003 325i
Exclamation Red Oil Pressure Light

I'm having some difficulties with my 2003 325i sedan. The car has almost 90,000 miles on it and recently the red oil pressure light came on while idling at a red light. The light would turn off once I accelerated. I've done a lot of searching on here but don't know what else to do. I brought the car into my local BMW dealership and had they performed a pressure test ( results came back that pressure was good). They said I needed a new oil pressure sensor (located in the engine). I replaced the sensor, however, the light came on the first time I drove it a few days later. I noticed the light only comes on when the car is idling in Drive or Reverse and that the RPMs seem to be hovering around the 500-550 mark at this time. If I put the car in Park the RPMs increase slightly and the light goes out. I called the dealership again and they want me to bring it back in to be examined again. They mentioned it could be another sensor located in the oil pan? Im just wondering whether or not it is just the ICV. Any suggestions?

Last edited by BusinessDrive; 06-27-2012 at 09:40 PM.
BusinessDrive is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Tags
engine, light, oil, pressure, red

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use