E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-15-2005, 01:17 PM   #1
RDrewes
Registered User
 
Join Date: Dec 1969
Posts: 6
330Ci Steptronic shifter problem

My '01 330 Ci Steptronic shifter has become difficult to shift from park into drive. It want to stick in the neutral position. It is possible to place it in drive, but only after nudging it to the left. A little too much nudging ends up in the sport manual mode. Is it out of adjustment or is there a part that needs replacing?
__________________
x
RDrewes is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-15-2005, 02:05 PM   #2
jpm330ci
Registered User
 
Join Date: May 2004
Location: Guatemala
Posts: 514
My Ride: 2005 e53 X5 4.8is
u should have it checked asap...
__________________
jpm330ci is offline   Reply With Quote
Old 07-09-2012, 03:38 PM   #3
steveybrown
Registered User
 
Join Date: Jun 2012
Location: NC
Posts: 47
My Ride: 325i
I just found you're old post. Did you ever get the problem fixed. Mine does the same and inside a small white circular thing looked broken. I'm not sure if that's 100% the issue or just coincidence. Seams to be the problem to me
__________________
Projects still left to complete




Coils and o2 sensors
wheel bearing
Control arm bushings
Oil pan gasket
New working remote key
steveybrown is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use