E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-17-2012, 11:47 AM   #1
AMPGE46
Registered User
 
Join Date: Jul 2012
Location: Tinton Falls
Posts: 3
My Ride: 1999 328i
Need some help

Need some help here

First off, I own a 1999 328i. 197k miles. Love the car

Here's the problem. When I started it a few days ago, it idled rough for about a half minute and the check engine light came on. After the 30 seconds it settled down and ran smooth again, and didn't become rough. The check engine light stayed on, however, and is still on. I stopped after about 10min of driving to pop the hood and check for any visual problems and just do a quick inspection. Nothing. The EML light flashed on during ignition when i turned it back on, which i think is normal, but aside from that and the check engine light I've had no other warning lights since.

Does this pose a significant problem or just is it just a product of the car being 17 years old, and if it is a problem, does anyone know what the cause is? If I need to take it in I'd like to be armed with some information.

Thanks

Last edited by AMPGE46; 07-17-2012 at 01:35 PM. Reason: Added more info
AMPGE46 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Reply

Tags
328i, mechanical, rough idle, startup

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use