E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-18-2012, 03:57 PM   #1
ayashifx55
Registered User
 
Join Date: Jun 2012
Location: Canada, Montreal
Posts: 35
My Ride: M3 01
Rear knocking noise ?? (Not RTABSor subframe ...)

Hello everyone,

About a two months ago , i had my RTABS replaced with m3 oe bushings because i searched around the forum for this problem.The mechanic said it was indeed the rtabs and my subframe was in perfect condition but he still suggested a reinforcement kit ..... now today , when i tried to reverse from my parking (goes up a bit to the street), it knocks a bit , from the rear left. Also knocks when i try to turn either left or right ?? It's not the transmission bushings because it only happens when i turn or take slight bumps. Heavy bumps will not make this noise. Has to be like a 80-90 degree turn i think.

Shocks are 1 year old bilsteins but i saw the end of the rear right spring broke off , can it cause this ? I am about to replace the springs with some h&r's.

The car still turns by itself toward left if i brake hard (But i replaced the RTABS !!)

Thank you for your suggestions everyone.

Last edited by ayashifx55; 07-18-2012 at 04:02 PM.
ayashifx55 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-18-2012, 04:02 PM   #2
ShootyzGruve
Registered User
 
Join Date: Dec 2011
Location: MA
Posts: 140
My Ride: 2003 325i
Have you checked the RSMs?
ShootyzGruve is offline   Reply With Quote
Old 07-18-2012, 04:03 PM   #3
Gus330vrum
Registered User
 
Join Date: Mar 2011
Location: atlanta
Posts: 1,319
My Ride: 330ci
Quote:
Originally Posted by ayashifx55 View Post
Hello everyone,

About a two months ago , i had my RTABS replaced with m3 oe bushings, he showed me they were finished.The mechanic said my subframe was in perfect condition but he still suggested a reinforcement kit ..... now today , when i tried to reverse from my parking (goes up a bit to the street), it knocks a bit , from the rear left. Also knocks when i try to turn either left or right ??

Shocks are 1 year old bilsteins but i saw the end of the rear right spring broke off , can it cause this ? I am about to replace the springs with some h&r's.

The car still turns by itself toward left if i brake hard (But i replaced the RTABS !!)

Thank you for your suggestions everyone.
Yes the cause is your spring,

Do not use H&R spring ! Its harsh on shocks ... kills it quickly!

Try eibach-pro kit spring.

Go ahead and take out shock on spring broken side & check it by compressing and see if it comes back up
Gus330vrum is offline   Reply With Quote
Old 07-18-2012, 04:05 PM   #4
aggieE46
Keep it clean
 
aggieE46's Avatar
 
Join Date: Aug 2006
Location: Royse City
Posts: 8,037
My Ride: 03 Evo, 07 Passat
Send a message via AIM to aggieE46
Have you checked the differential bushings? Mainly the big one in the rear.
__________________
aggieE46 is offline   Reply With Quote
Old 07-18-2012, 04:05 PM   #5
ayashifx55
Registered User
 
Join Date: Jun 2012
Location: Canada, Montreal
Posts: 35
My Ride: M3 01
Quote:
Originally Posted by mrlatexxx View Post
Yes the cause is your spring,

Do not use H&R spring ! Its harsh on shocks ... kills it quickly!

Try eibach-pro kit spring.

Go ahead and take out shock on spring broken side & check it by compressing and see if it comes back up
too late , i bought them already from this forum's member lol. Should be fine since i have aftermarket shocks.

though its the rear that makes the noise and the broken spring is on the rear right.

How do i know if the differential bushings and RSM are bad? Yes it does make noise when i change speed.

Last edited by ayashifx55; 07-18-2012 at 04:09 PM.
ayashifx55 is offline   Reply With Quote
Old 07-18-2012, 07:55 PM   #6
doggy
Registered User
 
Join Date: Oct 2011
Location: london
Posts: 216
My Ride: 330ise
if you see cracks in rubber of diff bush, it needs changing
to check RSM, take off top nut and washer off shock and look for liquid leak
did you get alignment after changing RTAB?
__________________
doggy is offline   Reply With Quote
Old 07-18-2012, 08:06 PM   #7
Pawley
Registered User
 
Join Date: Jul 2011
Location: Adelaide
Posts: 46
My Ride: 2001 330Ci
I had the exact same thing recently - backing out of driveway (downhill) would produce a clunk from rear left.
Stuck my head underneath to see that the rear sway bar link was detatched from the sway bar.
These are rubber units that simply push onto the sway bar.
Pawley is offline   Reply With Quote
Old 08-10-2012, 03:31 AM   #8
J LAU
Registered User
 
Join Date: Feb 2008
Location: SoCal / HK
Posts: 174
My Ride: 325i
I have the same problem!!!!
what's the cure!????
J LAU is offline   Reply With Quote
Old 08-10-2012, 08:58 AM   #9
ayashifx55
Registered User
 
Join Date: Jun 2012
Location: Canada, Montreal
Posts: 35
My Ride: M3 01
Turns out both rear springs were broken , i changed all springs for lowering springs and haven't got thee sound anymore. Im also changing the FCAB for some powerflex
ayashifx55 is offline   Reply With Quote
Old 08-24-2012, 06:41 AM   #10
J LAU
Registered User
 
Join Date: Feb 2008
Location: SoCal / HK
Posts: 174
My Ride: 325i
Quote:
Originally Posted by ayashifx55 View Post
Turns out both rear springs were broken , i changed all springs for lowering springs and haven't got thee sound anymore. Im also changing the FCAB for some powerflex
Th
Do u have pics of the broken springs?
I just recently changed to the Eibach pro-street S coilovers which is pretty much the same as KW V1 but with Eibach springs.
It shoooould not be the springs in my case but I'm not sure. I want to get that checked out to just in case.
J LAU is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use