E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

 
 
Thread Tools Search this Thread Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
Prev Previous Post   Next Post Next
Old 07-25-2012, 03:21 PM   #1
Sk8orkidd
Registered User
 
Join Date: Jul 2012
Location: Orlando, FL
Posts: 10
My Ride: 2003 BMW 325ci
Exclamation EML Light Issue

I recently bought a 2003 325 ci with about 120k on it. I am a very mechanically inclined person, so I normally do all the work on my cars myself. I was driving the bimmer for about 6 hours after purchasing when the EML light turned on. I did a lot of forum research trying to figure out what it was. I took it to Advanced auto parts to have the codes run, and they told me it was the idle control valve. I took that out, cleaned it, replaced it. The EML light comes on, usually at lower speeds at this point, but turns off every time you shut the car off. it doesn't turn on when the car is sitting still, only when moving. I took it to a Eurosport shop then, and they told me the same thing, saying that the Idle control valve had thrown 261 error codes since the last reset. They said the best route was to replace the valve. I bought a new valve and just replaced it yesterday. About 24 hours later when going to lunch today, the EML light turns back on. I am rather confused on what this could be. If anyone else has this problem, maybe there is a common issue?
Sk8orkidd is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Tags
325i, emission, eml, error code

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use