E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 4 votes, 5.00 average. Display Modes
Old 06-29-2009, 01:20 PM   #41
jbeurotech
Regional Sponsor
 
Join Date: Aug 2006
Location: New Brighton MN
Posts: 5,019
My Ride: 2000 E46 with 254K
Quote:
Originally Posted by ShaitanCR View Post
THANKS...

UPDATE 2 :

My battery died. got a new one (free)

Found out that the module messing around with the K-BUS was the info/emergency one (doors opened indicator on dash) unplugged it, and now everything is working fine.

radio
mirrors
sunroof
a/c
lights
seatbelt light
blinker lights
etc, etc

thanks for the help

Cool So much Better that cutting a wire. Now you know which module to replace!!!
__________________

Seth Thorson
Service Manager/BMW Tech
JB Eurotech Service "Your Reasonable Dealer Alternative"

General Questions can be sent to appointment@jbeurotech.com

1. Do not argue with an idiot. He will drag you down to his level and beat you with experience.
2. Light travels faster than sound. This is why some people appear bright until you hear them speak.
jbeurotech is offline   Reply With Quote
Old 06-30-2009, 02:37 PM   #42
ShaitanCR
Carbon Fiber Member
 
ShaitanCR's Avatar
 
Join Date: Apr 2009
Location: CA
Posts: 705
My Ride: 2001 / 330i
Send a message via MSN to ShaitanCR
Quote:
Originally Posted by jbeurotech View Post
Cool So much Better that cutting a wire. Now you know which module to replace!!!
actually... I found out later that the A/C was not blowing cold. so i went back to the cables and to my deslike, the A/C compressor cable must be connected to another cable which makes the doors not open with the key buttons. and at the same time to have both those they must be connected to one of the radio cables that makes the radio stay on.

soooooooooo. I am back to step one. put the k-bus back together and am with no radio.

I wish their was a eurotech shop on SoCal.

thanks for all your help. I feel better now knowing allot more, and with all the little BMW perks back in the car.
__________________

************! STEPTRONIC ALL THE WAY...
*SPL Car Audio Champion*
Hamann EURO Black Shadowline Grills
Black EURO 330i emblem
Carbon Fiber Hamann Style Eyelids
Carbon Fiber Emblems
Clear Turn Lights and Sidemarkers
ShaitanCR is offline   Reply With Quote
Old 06-30-2009, 02:46 PM   #43
jbeurotech
Regional Sponsor
 
Join Date: Aug 2006
Location: New Brighton MN
Posts: 5,019
My Ride: 2000 E46 with 254K
Quote:
Originally Posted by ShaitanCR View Post
actually... I found out later that the A/C was not blowing cold. so i went back to the cables and to my deslike, the A/C compressor cable must be connected to another cable which makes the doors not open with the key buttons. and at the same time to have both those they must be connected to one of the radio cables that makes the radio stay on.

soooooooooo. I am back to step one. put the k-bus back together and am with no radio.

I wish their was a eurotech shop on SoCal.

thanks for all your help. I feel better now knowing allot more, and with all the little BMW perks back in the car.
Sounds like your cluster is causing you the issue. If you have a good indy near you you may want to have them recode the cluster and IHKA and see if that fixes your issue it won't hrt to try for 50-60
__________________

Seth Thorson
Service Manager/BMW Tech
JB Eurotech Service "Your Reasonable Dealer Alternative"

General Questions can be sent to appointment@jbeurotech.com

1. Do not argue with an idiot. He will drag you down to his level and beat you with experience.
2. Light travels faster than sound. This is why some people appear bright until you hear them speak.
jbeurotech is offline   Reply With Quote
Old 06-30-2009, 05:27 PM   #44
ShaitanCR
Carbon Fiber Member
 
ShaitanCR's Avatar
 
Join Date: Apr 2009
Location: CA
Posts: 705
My Ride: 2001 / 330i
Send a message via MSN to ShaitanCR
Quote:
Originally Posted by jbeurotech View Post
Sounds like your cluster is causing you the issue. If you have a good indy near you you may want to have them recode the cluster and IHKA and see if that fixes your issue it won't hrt to try for 50-60
good idea. will do ! thanks for the tip
__________________

************! STEPTRONIC ALL THE WAY...
*SPL Car Audio Champion*
Hamann EURO Black Shadowline Grills
Black EURO 330i emblem
Carbon Fiber Hamann Style Eyelids
Carbon Fiber Emblems
Clear Turn Lights and Sidemarkers
ShaitanCR is offline   Reply With Quote
Old 06-01-2011, 10:01 AM   #45
zmster2033
Registered User
 
Join Date: Apr 2007
Location: Clemmons
Posts: 16
My Ride: Car was stolen
I am having issues with the K-Bus and am having difficulties finding the exact culprit. I can get to step #31 with my eyes closed by now. However, I am having difficulties taking the connectors out of the black "sleeve". Any suggestions on how to do so? When I look at it it appears there are little black tabs on the sleeve but when I push those in and attempt to pull out the wires it does not work.
zmster2033 is offline   Reply With Quote
Old 08-09-2012, 10:48 AM   #46
a13x
Registered User
 
Join Date: May 2009
Location: Romania
Posts: 34
My Ride: E46 320i
Please, I need help...

What is the k-bus wire of sunroof? Anyone knows?
I have installed a sunroof on my E46. (the car came from the factory without sunroof).
I replaced all it needs to instal the sunroof (The roof, the GM5 module, etc...)

It is a wire White/Red/Yellow and I don't know where I can connect it on the K-bus.
Thanks a lot!
Attached Thumbnails
Click image for larger version

Name:	09082012112.jpg
Views:	73
Size:	89.8 KB
ID:	464180  
__________________

BMW E46 320i M54B22
a13x is offline   Reply With Quote
Old 08-10-2012, 07:08 PM   #47
boatshoe
Registered User
 
Join Date: Feb 2012
Location: Rhode Island
Posts: 279
My Ride: '03 330xi
Great pictures and useful thread to the few of us this with this problem. Jbeurotech's old thread really helped me out...mine turned out to be rain sensor module and the problem seemed to be rain-activated for me. Hopefully it was simply a loose connection because unplugging the module and plugging it back in seemed to fix the issue for me. I just wish these pictures were around when I was messing with mine!
__________________
boatshoe is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use