E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-12-2012, 08:17 PM   #1
Mr.Miller
Registered User
 
Join Date: Aug 2012
Location: NYC
Posts: 53
My Ride: Bmw m3
Business radio problem?

Hello my fellow M3 enthusiast. My name is Mr.Miller and I'm having an radio problem and i cant seem to fix it. First i would give history this is the standard radio not the navigation i search this forum but didn't seem to find anything relative to my problem most radio problems are from navigation. Anyway it started with two days ago i was listening to music and accidentally hit the speaker bottom on my steering wheel( the button below the r/t button). I immediately tried to turn it off by holding the r/t bottom, then tried turning it off by holding the speaker bottom but it didn't seem to work. So i restarted my battery and reset my time thinking it would work but it didn't. Now it seems like my radio isn't working correctly non of the bottoms on my radio are functioning. :jawdrop:. Only one buttom works on my radio which is the r/t buttom and it just switches two setting the time and then phone-book E.
here is some pictures of my radio and what it display. I already took the fuse out and restarted it still didnt work. Today i took out the radio to see if the plugs were connected and still doesn't work. Has this happen to anyone

when i press the r/t bottom this is what it displays

here the r/t bottom on the steering wheel

Last edited by Mr.Miller; 08-17-2012 at 10:55 AM.
Mr.Miller is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-12-2012, 08:19 PM   #2
Mr.Miller
Registered User
 
Join Date: Aug 2012
Location: NYC
Posts: 53
My Ride: Bmw m3
this thing is getting frustrating idk what to try any radio heads i can bring it to besides dealership im located in nyc. i want to upgrade to navi but i want to make sure everything is good im going to see if i can switch radio with my friend
Mr.Miller is offline   Reply With Quote
Old 08-17-2012, 04:44 AM   #3
RichardP
Registered User
 
Join Date: Nov 2004
Location: England
Posts: 304
My Ride: M5
The radio appears to be stuck in Phone mode. That's pretty odd if you don't have a phone module installed in the car. You enter phonebook mode using the R/T key but this only works if there is a phone module installed. The control is all done via iBus messages so it's not something simple like a stuck button. Do you have an after market phone system installed in the car?

By the way, it's 'button', not 'bottom'! Bottom = Butt.
RichardP is offline   Reply With Quote
Old 08-17-2012, 11:02 AM   #4
Mr.Miller
Registered User
 
Join Date: Aug 2012
Location: NYC
Posts: 53
My Ride: Bmw m3
Quote:
Originally Posted by RichardP View Post
The radio appears to be stuck in Phone mode. That's pretty odd if you don't have a phone module installed in the car. You enter phonebook mode using the R/T key but this only works if there is a phone module installed. The control is all done via iBus messages so it's not something simple like a stuck button. Do you have an after market phone system installed in the car?

By the way, it's 'button', not 'bottom'! Bottom = Butt.
Not to my knowledge i don't think i have an aftermarket phone system installed in my car. I already tried reseting the fuse, the battery i took the radio out to make sure everything was in place and it was. how can i check if there an after market phone system installed
Mr.Miller is offline   Reply With Quote
Old 08-17-2012, 06:38 PM   #5
haurelio
Registered User
 
Join Date: Apr 2008
Location: New Jersey
Posts: 1,040
My Ride: 2001 bmw 325i
try resetting the radio. this video shows that country code, but scroll to the right setting

haurelio is offline   Reply With Quote
Old 08-17-2012, 11:56 PM   #6
Mr.Miller
Registered User
 
Join Date: Aug 2012
Location: NYC
Posts: 53
My Ride: Bmw m3
Quote:
Originally Posted by haurelio View Post
try resetting the radio. this video shows that country code, but scroll to the right setting

Just tried reseting holding the m button down. But there was no response at all. I really don't understand what's wrong with this thing and if I buy another radio I feel it might do the same thing
Mr.Miller is offline   Reply With Quote
Old 08-18-2012, 12:18 AM   #7
Mr.Miller
Registered User
 
Join Date: Aug 2012
Location: NYC
Posts: 53
My Ride: Bmw m3
I read on google somewhere this problem might be called Phone mode sometimes the radio gets stuck on phone mode but previous post I read people had some controls of the radio I don't. But I read somewhere that said I can reset the telephone fuse and see of that works
Mr.Miller is offline   Reply With Quote
Old 08-18-2012, 02:01 PM   #8
Mr.Miller
Registered User
 
Join Date: Aug 2012
Location: NYC
Posts: 53
My Ride: Bmw m3
i just took the telephone fuse out still no good might have to try a new radio
Mr.Miller is offline   Reply With Quote
Old 02-09-2013, 07:47 PM   #9
monkeyhead
Registered User
 
Join Date: Dec 2011
Location: Los Angeles
Posts: 128
My Ride: 2003 330i
I had the same problem, radio was stuck on "phone" I just took out both radio fuses 7, 41, turned key to position one to make sure radio was dead. Took key out. Then i put both fuses back, turned key back to position one and walla, radio is back to normal.
__________________

see one, do one, teach one
monkeyhead is offline   Reply With Quote
Reply

Tags
radio issue

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use