E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-18-2012, 12:24 AM   #1
mike0593
Registered User
 
Join Date: Aug 2012
Location: New Jersey
Posts: 15
My Ride: 2002 bmw
trying so hard to fix this problem. Help!

Hey guys im new to this particular forum but im gunna get right down to it. I own a 2002 325ci supercharged by active autowerke. Ive come across a serious problem. my car Boggs really hard from 2800 rpms on (although it varies in some gears) it Boggs out and after i restart the car it stalls out at low rpms. I can barely make it up hills without down shifting to get power at least 3 Times. I automatically assumed vacuum leak, i had that fixed along with replacing the 02 sensors same problems. I got fault code p0340 intake cam position sensor i thought that was surely it, replaced both cam sensors still the problem remains. im exausting all options the only thing i can still think is the MAF any ideas guys PLEASE HELP!!
mike0593 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Reply

Tags
bogging, loss of power, maf sensor, stalling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use