E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-26-2012, 07:15 PM   #1
max2378
Registered User
 
Join Date: Apr 2005
Location: Grand Prairie, Tx.
Posts: 13
My Ride: 2001 BMW 330CI
Send a message via Yahoo to max2378
Please Help Rough Idle car stalls

I have a 2001 330ci. I have replaced the vanos, all the hoses, spark splugs, and the DISA. Prior to replacing the DISA the car did not shake as bad. It was able to stay on and for the most part function. My mechanic has stated that the DISA needed to be replaced so i went ahead and did so. From that point on the car is really rough. The peake codes I get are F3, EF and F1 which are misfiring for cylinders 2,4, and 6. I went ahead and purchased the coils and no change what so ever. I ensured that I reconnected all the sensors I unplugged when installing the DISA ( MAF and DISA). I have searched online extensively and can't seem to find a solution. Can someone please provide me with any feedback. Am I missing something?

Thanks in advance,
max2378 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-26-2012, 07:26 PM   #2
Jagean
Registered User
 
Join Date: Aug 2012
Location: Florida
Posts: 24
My Ride: 2001 BMW 325i
I found a little something, may help. not sure.

Quote:
Originally Posted by BWMguy206 View Post
Yes! If the orange seal goes bad you will get a really bad vacuum leak. You will have mixture faults for running too lean and the car will run very rough at idle to the point where it will be misfiring. If you keep driving like this the misfire faults will cause the DME to shut down a cylinder.
Source:
http://forum.e46fanatics.com/showthread.php?t=611798
Jagean is offline   Reply With Quote
Old 08-26-2012, 07:42 PM   #3
JasonSmithed
Registered User
 
Join Date: Jul 2012
Location: University of West Ga
Posts: 303
My Ride: 00 323i
Injectors? Coil?
__________________
JasonSmithed is offline   Reply With Quote
Old 08-26-2012, 07:53 PM   #4
max2378
Registered User
 
Join Date: Apr 2005
Location: Grand Prairie, Tx.
Posts: 13
My Ride: 2001 BMW 330CI
Send a message via Yahoo to max2378
Thanks Jagean I will definitely look into that....

Smith I did check the coils out and they are fine, no injectors codes

Sent from my SPH-L710 using Bimmer App
max2378 is offline   Reply With Quote
Old 08-26-2012, 08:19 PM   #5
Teddy7
Registered User
 
Join Date: Mar 2009
Location: Orlando, Florida
Posts: 942
My Ride: slides
Make sure every last one of your electrical connectors are plugged back in. People often leave one or two unplugged and always come here asking why they are stalling and experiencing rough idle. Just an idea. Good luck.
__________________
Teddy7 is offline   Reply With Quote
Old 08-27-2012, 01:22 AM   #6
MJLavelle
Registered User
 
Join Date: Jul 2011
Location: Charlotte NC
Posts: 2,753
My Ride: 2001 BMW 330ci
How old is your fuel filter and fuel pump? I was getting rough starts and really rough idle, and a new fuel filter cleared that right up. I have since installed a new fuel pump as well. Just a possibility....
MJLavelle is offline   Reply With Quote
Reply

Tags
disa, idle, ignition coils, misfiring

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use