E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-26-2012, 11:59 PM   #1
E46er75
Registered User
 
Join Date: Aug 2011
Location: New England
Posts: 298
My Ride: 323i Vert, 330xi
Rough idle vibration when cold//No CEL

Tis the season. I remember towards the end of last year I started to notice a rough idle when it was getting cold. I notice it mostly when I'm sitting at a light or in a drive thru while in gear. Anyone else have this problem? I'm wondering it is the motor mounts?

Last edited by E46er75; 09-27-2012 at 12:02 AM.
E46er75 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-27-2012, 05:14 AM   #2
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 9,346
My Ride: '06 330CiC, '03 M5
Suggest you check the first link below in my signature.

I would focus on the DISA, DISA O-ring & CCV lower oil return hose that connects to the dipstick tube.

There may be other areas or things to check, but the above are the most common culprits.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is online now   Reply With Quote
Old 09-27-2012, 09:40 AM   #3
E46er75
Registered User
 
Join Date: Aug 2011
Location: New England
Posts: 298
My Ride: 323i Vert, 330xi
Yup, already read this. Great write up, but I have no CEL and for the most part all parts mentioned have been replace. The only piece not replaced was the intake boot, but it's still in good condition with no visible tears or holes.
E46er75 is offline   Reply With Quote
Old 09-28-2012, 06:24 AM   #4
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 9,346
My Ride: '06 330CiC, '03 M5
No CEL does not mean you do not have vacuum leaks, maybe not be enough to trigger the CEL? Does the CEL work with a bulb check? Have you checked codes?

Could be soft fail fuel pump? Might want to perform wet & dry compression check and cylinder leakage test as well to rule out burnt valves?
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is online now   Reply With Quote
Old 09-28-2012, 08:27 AM   #5
moiz21
Registered User
 
Join Date: Oct 2010
Location: Silver Spring, MD
Posts: 1,413
My Ride: 1999 323i 5-SPD
May also want to look into the VANOS seals. My brother had some cold start issues and idling fluctuation before I changed it as well.
__________________

MODS
P46 Projectors + FX-R Retrofit + 6k D2S / 60 LED AE's / Smoked LED Tails / Smoked Turn and Side Markers / BSW 10" Sub /ZHP Knob / Matte Black Grills / DICE / Parrot + Connects2 / OEM Alternative Alarm Mod / Clutch Switch Delay Mod / M3 Rep Front Bumper / 3M Black CF Di-Noc Wrap / K&N Intake / 35% Tint All Around / Black Short Eurotray / 545i Shifter
moiz21 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use