E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-27-2012, 11:30 PM   #1
biMMer4.4i
Registered User
 
Join Date: Jan 2012
Location: Cincinnati, Ohio
Posts: 274
My Ride: 2002 330i
2002 330i Headlight trouble

Bought the car a little over two weeks ago without a working xenon on the drivers side. Replaced the bulb (old one looked burned) but still didn't work. The following weekend the bulb was taken out again to look for loose connections. Still nothing. The car then sat for two days until I drove it today and the drivers side came on, and brighter worked too. It did look to be more of a yellow light than a xenon blue light though but still bright. The replacement bulb was identical to the original. Where am I going wrong? Any help is greatly appreciated.

Sent from my PC36100 using Bimmer
biMMer4.4i is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-28-2012, 12:06 AM   #2
Toofpik
Registered User
 
Join Date: Apr 2010
Location: Miami, FL
Posts: 93
My Ride: 2002 325ci
Does ur passenger light work fine? If so swap the bulbs and see what happens. Im no xenon expert but i did this when i had my old 330i and the passengers side was brighter and off color with both bulbs. A week later it just stopped working so i took it out and found out that water had got inside the balast and ruined it.
__________________

Last edited by Toofpik; 01-28-2012 at 12:07 AM.
Toofpik is offline   Reply With Quote
Old 09-30-2012, 12:12 PM   #3
mpower009
Registered User
 
Join Date: Nov 2008
Location: TC, MN
Posts: 343
My Ride: Tial Of Dragon
Quote:
Originally Posted by Toofpik View Post
Does ur passenger light work fine? If so swap the bulbs and see what happens. Im no xenon expert but i did this when i had my old 330i and the passengers side was brighter and off color with both bulbs. A week later it just stopped working so i took it out and found out that water had got inside the balast and ruined it.
Hello Toofpik, I believe my Xenon headlights have the same issue as your situation. Here is my car symthom, only passenger side doesn't work. So I replaced to brand new bulb and still it doesn't work. Is this mean the balast is shot?

Thanks!
__________________
LET'S ROLL
mpower009 is offline   Reply With Quote
Old 09-30-2012, 12:21 PM   #4
98bimmer
Registered User
 
Join Date: Nov 2008
Location: Toronto, Canada
Posts: 568
My Ride: E90 330i, E36 328i
If its not the bulb its either the ballast or igniter, if its the igniter you have to take your lights apart to replace them. I believe for the ballast you don't need to but don't quote me on that! Switch those around and that will answer your questions!
__________________
98bimmer is offline   Reply With Quote
Old 01-04-2014, 05:41 PM   #5
gavi
Registered User
 
Join Date: Apr 2012
Location: Los Angeles, CA
Posts: 168
My Ride: BMW 330Ci sport 6MT
HI I have the same problem, have you guy got it solved? what was it?
__________________
A BMW can't take you as far as a diploma.
Joyce Meyer
gavi is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use