E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > New Member Introductions

New Member Introductions
New members check-in, introduce yourselves, and post a picture of your BMW here!

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-30-2012, 08:05 PM   #1
kevinne4601
Registered User
 
Join Date: Sep 2012
Location: quincy, ma
Posts: 2
My Ride: 2001 325i, carrera 2
e46 rookie

Hi everyone. Just got a used 2001 bmw 325i, black 60k. First time owning a e46. already service light on. camshaft position sensor a,b and thermostat. mechanic said fixing the cps would not turn off the service light. He recommend fixing the waterpump and the thermostat. A little confuse on the whole thing. nothing is leaking. the temp. is in the middle of the gauge. Drives fine. He just reset the light. please advise. Thanks
kevinne4601 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-30-2012, 08:07 PM   #2
j_block
Registered User
 
Join Date: Apr 2011
Location: SA TX
Posts: 1,239
My Ride: 2003 325i
Depends on what is triggering the engine light. Go check it. Also welcome to the forums

Sent from my SPH-D700 using Bimmer App
__________________
j_block is offline   Reply With Quote
Old 10-04-2012, 10:21 AM   #3
Solidjake
Zero. Oil. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 22,210
My Ride: 2002 330i
Give us the exact error code numbers.

Change the thermostat with a Behr or Wahler unit that will cost around 45-50.

As for the camshaft sensor give us the code so we can tell you if it's intake or exhaust. For those sensors you MUST get OEM.
Solidjake is offline   Reply With Quote
Old 10-04-2012, 01:52 PM   #4
kevinne4601
Registered User
 
Join Date: Sep 2012
Location: quincy, ma
Posts: 2
My Ride: 2001 325i, carrera 2
Thank you so much!
kevinne4601 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use