E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-02-2012, 06:05 PM   #1
Caden
Registered User
 
Join Date: Feb 2012
Location: Texas
Posts: 328
My Ride: '01 325i
Tires replaced at discount tire, now dsc and yellow brake light are on.

Just replaced my two front tires and balanced the back two. Right after I left discount tire I realized my DSC Light and the yellow brake light were on. What could be causing this? Could they have broke something?

SES light not on or any other lights.

Last edited by Caden; 10-02-2012 at 07:06 PM.
Caden is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-02-2012, 06:09 PM   #2
Mango
Over 15,000 visitors
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 22,529
My Ride: M54B30
If the DSC control unit senses a 2% (or is it 2mph?--i forget) difference in rotation speed between the two axles, the DSC light could illimunate. Yours must be so extreme that the system has disabled itself. how big of a difference in tire wear? same tire type AND size? more info please
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is offline   Reply With Quote
Old 10-02-2012, 06:16 PM   #3
Caden
Registered User
 
Join Date: Feb 2012
Location: Texas
Posts: 328
My Ride: '01 325i
Different tires. Same specs. 225-40-zr18. Back tires are 245-40zr18
Caden is offline   Reply With Quote
Old 10-02-2012, 06:56 PM   #4
Zell
Registered User
 
Zell's Avatar
 
Join Date: Jun 2009
Location: Such City
Posts: 5,641
My Ride: '02 Dogemobile Shibe
They messed something up. Bring it back.
__________________
Zell is offline   Reply With Quote
Old 10-02-2012, 06:59 PM   #5
absolutegtr
Registered User
 
Join Date: Sep 2006
Location: Charleston, SC
Posts: 69
My Ride: Alpine White e39 M5
Should you have 245/35 rears?
absolutegtr is offline   Reply With Quote
Old 10-02-2012, 07:03 PM   #6
Caden
Registered User
 
Join Date: Feb 2012
Location: Texas
Posts: 328
My Ride: '01 325i
I brought it back, manager says he has no clue and I think he doesn't think that they caused it. I was like wtf. The DSC is not working, I shouldn't be driving the car, right? What should I do next? I have to go back tomorrow and speak with the store manager I guess.

Last edited by Caden; 10-02-2012 at 07:07 PM.
Caden is offline   Reply With Quote
Old 10-02-2012, 07:05 PM   #7
Caden
Registered User
 
Join Date: Feb 2012
Location: Texas
Posts: 328
My Ride: '01 325i
Quote:
Originally Posted by absolutegtr View Post
Should you have 245/35 rears?
I did have 250/35 in the rear but the tire was due for replacement and the local shop down the road only had 245/40. These lights haven't come on the whole time i've had this tire set up, until discount tire touched the car.

Last edited by Caden; 10-02-2012 at 07:09 PM.
Caden is offline   Reply With Quote
Old 10-02-2012, 07:13 PM   #8
mtnbound
Town Clown
 
Join Date: Nov 2002
Location: Yay Area
Posts: 15,071
My Ride: 330Ci Vert, 325iT
Have you checked to see if they knocked out the brake sensor?
__________________
**********************
Bay Area Top Dropper
Orient Blue 330 Ci Vert
**********************
mtnbound is offline   Reply With Quote
Old 10-02-2012, 07:19 PM   #9
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 6,722
My Ride: '94 325iC & '00 323i
Quote:
Originally Posted by Caden View Post
I brought it back, manager says he has no clue and I think he doesn't think that they caused it. I was like wtf. The DSC is not working, I shouldn't be driving the car, right? What should I do next? I have to go back tomorrow and speak with the store manager I guess.
Drive it all you want, lots of cars with RWD don't have DSC so your car with the DSC disabled is no different than these other cars.

They managed to knock a sensor off. You need to take the tires off and inspect all four corners for the speed sensors to be intact.
jdstrickland is offline   Reply With Quote
Old 10-02-2012, 07:22 PM   #10
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 6,722
My Ride: '94 325iC & '00 323i
Your trouble is in the Brake Light, not the speed sensors. It never hurts to take the tires off and look, but the brake light means that the car thinks the brake fluid is low for some reason. Open the hood and look at the brake fluid reservior.
jdstrickland is offline   Reply With Quote
Old 10-02-2012, 07:22 PM   #11
Caden
Registered User
 
Join Date: Feb 2012
Location: Texas
Posts: 328
My Ride: '01 325i
The brake sensor was disconnected. This would trigger the DSC light, right? They knocked it out when they were balancing the back two tires. If this is the case, how long would it usually take to reset?
Caden is offline   Reply With Quote
Old 10-02-2012, 07:28 PM   #12
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 6,722
My Ride: '94 325iC & '00 323i
Yes, it would trigger the traction control fault. The car sees the rear tires going too fast relative to the front tires, the brakes are applied and the throttle is reduced. If the brakes are disabled, then they cannot be applied and the light comes on to tell you the system is unreliable/disabled.

The light should go out if you set the ignition to Position 1 for 30-ish seconds so the car can look to see that the systems are all System Go.
jdstrickland is offline   Reply With Quote
Old 10-02-2012, 07:43 PM   #13
SeanC
Registered User
 
Join Date: May 2007
Location: TX
Posts: 4,037
My Ride: 330i
The correct tire size for the back is 255/35/18. Currently, there is discrepancy in what the sensors are measuring up front and in the back, which is probably why your DSC light is on. It is also possible that you will need a alignment along with correct size tires.

Sent from my SGH-I997 using Bimmer App
__________________

Sapphire Black MetallicNatural BrownSilver Cube e46 330i ZHP/ZCW/6MT - Sold
HellrotDove Grey e36 ///M3 - RIP
Alpine WhiteTanSand High Gloss e46 330i SunRoofLess/5MT
SeanC is offline   Reply With Quote
Old 10-02-2012, 07:46 PM   #14
B_Cyrus
Banned User
 
Join Date: Jul 2011
Location: Yarmouk, Syria Valentine: Kushy
Posts: 9,438
My Ride: Malfouf
Quote:
Originally Posted by SeanC View Post
The correct tire size for the back is 255/35/18. Currently, there is discrepancy in what the sensors are measuring up front and in the back, which is probably why your DSC light is on. It is also possible that you will need a alignment along with correct size tires.

Sent from my SGH-I997 using Bimmer App
I'm having a hard time believing this. 325i's come stock with like 195/50/16
B_Cyrus is offline   Reply With Quote
Old 10-02-2012, 07:48 PM   #15
cityjohn
Registered User
 
Join Date: Nov 2007
Location: Los Angeles
Posts: 2,416
My Ride: 2001 M3
Missing sensor sounds right. I know the smog check places tell you that you need to drive a little while after the test for your lights to return to normal (after computer detects rear wheels turning and front ones stationary).
__________________
cityjohn is offline   Reply With Quote
Old 10-02-2012, 07:53 PM   #16
Caden
Registered User
 
Join Date: Feb 2012
Location: Texas
Posts: 328
My Ride: '01 325i
Quote:
Originally Posted by jdstrickland View Post
Yes, it would trigger the traction control fault. The car sees the rear tires going too fast relative to the front tires, the brakes are applied and the throttle is reduced. If the brakes are disabled, then they cannot be applied and the light comes on to tell you the system is unreliable/disabled.

The light should go out if you set the ignition to Position 1 for 30-ish seconds so the car can look to see that the systems are all System Go.
I set in position 1 for approx 2 mins. No change. The tire size hasn't been a problem for like 6 months. Why would it be now?
Caden is offline   Reply With Quote
Old 10-02-2012, 07:57 PM   #17
Caden
Registered User
 
Join Date: Feb 2012
Location: Texas
Posts: 328
My Ride: '01 325i
The brake sensor is back on correctly. I'm pretty sure that was the problem seeing how it was unplugged and all. The po had the 255/35/18 225/40/18 set up. Isn't that m3 setup or something like that? I've driven the car about 20 miles since putting back in the sensor. Still no sucess.
Caden is offline   Reply With Quote
Old 10-02-2012, 07:59 PM   #18
B_Cyrus
Banned User
 
Join Date: Jul 2011
Location: Yarmouk, Syria Valentine: Kushy
Posts: 9,438
My Ride: Malfouf
Quote:
Originally Posted by Caden View Post
I set in position 1 for approx 2 mins. No change. The tire size hasn't been a problem for like 6 months. Why would it be now?
Honestly, it isn't. The person who mentioned it is incorrect. You would run into mechanical and maybe electrical issues if you were running 16" wheels/tires in the front and 18" tires/wheels in the back(in simple terms). The problem is a speed sensor that is now dirty or has become dislodged.This has happened to a few members in the past. The brake sensor, unless it's the ABS sensor, has nothing to do with anything other than how much life you have left in your pads.

Last edited by B_Cyrus; 10-02-2012 at 08:02 PM.
B_Cyrus is offline   Reply With Quote
Old 10-02-2012, 08:01 PM   #19
Sven330ci
Registered User
 
Join Date: Jan 2011
Location: Summerfield, Fl
Posts: 108
My Ride: 06 330ci
Kinda off topic, but I had a bad experience with discount tire in Ocala, Fl. I went in to check out a problem that I was having with a front tire. They found the problem, but didn't diagnose the cause properly. When they put my wheels back on they scratched all of them around the bolt holes. I told them about it and they were willing to get them repainted for me. Estimate to fix the damage was $750 at a local shop. Instead of having them repainted I had them give me a discount on new tires.

I appreciate them owning up to the damage and offering to pay for it, but I will never take my car to them again. And because of me they now use sockets with the rubber guard

P.s. think the kid that did it got fired that day
Sven330ci is offline   Reply With Quote
Old 10-02-2012, 08:04 PM   #20
deadwood83
Registered User
 
Join Date: Aug 2007
Location: SLC, UT
Posts: 605
My Ride: has an iron lung
Send a message via MSN to deadwood83
Quote:
Originally Posted by Caden View Post
I brought it back, manager says he has no clue and I think he doesn't think that they caused it. I was like wtf. The DSC is not working, I shouldn't be driving the car, right? What should I do next? I have to go back tomorrow and speak with the store manager I guess.
You will be perfectly fine driving it.



Ask me how I know. (error 90, system deactivation, frequency 213)
__________________
AA Stg2+ 325xiA? Are you stupid? Maybe a little.
I can program cars fo' freeee near Salt Lake City. PM for details.
deadwood83 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use