E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 10-03-2012, 07:07 PM   #1
cocolo9uno
Registered User
 
Join Date: Sep 2012
Location: Charlotte NC
Posts: 21
My Ride: 2003 325xi
2003 325xi Stereo not working/ Electrical problems

I bought my 325xi a couple of weeks ago knowing that the stereo didnt turn on. BMW told the dealer that they didnt know what the problem was and to take it to a stereo specialist to see if it could be repaired or if it had to be replaced. I took it to a well known car audio chain here in Charlotte called Freemans Car Stereo and they looked at it and said it was missing a fuse in the first place but when they put one in it still didnt turn on so i would need a new stereo but they went ahead and left the fuse in it. So i said id be back probably later in the week.

After about 10 min of driving home i noticed my turn signals, dash lights, and sunroof stopped working. And also the "warning beep" when u open the door wont stop until about 30 seconds after u close the door. Basically electrical problems. I took it back and told them what happened and they said thers no reason why that fuse should affect the other electrical in the car like that but that theyll go ahead and remove the fuse. They did and evrything went back to normal. Apparently i have a HUGE and EXPENSIVE electrical problem according to them....
Does anyone have any idea what the problem could be or has anyone experienced anything similar???
cocolo9uno is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use