E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 10-05-2012, 01:06 AM   #1
MARVEL3
Registered User
 
Join Date: Oct 2012
Location: Northern Colorado
Posts: 6
My Ride: 2003 BMW M3
New Buy, few questions!

Hey everyone, I just recently purchased a 2003 M3, I do have a "clunk" that appears every time I switch gears or get on the gas harder, and it is coming from the rear. Is it pretty obvious that it is the Differential bushing? I heard that it's pretty common for these queens to let that one go.

Another question is about the Navi, When I bought the car a few weeks ago it was fine. Now however it still operates perfectly fine, just last week a small half inch sized vertical line appeared in the upper right kind of, and now it's been spreading a little bit, not a crack, but more inside of the screen, has anyone had that happen? And What could it possibly be?

And my last question is about the headlights. Just before this M3 I owned a 2001 330ci. (another great car) ANd it had the same problem. THe headlights would sometimes not turn on, either both or the left or the right. Then I have to toggle the switch a few times before one or both of them finally turn on. They stay on the whole time when the car is running then, but it's just the initial turn on. WIth 330ci used to happen more during night time, or when it was colder. The m3 now does it just whenever really. SO I'm curious if that would be the Ballast, or the igniter, I have looked up the questions before, just never got a clear answer.

Any input would be helpful, so thanks.

By the way, this is my new baby:
http://sphotos-a.xx.fbcdn.net/hphoto...75978003_n.jpg

http://sphotos-a.xx.fbcdn.net/hphoto...07387374_n.jpg
MARVEL3 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use