E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-05-2012, 09:55 AM   #1
JohnnyG46
Registered User
 
Join Date: Oct 2012
Location: Australia
Posts: 7
My Ride: 2003 320CI E46
Had a run of bad f@#$n luck!

Hello to all, i new to this forum (actually, forums in general) and bmw ownership.
I have been loving it (owning the E46) but over the past couple weeks i have experienced a run of bad luck. After driving her around for 6 months...it finally happened...2 weeks ago my e46 was defected by the police for being too low and the window tint too dark, peaking. Then the wanks at the inspection place you take it to get cleared defected me for my angel lights, my indicator lights and a hole the size of a pin head in my left passenger seat belt.

anyways i fixed that all up and got her completely cleared and road legal again
2 days ago, then tonight.....3 hours before posting this on this forum my gearbox chucked itself into safe mode.

Now i did do some reading before posting here so i will state the difference between the posts i read and what my E46 is doing.

It is NOT falling in and out of activation depending on my speed or temperature.
The box is NOT making any worrying noises.
The dash is NOT doing anything erratic with the needles or lights.
only the safe mode indicator is on....(!).....
The car is mechanically stock except for an after market exhaust.
The trans pan gasket has been weeping since i bought her, but up until now have had no problems.

It activated about 1-minute after i took off round a corner pretty hard in S/M mode in first gear with traction and stability turned off.

THANK YOU FOR READING ANY COMMENTS OR ADVICE MUCH APPRECIATED
I AM WANTING MEMBER INPUT AND ADVICE BEFORE I TAKE HER TO THE MECHANICS AND SELL THE SHIRT OFF MY BACK.
__________________
JohnnyG46 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-05-2012, 05:49 PM   #2
lcoleman
Registered User
 
Join Date: Mar 2007
Location: the barnyard
Posts: 2,458
My Ride: '79 Massey Ferguson
You need to have the codes read. We can't tell you anything beyond what you already know: your dash light is on, and you say everything seems to be fine with it.
__________________
lcoleman is offline   Reply With Quote
Old 10-05-2012, 05:57 PM   #3
M4TT4
Registered User
 
Join Date: Nov 2010
Location: Newcastle NSW
Posts: 49
My Ride: BMW e46 323i luxury
Quote:
Originally Posted by lcoleman View Post
You need to have the codes read. We can't tell you anything beyond what you already know: your dash light is on, and you say everything seems to be fine with it.
+1 definitely get the codes read.
And man, that's just crazy unlucky!! I can't believe they pulled you up on your angels!
__________________
M4TT4 is offline   Reply With Quote
Old 10-05-2012, 06:00 PM   #4
Amhague
Registered User
 
Join Date: Apr 2010
Location: Michigan
Posts: 99
My Ride: 330xi
Bimmer app pocket post. GG

Last edited by Amhague; 10-05-2012 at 06:03 PM.
Amhague is offline   Reply With Quote
Old 10-05-2012, 11:33 PM   #5
JohnnyG46
Registered User
 
Join Date: Oct 2012
Location: Australia
Posts: 7
My Ride: 2003 320CI E46
ok code check. haha i know ey, friggin angels, in S.A they pretty much defect you for anything. According to the wank at regency, angel lights are illegal unless you have headlight washers on your front bumper ......... I surprised they didn't defect me for applying tyre shine.

...Australia mate!!...Australia!!...have you got your little helmet?.....
lol...(Steve Hughes stand up live in melbourne 2011)
__________________
JohnnyG46 is offline   Reply With Quote
Old 10-05-2012, 11:55 PM   #6
M4TT4
Registered User
 
Join Date: Nov 2010
Location: Newcastle NSW
Posts: 49
My Ride: BMW e46 323i luxury
We have stupid laws in Aussie too but they don't really act on them. Our coppers are pretty cruisy unless you driving a *** import, piece of crap old Holden or rice.
Dude, that guy is a genius!!!!

But let us know how you go with those codes.
__________________
M4TT4 is offline   Reply With Quote
Old 10-05-2012, 11:55 PM   #7
peytonracer4
:D
 
peytonracer4's Avatar
 
Join Date: Jan 2010
Location: Valparaiso, IN
Posts: 6,689
My Ride: '00 328i
They're illegal unless you have headlight washers!? Wtf
__________________
choose to click or forever hold your peace ;)
peytonracer4 is offline   Reply With Quote
Old 10-06-2012, 12:44 AM   #8
JohnnyG46
Registered User
 
Join Date: Oct 2012
Location: Australia
Posts: 7
My Ride: 2003 320CI E46
LOL...yea, in Australia according to wank..if your car did not come out of factory with the angel lights and you go and put them in yourself, they must be accompanied by head light washers on your front bumper

i love Australia, i really do, but our law makers (and some enforcers) are stupid stupid stupid quota and money obsessed wankers. Steve puts it perfectly lol.

i just got off the phone to a BMW specialist mechanic where i have booked her in for Monday, and he had a full go at me for attempting to get advice first on forums LOL! he claims its a waste of time! first thing he said was.."well why don't you take it to your internet buddies to get it fixed"...wtf?....it was like he was actually offended that i chose to hit up the forums before giving him a call lol. not sure i should take her there now.
__________________
JohnnyG46 is offline   Reply With Quote
Old 10-06-2012, 06:39 AM   #9
328ci906
Registered User
 
Join Date: May 2010
Location: Scranton, PA
Posts: 433
My Ride: 2003 M3
^He's just pissed that were taking all his business, it's cool.
__________________
2003 ///M3 6spd Jet Black/Cinnamon (I Loan Valve Adjustment Tools! PM me...)
328ci906 is offline   Reply With Quote
Old 10-09-2012, 06:14 AM   #10
JohnnyG46
Registered User
 
Join Date: Oct 2012
Location: Australia
Posts: 7
My Ride: 2003 320CI E46
Hi guys, i got the car back today and all is fine!
I didn't end up taking it to that dero who was unhappy about me looking for advice on forums i took her somewhere else.

anyways, the diagnostic showed nothing major was wrong, however it registered a malfunction with the TCS (traction control system).
So the mechanic simply reset the computer, test drove the car, parked it for 30mins then test drove again and it hasn't gone into limp mode since.

I find the result a little weird to be honest, as when it happened (limp mode activating itself) as i metioned in an earlier post, i came round a corner pretty hard-the TCS was turned off, because i had previously switched it off beforehand.

certainly not complaining however, got the best result
thanks to those who bothered to reply.
__________________

Last edited by JohnnyG46; 10-09-2012 at 06:18 AM.
JohnnyG46 is offline   Reply With Quote
Old 10-09-2012, 06:24 AM   #11
M4TT4
Registered User
 
Join Date: Nov 2010
Location: Newcastle NSW
Posts: 49
My Ride: BMW e46 323i luxury
Awesome man! That's fantastic
Glad it all worked out
__________________
M4TT4 is offline   Reply With Quote
Old 10-09-2012, 06:29 AM   #12
JohnnyG46
Registered User
 
Join Date: Oct 2012
Location: Australia
Posts: 7
My Ride: 2003 320CI E46
Quote:
Originally Posted by M4TT4 View Post
Awesome man! That's fantastic
Glad it all worked out
cheers m8
__________________
JohnnyG46 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use