E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 62 votes, 4.74 average. Display Modes
Old 10-13-2012, 08:35 AM   #641
Stinger9
Registered User
 
Join Date: Sep 2011
Location: New York
Posts: 7,827
My Ride: '04 330Ci
Next think about your fuel pump. How old is it?
And then a fuel filter just in case you got it clogged.
Stinger9 is offline   Reply With Quote
Old 10-13-2012, 10:33 AM   #642
smacera
Registered User
 
Join Date: Oct 2012
Location: London
Posts: 13
My Ride: Bmw 318
Thanks Stinger for the reply, I haven't thought about the fuel pump as they can be fairly costly. I don't think it's been changed by a previous owner so it would be almost 12 years old. I changed the fuel filter last week but hasn't made a difference. What else can be causing these very low revs, I'd love to have a solution, any other ideas please.
Thanks so much
smacera is offline   Reply With Quote
Old 10-13-2012, 11:02 AM   #643
Stinger9
Registered User
 
Join Date: Sep 2011
Location: New York
Posts: 7,827
My Ride: '04 330Ci
You are a prime candidate for a new pump.
Too bad you can't get US pricing as it's only $120 here and easy to DIY.

You could do a pressure and volume test to test the pump, or better to just replace. What does it cost there?
Stinger9 is offline   Reply With Quote
Old 10-13-2012, 11:42 AM   #644
smacera
Registered User
 
Join Date: Oct 2012
Location: London
Posts: 13
My Ride: Bmw 318
Pricing of the fuel pumps here new on ebay is $200 or used $70. Do you think this low rev and stalling when cold is related to the spark plugs, the engine computer hasn't given any codes for the plugs or the fuel pump??
Thanks again.
smacera is offline   Reply With Quote
Old 10-13-2012, 11:53 AM   #645
Stinger9
Registered User
 
Join Date: Sep 2011
Location: New York
Posts: 7,827
My Ride: '04 330Ci
You will get no codes from a dying fuel pump. Further corroborates my theory.
It is a mechanical failure, not electrical.

Don't even think about an off brand pump. Siemans VDO is what you want.

If it is the pump, you could be stranded somewhere soon.

Spark plugs would have to be complete toast to cause this problem.

Last edited by Stinger9; 10-13-2012 at 11:55 AM.
Stinger9 is offline   Reply With Quote
Old 10-14-2012, 04:06 AM   #646
smacera
Registered User
 
Join Date: Oct 2012
Location: London
Posts: 13
My Ride: Bmw 318
Thanks Stinger for your reply, I'll keep the fuel pump in mind but like to try some other options first as they can be expensive. What about the Idle control clean or CVV?
I just really want to get rid of this rough idle and stalling.

I've looked up CVV and read a few articles and I'm still trying to diagnose if it's the CVV. A few say the following to test:
Paper (or a plastic freezer baggy) over the warm-engine oil-filler opening as a visual vacuum test (1)
Should move inward one inch or less
Some say it should improve the idle if the CCV is bad (1)
Some say you can feel the vacuum by hand (1)
Inflating balloon (or glove) over the dipstick as a visual crankcase pressure test (1) (2)

I've tried placing the paper over the oil filler when in idle, but lots of air comes out of the opening, blowing the paper away, is this normal or should I take it as a bad sign? Before I can lift the dipstick fully out, it losses rpms and nearly stalls so I'm not sure if air is going in or out of the dipstick.
Any other ways to see if it is the CVV.
I've look at all the nearby hoses and they all look in pretty good shape, some even look new. I've had the car 1 year, done 7k this year, bought with 77k miles.
smacera is offline   Reply With Quote
Old 10-14-2012, 09:21 AM   #647
Stinger9
Registered User
 
Join Date: Sep 2011
Location: New York
Posts: 7,827
My Ride: '04 330Ci
def clean out that ICV is you're on the cheap. your labor is free. mine was only slightly dirty after 88K miles. cleaning did not make a difference.

not that well versed in CVV test as I just replaced mine with all four hoses 'cause I like to run new parts.
can search youtube and plenty here to find what you need.
Stinger9 is offline   Reply With Quote
Old 10-15-2012, 11:36 AM   #648
smacera
Registered User
 
Join Date: Oct 2012
Location: London
Posts: 13
My Ride: Bmw 318
Hi Stinger
Thanks so much for your replies, you've been really helpful.
One last thing I forgot to mention, is that I've had a coolant leak ever since I bought the car just over a year ago, that I've never done anything about as it's so small. If I fill the coolant up to the max it takes 2 months for it to leak out, could this coolant leak affect this rough idling problem and stalling?
Thanks again
Simon
smacera is offline   Reply With Quote
Old 10-15-2012, 01:56 PM   #649
Stinger9
Registered User
 
Join Date: Sep 2011
Location: New York
Posts: 7,827
My Ride: '04 330Ci
I'm no expert, but I've not come across anything that might give you a rough idle from a slo coolant leak.
Search for rough idle on this board.
Don't know how you're going to find that coolant leak.

Good place to start reading for rough idle:

http://forum.e46fanatics.com/showthr...h+idle&page=20
Stinger9 is offline   Reply With Quote
Old 10-17-2012, 12:50 PM   #650
smacera
Registered User
 
Join Date: Oct 2012
Location: London
Posts: 13
My Ride: Bmw 318
Hi Stinger, glad to hear it's not the Coolant leak. I've just had the car scanned twice by a mechanic and he says it's the Camshaft Position Sensor even though I had a new one put in a month ago, maybe it's faulty, but I'm not convinced???? Any other ideas?
smacera is offline   Reply With Quote
Old 10-17-2012, 12:54 PM   #651
Stinger9
Registered User
 
Join Date: Sep 2011
Location: New York
Posts: 7,827
My Ride: '04 330Ci
Did you use an original equipment BMW CPS?
This is critical as any other has a high incidence of not working correctly.
Stinger9 is offline   Reply With Quote
Old 10-17-2012, 01:10 PM   #652
smacera
Registered User
 
Join Date: Oct 2012
Location: London
Posts: 13
My Ride: Bmw 318
No I bought it off Ebay lol. Most of them seem to be around $15. I'm trying to get a replacement.
smacera is offline   Reply With Quote
Old 10-17-2012, 01:22 PM   #653
Wh33lhop
Registered User
 
Join Date: Sep 2012
Location: norcow
Posts: 1,349
My Ride: douchemobile
Quote:
Originally Posted by smacera View Post
No I bought it off Ebay lol. Most of them seem to be around $15. I'm trying to get a replacement.
Sounds like that's your problem.
Wh33lhop is offline   Reply With Quote
Old 10-17-2012, 01:24 PM   #654
darksideracer69
Registered User
 
Join Date: Jan 2008
Location: TX
Posts: 2,886
My Ride: 01 325ci
Waste of 15$

Sent from my SGH-T959 using Bimmer App
__________________
Quote:
Originally Posted by dmax View Post
If she ever yells 'oh god, oh god' just say, 'no, just Doug.'


IMAG02051
darksideracer69 is offline   Reply With Quote
Old 10-17-2012, 01:27 PM   #655
Alex323Ci
Registered User
 
Join Date: Jan 2005
Location: Huntington Beach -Surf City USA
Posts: 17,045
My Ride: M3 & 323Ci (sold)
Quote:
Originally Posted by smacera View Post
No I bought it off Ebay lol. Most of them seem to be around $15. I'm trying to get a replacement.
yep there has been a high number of aftermarket CPS that don't work correctly. so this certainly could be the issue.
also when you say scanned the codes twice. hope this means he cleared and scanned again? just making sure the CPS code isn't a remnant code from before.
__________________
OE CSL WHEELS - OE CSL BRAKES - OE AUTOFLD MIRRORS - CSL TRUNK - CSL DIFFUSER - AA TUNE - AA PULLEYS - AS 40% SSK - BILSTEIN PSS9s
CF CSL LIP - NAVI - BMWPERF CF STRUT BAR - BMW GROUP N MNTS - GRUPPE M CF INTAKE - SUPERSPRINT - UUC BRKLINES, TRANS, RTABs - H&R SWAYS - 4.10 M-SPORT DIFF
Alex323Ci is offline   Reply With Quote
Old 10-17-2012, 04:08 PM   #656
Stinger9
Registered User
 
Join Date: Sep 2011
Location: New York
Posts: 7,827
My Ride: '04 330Ci
Quote:
Originally Posted by smacera View Post
No I bought it off Ebay lol. Most of them seem to be around $15. I'm trying to get a replacement.
Spent more than $100 each to replace mine.
Not just because I like to spend a lot of money.
Stinger9 is offline   Reply With Quote
Old 10-17-2012, 04:16 PM   #657
GhostFlame
Registered User
 
Join Date: Jun 2011
Location: oceans
Posts: 192
My Ride: LSB/HPF
I wonder if kpeng lost any weight by now..
GhostFlame is offline   Reply With Quote
Old 02-14-2013, 11:09 AM   #658
kpeng
Banned User
 
Join Date: Jan 2004
Location: Gainesville, FL
Posts: 25,675
My Ride: E46 330 and E30 325
Quote:
Originally Posted by GhostFlame View Post
I wonder if kpeng lost any weight by now..
Still lovable jello of sex.
kpeng is offline   Reply With Quote
Old 05-04-2013, 07:12 AM   #659
smacera
Registered User
 
Join Date: Oct 2012
Location: London
Posts: 13
My Ride: Bmw 318
I'm still having the same problem, now at 91k but been rough idle since 80K, I've changed everything that the codes suggest but still getting rough idle, drives smooth above 5Mph. It's an auto but will stall if it comes to a stop. I've changed both O2 sensors, MAF sensor, fuel filter, Cam shaft sensor, Air Filter and now just had Transmission filter and fluid drained but still the same. Also, I can't see any air leaks from the hoses. Another guy mentioned he changed more than these items and he's still got rough idle but was told the crankcase breatherhose for the CVV was a little blocked with a buildup of oil, said he changed it and car works like new. Does anybody think that this could be my problem? My photos below on my car shows some build up of Mayo, does this relate to the CVV or Crankcase and should I be worried?
Attached Thumbnails
Click image for larger version

Name:	20130504_121805.jpg
Views:	50
Size:	102.1 KB
ID:	503774   Click image for larger version

Name:	20130504_121805-1.jpg
Views:	41
Size:	41.5 KB
ID:	503775  
smacera is offline   Reply With Quote
Old 05-09-2013, 10:32 PM   #660
latitude39
Registered User
 
Join Date: Jan 2010
Location: United States/Colorado
Posts: 139
My Ride: 2002 325xi
Quote:
Originally Posted by smacera View Post
I've changed both O2 sensors, MAF sensor, fuel filter, Cam shaft sensor, Air Filter and now just had Transmission filter and fluid drained but still the same. Also, I can't see any air leaks from the hoses. Another guy mentioned he changed more than these items and he's still got rough idle but was told the crankcase breatherhose for the CVV was a little blocked with a buildup of oil, said he changed it and car works like new. Does anybody think that this could be my problem? My photos below on my car shows some build up of Mayo, does this relate to the CVV or Crankcase and should I be worried?
"both" O2 sensors? On the 6-cylinder engines there are 4 O2 sensors, the pre-cats being the most important for performance. Mayo in CCV: my guess is to replace CCV and hoses, which will be brittle, if not cracked, by now. How about spark plugs? Which camshaft sensor? The intake seems to be the most critical.
latitude39 is offline   Reply With Quote
Reply

Tags
maintenance, propaganda, tool

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use