E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-25-2012, 10:27 PM   #1
TArse
Registered User
 
Join Date: Nov 2010
Location: Columbus, GA
Posts: 695
My Ride: 03 330xi, 87 325is
Little issue with removing headlight assembly.

I tried to remove my headlight assemblies on my facelift 330xi with headlight washers today and I ran into a little problem.

I got the headlight unbolted, wire connectors disconnected and ready to remove.

Then I say two wires going into the assembly that could not be disconnected, or so it seemed.

The wires were connected to the headlight computer(i think that's what it was?)

Has anyone else ran into this and care to shed some light?
TArse is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-26-2012, 01:50 PM   #2
haurelio
Registered User
 
Join Date: Apr 2008
Location: New Jersey
Posts: 1,043
My Ride: 2001 bmw 325i
Not sure what cables are you referring to, but in any case just unclip them..
haurelio is offline   Reply With Quote
Old 10-26-2012, 02:40 PM   #3
TArse
Registered User
 
Join Date: Nov 2010
Location: Columbus, GA
Posts: 695
My Ride: 03 330xi, 87 325is
Quote:
Originally Posted by haurelio View Post
Not sure what cables are you referring to, but in any case just unclip them..
That's the issue, I couldn't find a clip. I check both assembly's and couldn't not figure it out. I will take pics next week and post
TArse is offline   Reply With Quote
Old 10-26-2012, 07:37 PM   #4
haurelio
Registered User
 
Join Date: Apr 2008
Location: New Jersey
Posts: 1,043
My Ride: 2001 bmw 325i
Ok. Are they oem headlights? Does the light have the cleaning option?
haurelio is offline   Reply With Quote
Old 10-27-2012, 05:08 AM   #5
TArse
Registered User
 
Join Date: Nov 2010
Location: Columbus, GA
Posts: 695
My Ride: 03 330xi, 87 325is
Quote:
Originally Posted by haurelio View Post
Ok. Are they oem headlights? Does the light have the cleaning option?
Yea they are the oem bi xenons with the headlight washers.
TArse is offline   Reply With Quote
Old 04-20-2016, 02:34 PM   #6
TArse
Registered User
 
Join Date: Nov 2010
Location: Columbus, GA
Posts: 695
My Ride: 03 330xi, 87 325is
Little issue with removing headlight assembly.

Going to bump this post.

My xenon started working again shortly after I originally posted and I never figured out how to get my assembly out of the car.


So now my xenon has gone out. I swapped bulbs and the same side is out, so that rules out the bulbs.
I want to swap my igniter and computer on each to figure out what I need to buy to solve this issue.
My problem is that every video or DIY I see about removing the headlight assembly is so simple.
1. Remove blinker.
2. Remove bottom trim and headlight washer.
3. Remove the 4 bolts on the headlight assembly.
4. Remove the assembly while disconnecting the plugs.

In my case when I get to step 4 there are two wire that run INTO the assembly and do not have a plug, they run to what looks like the control module for the headlight, but again they run into the module and do not have a clip. These two wires are preventing me from removing the assemlbly as they run the another part bolted to the car which is near impossible to get to while the assembly is still on the car.
I will post a picture in just a few minutes hopefully someone can point out what I need to do, but as of right now I am stumped.

Last edited by TArse; 04-20-2016 at 02:39 PM.
TArse is offline   Reply With Quote
Old 04-20-2016, 02:51 PM   #7
TArse
Registered User
 
Join Date: Nov 2010
Location: Columbus, GA
Posts: 695
My Ride: 03 330xi, 87 325is
Click image for larger version

Name:	ImageUploadedByBimmerApp1461181790.793473.jpg
Views:	35
Size:	254.9 KB
ID:	630022

I think I may have figured out the issue.

The wires do indeed run the the control module. I just removed the passenger side assembly easily, but on the drivers side my Dinan longtube (installed my previous owner) runs right where the module should be and the module is bolted off the the side, I think. It's hard to see. I'm going to remove my intake and see if I can get this figured out.
TArse is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use