E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-27-2012, 08:55 PM   #1
louie101086
Registered User
 
Join Date: Jun 2010
Location: Trenton, NJ
Posts: 17
My Ride: 03 325xi
LEAN FUEL BANK 1 & 2 and MISFIRE BANK 1

today i did some work on my xi i replaced squealing mech pulley with hydraulic pulley, repaired leaking temp sensor o ring with one from home depot and also replaced throttle body gasket in the process of replacing my throttle body gasket trying to fix these codes i figured i would pull off disa valve. I checked for the signs of a bad disa which is rattling from flapping piece and unplug connector. It wasnt until i pulled it out and inspected it I noticed lots of buildup, worn out flap, and worn out crank which controls open and close of flap. i dont know if this will fix it yet but just wanted to inform my fellow man to inspect disa. next i will order german auto solutions repair kit.

Things replaced/done thus far:

- cleaned maf sensor
- replaced throttle body gasket
- replaced intake boot
- replaced air filter
- replaced ccv & hoses
- replaced fuel sending unit wire harness
- replaced fuel pump
- replaced fuel regulator

Last edited by louie101086; 10-27-2012 at 09:23 PM.
louie101086 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-27-2012, 09:01 PM   #2
zabalzae
Registered User
 
Join Date: Jun 2012
Location: Georgetown Texas
Posts: 357
My Ride: 01 330ci
Sounds like a MAF

Sent from my SAMSUNG-SGH-I747 using Bimmer App
zabalzae is offline   Reply With Quote
Old 10-27-2012, 09:16 PM   #3
louie101086
Registered User
 
Join Date: Jun 2010
Location: Trenton, NJ
Posts: 17
My Ride: 03 325xi
i cleaned maf sensor i will look further into that once disa is fixed trying to eliminate all possibilities of things it could be before last resort of taking it to dealer i also have to check spark plugs for oil to see if valve cover gasket needs to be replaced and also have to check ignition coils
louie101086 is offline   Reply With Quote
Old 10-28-2012, 12:47 AM   #4
Chilton88
Registered User
 
Join Date: May 2012
Location: San Diego, CA
Posts: 66
My Ride: 325ci, 325xi
Check your vacuum lines...start from the egr valve and trace along the side where the oxygen sensor connectors are attached. Then it goes to the back of the engine under the cabin filter housing. You are going to have to remove the cabin filter housing to find the rest of the hose. Then the hose connects to a black and white one way valve and then to a another valve on the driver side back top of the engine block. This is usually the place where there is a disconnect or a crumbling hose has occurred. It is difficult to reach, but doable.
If you do a search in the forums for "failed smog inspection," there are detailed instructions on how to do this, and then there is a great way to rule out things that are failing..
Chilton88 is offline   Reply With Quote
Old 10-28-2012, 06:11 AM   #5
tttomttt
Registered User
 
Join Date: Oct 2010
Location: Long Island NY
Posts: 126
My Ride: 2003 330xi
This has not happened on my Bimmer but I did get these codes on my GMC truck. Changed the related oxy sensor and all was well.
tttomttt is offline   Reply With Quote
Old 10-29-2012, 11:32 AM   #6
louie101086
Registered User
 
Join Date: Jun 2010
Location: Trenton, NJ
Posts: 17
My Ride: 03 325xi
if it was oxy sensor would i be gettin lean on bank 1 & 2.... arent these codes a sign of working oxy sensors
louie101086 is offline   Reply With Quote
Old 10-29-2012, 02:08 PM   #7
SamDoe1
Registered User
 
Join Date: Oct 2010
Location: Minnesnowta
Posts: 3,479
My Ride: Clubs baby seals
Quote:
Originally Posted by louie101086 View Post
if it was oxy sensor would i be gettin lean on bank 1 & 2.... arent these codes a sign of working oxy sensors
It's a sign that your O2 sensors are sending a signal, it doesn't mean that it's the right signal.

How many miles do you have and have the sensors ever been replaced?
SamDoe1 is online now   Reply With Quote
Old 10-29-2012, 03:59 PM   #8
louie101086
Registered User
 
Join Date: Jun 2010
Location: Trenton, NJ
Posts: 17
My Ride: 03 325xi
i have a little over 170k miles and i do not know if o2 sensors were ever changed.... i think i will fix my disa valve first then reset service engine light and if light comes back on i will change o2 sensors if i change sensors should i just change the 2 by engine or change all 4

Last edited by louie101086; 10-29-2012 at 04:02 PM.
louie101086 is offline   Reply With Quote
Old 10-29-2012, 06:53 PM   #9
SamDoe1
Registered User
 
Join Date: Oct 2010
Location: Minnesnowta
Posts: 3,479
My Ride: Clubs baby seals
Just change the pre-cat sensors, the post cat ones rarely give out.
SamDoe1 is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use