E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 11-04-2012, 11:51 PM   #1
Kittepunch
Registered User
 
Join Date: Nov 2012
Location: Ontario, Canada
Posts: 35
My Ride: 2003 325xi
Transmission warning light on a manual?

2003 325xi manual here.

This warning light showed up a bout a month ago, and I'm not too sure why.

http://img521.imageshack.us/img521/8...703transmi.jpg

The car doesn't feel any different, my transmission is smooth, my clutch doesn't slip, nothing feels off. I checked the owner's manual and it only mentions this light showing up on the automatic transmission - nothing about manual. My CEL is also on, but I believe that's because of my missing ambient temp sensor (I read that somewhere else).

Note that despite my transmission not feeling a little off, I do sometimes smell a "hot" smell if I push the car a little harder than usual (quick acceleration, high top speed, etc).

Any insight is much appreciated - sorry if wrong forum.

Edit: Not my picture. The only warning lights present on the dash are the gear symbol and the CEL. Also, the car has 175000 km's on it.

Last edited by Kittepunch; 11-04-2012 at 11:52 PM.
Kittepunch is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use