E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-01-2010, 09:39 PM   #1
subcop42
Registered User
 
Join Date: Nov 2009
Location: florida
Posts: 41
My Ride: 2000 328i
Rough idle

my 2000 328I has a rough idle and i have the fault code and reset tool,and i'm getting a vanos problem,my mpgs isn't as good as it used to be, can anyone tell me if its just the vanos solenoid,or would I have to rebuild the whole vanos assembly. Thanks to any and all,who can help.
subcop42 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-01-2010, 10:42 PM   #2
Toad21
Registered User
 
Join Date: Feb 2009
Location: Normal IL
Posts: 893
My Ride: 00' 328CI
I have the exact same drive train as you.

I needed to clean my Throttle body and Idle control valve. Its about a 1-2 hour DIY, and there are multiple tutorials in the DIY section.

This got rid of throttle body error code, and made my car run better.

Then I did the Vanos repair, and it fixed my rough idle in cold temps, and gave me more torque between 2000-2500 rpm.
__________________
Toad21 is offline   Reply With Quote
Old 11-14-2012, 02:15 PM   #3
subcop42
Registered User
 
Join Date: Nov 2009
Location: florida
Posts: 41
My Ride: 2000 328i
engine vibration

hello to the forum members.
I have a 2000 328i,the car runs great,due to my anal up keep,but not too long ago,i replaced,the motor mounts and tranny mounts,now i feel like a vibration thru the steering wheel,if i hit the accelerator a little it smoothes out,and the car idles at about 700 rpms ,it it normal or something mechanical,since,im not getting any engine light.
subcop42 is offline   Reply With Quote
Old 11-14-2012, 02:28 PM   #4
zabalzae
Registered User
 
Join Date: Jun 2012
Location: Georgetown Texas
Posts: 359
My Ride: 01 330ci
I've been trying to figure out the same.
zabalzae is offline   Reply With Quote
Old 12-13-2012, 07:45 PM   #5
subcop42
Registered User
 
Join Date: Nov 2009
Location: florida
Posts: 41
My Ride: 2000 328i
Rough idle

Hello to everyone in this forum,posting ,my first thread, I have a 2000 328i,and it has 132,000 miles,has good power,but I have a slight,rough idle,if I hit the accelerator pedal slightly it smoothes out,I'm anal when it comes to pm's, and I'm not getting any fault codes, I also get 33 mpg,at 70 mph.
pms i've done so far ,I only use premium gas
1-new plugs
2-rebiult vanos valve
3-cleaned MAF sensor ,replaced two years ago
4-new O2 sensor
5-replaced tranny fluid and filter - steptronic trans
6-G-force programmer
7-replaced alternator
8-replaced power steering pump
9-will replace fuel pump, over design failure
10-replaced fan and clutch
11-changed motor mounts
12-replaced tranny mounts
13-replaced guibo and center support bearing

I feel vibration ,thru steering wheel,and it started around a year ago.

any input,would be appreciated.

Last edited by subcop42; 12-13-2012 at 07:46 PM.
subcop42 is offline   Reply With Quote
Old 12-25-2012, 12:30 PM   #6
Bmwtay
Registered User
 
Join Date: Dec 2012
Location: Vancouver Canada
Posts: 7
My Ride: 2000 323CI E46
I have a 2000 323CI and I was getting a rough idle warm or cold, when I reved the engine a bit the idle would level out but start up again when i came to a stop... I replaced the PCV valve and hoses conecting to this part and it fixed my annoying rough idle problem... PCV valve + hoses + spark plugs + labour = approximately $800.
Bmwtay is offline   Reply With Quote
Old 07-17-2014, 07:12 PM   #7
subcop42
Registered User
 
Join Date: Nov 2009
Location: florida
Posts: 41
My Ride: 2000 328i
e46 idle vibration

hello to all on this forum

I have a 2000 328i with a steptronic transmission with 146,000 miles, I have no check engine light on,I've replaced various components on my 328i, and at idle ,which is at 700 rpms,I get a vibration,once i take off,car feels normal and with good take off,last component installed was the ICV ,a little better,but still vibrating,checked the DISA valve and its in good condition, did the diaphram,test and its holding at about 45 degrees, checked the fan,and removed it,and ran the car without the fan on,still vibration,If I remember correctly,the vibration started around,the time i changed the motor mounts,not sure if thats the problem. just wondering ,if anyone out there has a clue as to what could be causing the vibration. Thanks Nelson
subcop42 is offline   Reply With Quote
Old 07-17-2014, 07:13 PM   #8
BartenderPlease
OEM ///Member
 
BartenderPlease's Avatar
 
Join Date: Sep 2006
Location: FL
Posts: 9,245
My Ride: 328i Sport
Heat shield?
__________________
FS: OEM CCV hoses, 328i DISA

image
AERA Performance Engine Builder
| BBS | FK | Rogue Eng | K&N | Exhaust | 330i Brakes |
| b30 manifold | ported head | FX-R/Orion V4 | LEDs |
| Alcantara | Khoalty Knob | JL Audio |


BartenderPlease is offline   Reply With Quote
Old 07-17-2014, 07:13 PM   #9
Gunsnbacon
Registered User
 
Join Date: Apr 2014
Location: Myrtle Beach
Posts: 598
My Ride: 2001 330ci
Is it a constant vibration, or intermittent?

Also heat shield can cause a vibration but its more of a rattly noise than a physical vibration. Doesn't hurt to check though, just press a screw driver against it to see if it stops rattling.
__________________



Last edited by Gunsnbacon; 07-17-2014 at 07:14 PM.
Gunsnbacon is offline   Reply With Quote
Old 07-17-2014, 07:16 PM   #10
BartenderPlease
OEM ///Member
 
BartenderPlease's Avatar
 
Join Date: Sep 2006
Location: FL
Posts: 9,245
My Ride: 328i Sport
Yep more of a rattle, good call. Guibo?
__________________
FS: OEM CCV hoses, 328i DISA

image
AERA Performance Engine Builder
| BBS | FK | Rogue Eng | K&N | Exhaust | 330i Brakes |
| b30 manifold | ported head | FX-R/Orion V4 | LEDs |
| Alcantara | Khoalty Knob | JL Audio |


BartenderPlease is offline   Reply With Quote
Old 07-17-2014, 07:19 PM   #11
subcop42
Registered User
 
Join Date: Nov 2009
Location: florida
Posts: 41
My Ride: 2000 328i
I can feel vibration thru the steering wheel. it does have a rattle sound

Last edited by subcop42; 07-17-2014 at 07:22 PM. Reason: updating
subcop42 is offline   Reply With Quote
Old 07-27-2014, 07:30 PM   #12
subcop42
Registered User
 
Join Date: Nov 2009
Location: florida
Posts: 41
My Ride: 2000 328i
I rebuilt my vanos,replaced ICV and cleaned throttle body,going to replace FPR next to see.
subcop42 is offline   Reply With Quote
Old 07-27-2014, 08:39 PM   #13
Bmwtay
Registered User
 
Join Date: Dec 2012
Location: Vancouver Canada
Posts: 7
My Ride: 2000 323CI E46
I have A 2000 323CI. I had a vibration in my steering wheel. I felt it everywhere. I replaced my bushings and it totally fixed the problem. If it continues you should check the rims to see if they're bent.
Bmwtay is offline   Reply With Quote
Old 07-28-2014, 05:57 AM   #14
mlody
Registered User
 
Join Date: Oct 2013
Location: UK
Posts: 49
My Ride: 325ci
Quote:
Originally Posted by subcop42 View Post
Hello to everyone in this forum,posting ,my first thread, I have a 2000 328i,and it has 132,000 miles,has good power,but I have a slight,rough idle,if I hit the accelerator pedal slightly it smoothes out,I'm anal when it comes to pm's, and I'm not getting any fault codes, I also get 33 mpg,at 70 mph.
pms i've done so far ,I only use premium gas
1-new plugs
2-rebiult vanos valve
3-cleaned MAF sensor ,replaced two years ago
4-new O2 sensor
5-replaced tranny fluid and filter - steptronic trans
6-G-force programmer
7-replaced alternator
8-replaced power steering pump
9-will replace fuel pump, over design failure
10-replaced fan and clutch
11-changed motor mounts
12-replaced tranny mounts
13-replaced guibo and center support bearing

I feel vibration ,thru steering wheel,and it started around a year ago.

any input,would be appreciated.
Your list not including Ultrasonic injector cleaning,I've had the same problem and after cleaning it alot better
I jumped from 33mpg to 36-38 mpg at 70mph

Last edited by mlody; 07-28-2014 at 06:03 AM.
mlody is offline   Reply With Quote
Old 07-31-2014, 12:27 AM   #15
subcop42
Registered User
 
Join Date: Nov 2009
Location: florida
Posts: 41
My Ride: 2000 328i
I have cleaned the throttle body,replaced ICV,and i have no error codes,i have the scan tool from BAV,and its clean.
subcop42 is offline   Reply With Quote
Old 07-31-2014, 12:29 AM   #16
subcop42
Registered User
 
Join Date: Nov 2009
Location: florida
Posts: 41
My Ride: 2000 328i
vibration is only at idle,so in park or stopped at a light.
subcop42 is offline   Reply With Quote
Old 07-31-2014, 11:45 AM   #17
Bmwtay
Registered User
 
Join Date: Dec 2012
Location: Vancouver Canada
Posts: 7
My Ride: 2000 323CI E46
I had that on my BWM. It was really rough at idle, it started getting worse to the point where I could feel it while driving. I replaced the PCV valve and hoses that connected to it. Fixed all my idle issues. Good luck. Cost me 650 Canadian.
Bmwtay is offline   Reply With Quote
Old 07-31-2014, 09:12 PM   #18
subcop42
Registered User
 
Join Date: Nov 2009
Location: florida
Posts: 41
My Ride: 2000 328i
wondering,where does one get the ultrasonic injector done.
subcop42 is offline   Reply With Quote
Old 08-03-2014, 11:18 PM   #19
Las_man
Registered User
 
Join Date: Sep 2013
Location: Sri Lanka
Posts: 2
My Ride: E46 318i 2002
I had the vibration at Idel and could feel a different vibration at higher speed. mpg was not good as well. It was due to one coil being bad and the first cylinder was not firing(active). I have a 2002 318i and it is easy to access the coils. When I removed the wire socket from each Coil, nothing happened for the first Cylinder (DIY : http://diy-auto-repair.wonderhowto.c...-coils-323595/). Went to the dealer and the same Indicated with a Fault code. Cost was USD 80 for one new Coil + job. Apparently they go bad after 10 years or so.
Las_man is offline   Reply With Quote
Old 08-05-2014, 09:38 PM   #20
subcop42
Registered User
 
Join Date: Nov 2009
Location: florida
Posts: 41
My Ride: 2000 328i
if you have a bad coil,your engine light comes on,I had a bad coil and ,I have the scan tool,which told me which coil was bad,replaced it and car runs great. I have no check engine light , but still trying to figure out idle vibration.
subcop42 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use