E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-14-2012, 09:55 PM   #1
Iggy27
Registered User
 
Join Date: Nov 2012
Location: Inkom
Posts: 498
My Ride: 2003 330xi
Headlight washers aren't working? Any ideas why?

I bought my 2003 330xi. I never has a reason to use my headlight washers. But since winter is coming I wanted to test them out and see how I like them. But they won't turn on. Any main causes why they won't work?
Iggy27 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-15-2012, 12:11 AM   #2
cityjohn
Registered User
 
Join Date: Nov 2007
Location: Los Angeles
Posts: 2,416
My Ride: 2001 M3
Disuse could be one reason. They have a separate pump which may have gone years without being activated. Also, they can only be switched on when your wipers and headlights are on, and even then it's every 10th pull of the stalk.
__________________
cityjohn is offline   Reply With Quote
Old 11-15-2012, 12:44 AM   #3
mtnbound
Town Clown
 
Join Date: Nov 2002
Location: Yay Area
Posts: 15,071
My Ride: 330Ci Vert, 325iT
^^^ +1. Very likely the washer pump. Very easy and cheap DIY job.
__________________
**********************
Bay Area Top Dropper
Orient Blue 330 Ci Vert
**********************
mtnbound is online now   Reply With Quote
Old 11-15-2012, 01:07 AM   #4
Iggy27
Registered User
 
Join Date: Nov 2012
Location: Inkom
Posts: 498
My Ride: 2003 330xi
The pump is the one on the front top side of the windshield fluid tank right?
Iggy27 is offline   Reply With Quote
Old 11-15-2012, 06:49 AM   #5
jeepo23
Registered User
 
Join Date: Oct 2011
Location: cdn
Posts: 1,083
My Ride: 02 330
They come on every 6th time with your windshield wipers.

The pump is the one that is closer to the front end of the car at the washer bottle.

Easy way to test if its the pump. Have someone activate the washer and listen if you can hear the pump running. If the pump doesn't run its dead, if you can hear the pump what might of happened is the actual gear inside has failed not providing enough pressure to pop the headlight washers out.

I just had mine replaced earlier this year. I even managed to find a pump on ebay for $12 compared to what everyone else charges for these of $40+..

Ill find the link to my old post where it had a bunch of troubleshooting steps.
jeepo23 is offline   Reply With Quote
Old 11-15-2012, 08:55 AM   #6
SamDoe1
Registered User
 
Join Date: Oct 2010
Location: Minnesnowta
Posts: 3,479
My Ride: Clubs baby seals
You're not missing out on anything by having it broken. All the headlight washers do is make a huge mess and run through washer fluid like a drunk on Saturday night.

Other people are right though, get a cheap pump and swap it out. Mine stays disconnected 100% of the time to prevent it from running.
SamDoe1 is offline   Reply With Quote
Old 11-15-2012, 09:10 AM   #7
Iggy27
Registered User
 
Join Date: Nov 2012
Location: Inkom
Posts: 498
My Ride: 2003 330xi
Like during the winter I think it would be nice to have them. During the summer I would unplug them. And I never heard the pump click on at all. I think my pump is dead.
Iggy27 is offline   Reply With Quote
Old 11-15-2012, 09:24 AM   #8
jeepo23
Registered User
 
Join Date: Oct 2011
Location: cdn
Posts: 1,083
My Ride: 02 330
Here is the headlight pump troubleshooting.

http://forum.e46fanatics.com/showthr...dlight+washers

Cheapest I found by quickly doing part number search is $18 on ebay.
http://www.ebay.com/sch/i.html?_sop=...8377430&_rdc=1

Reason I was able to find one for $12 was because I searched an old headlight washer pump part number and it came up and was swap.
jeepo23 is offline   Reply With Quote
Old 11-15-2012, 09:35 AM   #9
Iggy27
Registered User
 
Join Date: Nov 2012
Location: Inkom
Posts: 498
My Ride: 2003 330xi
Yea sounds like I need to change my pump first and are if that's the problem.
Iggy27 is offline   Reply With Quote
Old 11-15-2012, 09:58 AM   #10
SamDoe1
Registered User
 
Join Date: Oct 2010
Location: Minnesnowta
Posts: 3,479
My Ride: Clubs baby seals
Quote:
Originally Posted by Iggy27 View Post
Like during the winter I think it would be nice to have them. During the summer I would unplug them. And I never heard the pump click on at all. I think my pump is dead.
I drive around all the time in one of the worst winters in the US. Trust me, the headlight washers do jack squat.
SamDoe1 is offline   Reply With Quote
Old 11-15-2012, 02:23 PM   #11
stingray71
Registered User
 
Join Date: Oct 2012
Location: Vienna, VA
Posts: 5
My Ride: 2005 325xi
Have you checked the fuse? It is possible that it was removed by the previous owner trying to avoid the typical problems.
stingray71 is offline   Reply With Quote
Old 11-15-2012, 03:51 PM   #12
Kubica
Registered User
 
Join Date: Apr 2008
Location: Boston
Posts: 4,361
My Ride: 2003 325xi
Quote:
Originally Posted by SamDoe1 View Post
I drive around all the time in one of the worst winters in the US. Trust me, the headlight washers do jack squat.
Do they use liquid magnesium chloride on the roads in MN? That stuff does cake on to the headlights pretty good.
Kubica is offline   Reply With Quote
Old 11-15-2012, 04:02 PM   #13
Iggy27
Registered User
 
Join Date: Nov 2012
Location: Inkom
Posts: 498
My Ride: 2003 330xi
Yea the fuse is still it. Just nothing is workin or clicking
Iggy27 is offline   Reply With Quote
Old 11-15-2012, 04:07 PM   #14
jeepo23
Registered User
 
Join Date: Oct 2011
Location: cdn
Posts: 1,083
My Ride: 02 330
Wonder of the option was disabled by code. I could be a possibility
__________________
** Removed **
jeepo23 is offline   Reply With Quote
Old 11-15-2012, 04:33 PM   #15
Iggy27
Registered User
 
Join Date: Nov 2012
Location: Inkom
Posts: 498
My Ride: 2003 330xi
I think the pump it burned out I tried to buy one today but it was way too much for a used one. Ill have to get one online
Iggy27 is offline   Reply With Quote
Old 11-15-2012, 05:51 PM   #16
SamDoe1
Registered User
 
Join Date: Oct 2010
Location: Minnesnowta
Posts: 3,479
My Ride: Clubs baby seals
FWIW I bought mine from Pelican parts. I got the cheapest one and it was like $15 for a brand new part.
SamDoe1 is offline   Reply With Quote
Old 11-15-2012, 06:15 PM   #17
E46er75
Registered User
 
Join Date: Aug 2011
Location: New England
Posts: 298
My Ride: 323i Vert, 330xi
I'm surprised that anybody even uses the washers. I had them on my Audi and really couldn't understand why anyone would want this option. Just like headlight wipers on a Volvo, it just doesn't make sense. I wouldn't even waste my time fixing these unless you actually use them. But hey, that's just me...
E46er75 is offline   Reply With Quote
Old 11-15-2012, 06:30 PM   #18
jizzzoe
Registered User
 
Join Date: Feb 2011
Location: Kent, WA
Posts: 628
My Ride: is no longer E46 :(
Send a message via Yahoo to jizzzoe
sub'd
__________________

My Steel Gray '03 330Ci... I miss you, baby!
MODS: Purely aesthetic… Shadowlined, Smoked and LED'd out!
jizzzoe is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use