E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 11-15-2012, 07:18 AM   #1
billy183
Registered User
 
Join Date: Nov 2012
Location: Australia
Posts: 4
My Ride: M3
Post Problem with s54 vanos hunting at idle

Hi guys,I have had my m3 now for approx 3 months, just the other day after driving it when pulling up to a set of lights the car started to hunt at idle and shake. Engine light also came on. I got my local mechanic to check it and he said it Had multiple cylinder misfire and something about my exhaust timing. Has anyone seen or come across this problem before. I'm planning to take it to the local BMW dealership later on next week. Cheers
billy183 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-15-2012, 11:00 AM   #2
taylor192
Registered User
 
Join Date: Feb 2012
Location: The Best Place on Earth
Posts: 1,755
My Ride: 2003.5 M3
You'll need to read the specific BMW codes to determine what's wrong.
taylor192 is offline   Reply With Quote
Old 11-15-2012, 01:06 PM   #3
sakumaxp
Registered User
 
Join Date: Mar 2011
Location: Diamond Bar
Posts: 1,114
My Ride: 02 M3 convertible
i dont this its your vanos unit, i think if its the exhaust timing, i think what you might need is the exhaust hub (http://drvanos.com/index.php?option=...&id=5&Itemid=6) scroll down a little and you can find it there......it aint cheap....
__________________

Carbon Black Metallic
SMG II
Verttttt
VCSL Front Bumper
VCSL 1 Piece Splitter
VIS GTR Hood
6K Angel Eyes
VMR VB3 19's
KW V2 coilovers
sakumaxp is offline   Reply With Quote
Old 11-16-2012, 04:31 AM   #4
billy183
Registered User
 
Join Date: Nov 2012
Location: Australia
Posts: 4
My Ride: M3
I think I've found the problem. When the vehicle starts to hunt and run rough at idle, I found that when I tap the vanous unit on the front of the engine with a hammer it runs ok.
billy183 is offline   Reply With Quote
Old 11-16-2012, 05:10 AM   #5
KaliVertBoy
Registered User
 
Join Date: Apr 2012
Location: SoCal
Posts: 274
My Ride: M3 Vert 6MT
What the hell?!?!
__________________


Interior Pioneer avic z2--brushed aluminum vinyled trim--wind deflecter
Exterior Csl front bumper--Gold CSL reps--Macht Schnell spacers 18mmf/10mmr--Ebay trunk spoiler
Performance Macht Schnell intake elbow--K&N drop in--Manzo Headers (still in box lol)-- TCKline/Ground Control Coilovers
Lighting OEM LED taillight retrofit w/ amber vinyl--Chris Brown mod--3500k H7's--6000k morimoto D2s's--6000k ccfl angel eyes--LED's everywhere
KaliVertBoy is offline   Reply With Quote
Old 11-16-2012, 08:23 AM   #6
danwilz
Registered User
 
Join Date: Oct 2009
Location: Staten Island, New York
Posts: 536
My Ride: E46 M3 Vert 2012 X5
Good idea hit the cast aluminum housing with a hammer you should try a sledge.
__________________
danwilz is offline   Reply With Quote
Old 11-16-2012, 10:47 AM   #7
Westrace
Registered User
 
Join Date: May 2012
Location: SoCal
Posts: 178
My Ride: 06 G35, 04 M3 Coupe
Quote:
Originally Posted by sakumaxp View Post
i dont this its your vanos unit, i think if its the exhaust timing, i think what you might need is the exhaust hub (http://drvanos.com/index.php?option=...&id=5&Itemid=6) scroll down a little and you can find it there......it aint cheap....
Damn, this little thing costs $900!!!

Last edited by Westrace; 11-16-2012 at 10:48 AM.
Westrace is offline   Reply With Quote
Old 11-16-2012, 04:28 PM   #8
Firstboost
Registered User
 
Join Date: Jul 2012
Location: East Bay
Posts: 109
My Ride: 2006 Tiag ZCP
Quote:
Originally Posted by Westrace View Post
Damn, this little thing costs $900!!!
Of course it does, and that one is cryogenically treated to boot!

Your broken exhaust hub tab won't have any ill effect on the engine persť, but if the tab falls into the timing chain well, the results could be catastrophic.

I doubt BOTH of your tabs could be broken and still have the VANOS operate. My best suggestion for you is to remove the valve cover and check your exhaust hub, then go from there.
Firstboost is offline   Reply With Quote
Old 11-17-2012, 12:18 AM   #9
nick0780
Registered User
 
Join Date: Oct 2011
Location: Mississippi
Posts: 15
My Ride: 2004 M3
Sounds like the VANOS solenoid pack if you ask me. They are known to have intermittent continuity at the solder joints. More info here: http://www.beisansystems.com/procedu..._procedure.htm

Last edited by nick0780; 11-17-2012 at 12:32 AM.
nick0780 is offline   Reply With Quote
Old 11-17-2012, 12:23 AM   #10
xx2wickedxx
Registered User
 
Join Date: Jun 2010
Location: New York
Posts: 76
My Ride: e46 m3 convertible
It's your vanos solenoid.
xx2wickedxx is offline   Reply With Quote
Old 11-17-2012, 03:36 PM   #11
Prdquik
Registered User
 
Join Date: Dec 2011
Location: California
Posts: 65
My Ride: 04 M3 Coupe
I agree Vanos solenoid.
Prdquik is offline   Reply With Quote
Old 11-30-2012, 11:10 PM   #12
nick0780
Registered User
 
Join Date: Oct 2011
Location: Mississippi
Posts: 15
My Ride: 2004 M3
So what was the fix?
nick0780 is offline   Reply With Quote
Old 12-01-2012, 06:23 PM   #13
billy183
Registered User
 
Join Date: Nov 2012
Location: Australia
Posts: 4
My Ride: M3
It was the vanous unit, replaced it myself and now runs ok
billy183 is offline   Reply With Quote
Old 12-01-2012, 06:25 PM   #14
billy183
Registered User
 
Join Date: Nov 2012
Location: Australia
Posts: 4
My Ride: M3
$1300 later it's back on the road
billy183 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use