E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-23-2012, 09:07 AM   #1
Tun6twista
tun6twista
 
Tun6twista's Avatar
 
Join Date: Oct 2004
Location: Wisconsin
Posts: 482
My Ride: 2001 BMW 330 CI
HID replacement kit question

I want to order the following...
D2S: Morimoto Elite HID System
I don't know what canbus wire harness I need to order for my 2001 BMW 330CI with existing Xenon lighting.
My existing balast or igniter fails after minutes of me turning my headlights on. It will turn back on again when I turn the switch off then on, but continues to fail between 1 and 5 minutes. Do I need the canbus 9006, H7, or 9007 wire harness? I've done an hours worth of searching.

Thanks
__________________
Tun6twista is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-23-2012, 09:34 AM   #2
FastHackem
Registered User
 
Join Date: May 2011
Location: Richmond, TX
Posts: 672
My Ride: E60 M5
None of those harnesses are correct for your application. If your car has a factory xenon system, its going to be a custom setup to install the Morimoto system. Not plug and play. Email TRS and ask them what your best option is.

Have you tried swapping your bulbs to isolate the problem? Sounds like a bulb issue to me.

Sent from my Nexus S 4G using Bimmer App
__________________

The Mind Is A Terrible Thing.
2006 M5
2005 Impreza WRX
2002 330i
1983 944
FastHackem is offline   Reply With Quote
Old 09-23-2012, 09:38 AM   #3
Tun6twista
tun6twista
 
Tun6twista's Avatar
 
Join Date: Oct 2004
Location: Wisconsin
Posts: 482
My Ride: 2001 BMW 330 CI
Yes I have tried swapping the bulbs. same issue with either bulb. I have not swapped balasts yet. I just e-mailed TRS with my question. Thanks

Quote:
Originally Posted by FastHackem View Post
None of those harnesses are correct for your application. If your car has a factory xenon system, its going to be a custom setup to install the Morimoto system. Not plug and play. Email TRS and ask them what your best option is.

Have you tried swapping your bulbs to isolate the problem? Sounds like a bulb issue to me.

Sent from my Nexus S 4G using Bimmer App
__________________
Tun6twista is offline   Reply With Quote
Old 09-24-2012, 05:00 AM   #4
Solidjake
Zero. Oil. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 22,275
My Ride: 2002 330i
Swap ballasts and get back to us.

Most likely the wiring on the ignitor is bad.
Solidjake is offline   Reply With Quote
Old 10-16-2012, 10:11 AM   #5
Tun6twista
tun6twista
 
Tun6twista's Avatar
 
Join Date: Oct 2004
Location: Wisconsin
Posts: 482
My Ride: 2001 BMW 330 CI
Reply...

So I finally ordered 2 new HID kits (one for the fog lights) and got to troubleshooting/replacing my lighting. Turns out the Ballast is fine. Swapped them and same light went out. Must be the ignitor on my drivers side. I will be replacing the OEM stuff and selling the working old ballasts to make up for the cost of the new kits. Thanks.

Quote:
Originally Posted by Solidjake View Post
Swap ballasts and get back to us.

Most likely the wiring on the ignitor is bad.
__________________
Tun6twista is offline   Reply With Quote
Old 11-15-2012, 01:10 PM   #6
rebelwitoutacoz
Registered User
 
Join Date: Oct 2011
Location: Lakewood
Posts: 54
My Ride: 2004 330ci
do you still have the passenger side ignitor?
rebelwitoutacoz is offline   Reply With Quote
Old 11-16-2012, 09:25 AM   #7
Tun6twista
tun6twista
 
Tun6twista's Avatar
 
Join Date: Oct 2004
Location: Wisconsin
Posts: 482
My Ride: 2001 BMW 330 CI
Yes I do. Someone else asked me this same question. I am not sure how to get the ignitor out as it is built into the headlight. Sounds like a pain in my arse. What do you think?

Quote:
Originally Posted by rebelwitoutacoz View Post
do you still have the passenger side ignitor?
__________________
Tun6twista is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use