E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 11-15-2012, 11:04 PM   #1
Big john (972)
Registered User
 
Join Date: Nov 2012
Location: Dallas
Posts: 5
My Ride: M3
Car misfire, need help, please.

Need help guys, please..... I have a 2003 m3 been running like crap. I have misfire sender 1 through 6. I'm using OBD 2 scanner made from blue point YA31000. Here are all my code are showing. P0301, P0302,P0303,P0304,P0305,P0306,P0300 random misfire,P0012 intake camshaft position timing over-retarded bank1,P0010 intake camshaft position actuator circuit/open bank1. So I've changed the exhaust and intake cam sensor. And another thing is when I use the scanner to clear the service engine light. The car runs fine for a week, and then the light come back on again. If anyone out there have the same problem PLEASE help. Oh and another thing, could it be my 02 sensor is going bad?
Big john (972) is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-16-2012, 02:17 AM   #2
Slyde
Registered User
 
Join Date: Jan 2010
Location: Seattle, WA, USA
Posts: 89
My Ride: 2001 M3 TiAg
I cannot accurately say, but maybe the VANOS solenoid? It may not be actuating the intake cam and therefor causing bad timing. The solenoid with broken solder points also exhibits intermittent faults as the connections may be maintained for a while, but then jolted open at some point and producing error codes again.

Although could be other things. I had similar issues (exhaust cam) and it was the VANOS itself, which was a rather expensive repair.
Slyde is offline   Reply With Quote
Old 11-16-2012, 05:32 AM   #3
lucky_doggg7
Registered User
 
Join Date: Mar 2008
Location: OC
Posts: 282
My Ride: 2005 M3
About your O2 sensor(s), hopefully your scan tool is capable of capturing and monitoring O2 sensor voltages in real time. If it has this ability, is is exactly the menu you need to use. First, insert the key into the ignition switch an turn it to detent just short of activating the starter; in this position, the entire car's FI system is energized and ready to fire. O2 sensors provide a straight base line voltage value at rest, meaning not actually reading 02 content. All primary and post car sensors should have the same baseline number on the scanner's screen, if I recall correctly. If a sensor is malfunctioning, it will not even likely provide the right baseline voltage and this is how you can tell if a O2 sensor is on its way out.

One step further, O2 sensors provide a predictable oscillating voltage signal in the form of a sine wave. If your scan tool can read real time O2 signal voltages, this is what you want to see for each primary O2 sensor. If you see an erratic wave on the scope function of your scan tool, that is a sure give away the O2 sensor is beyond its useful life, and replacement is warranted.

As for your VANOS problems, call Dr VANOS, this is the real vendors name, not some attempt at humor here, and ask him specifically what test you should perform to determine if the VANOS module on your sled is indeed experiencing intermittent failure, leading to your current predicament. There are more sophisticated scan tools that I believe can make the module activate a specific solenoid in the module; a year or so ago, I remember playing around with my buddy's expensive scan tool and manually activating a solenoid (when the car was at rest of course), and it made a faint "click" so this is a sure indicator the that the individual solenoid is working. That Scan tool was a $3,000 piece of equipment btw. Good luck fellah.
lucky_doggg7 is offline   Reply With Quote
Old 11-16-2012, 04:09 PM   #4
Big john (972)
Registered User
 
Join Date: Nov 2012
Location: Dallas
Posts: 5
My Ride: M3
The thing is when I use my scanner to clear the service engine light. The car runs good for about a week, then the service engine come back. Been doing this for almost two months now.
Big john (972) is offline   Reply With Quote
Old 11-17-2012, 03:27 PM   #5
Prdquik
Registered User
 
Join Date: Dec 2011
Location: California
Posts: 66
My Ride: 04 M3 Coupe
I think Slyde hit the nail on the head. Same symptoms I was having. Vanos solenoid fixed it. Not cheap to say the least. Good luck.
Prdquik is offline   Reply With Quote
Old 11-19-2012, 12:48 AM   #6
nick0780
Registered User
 
Join Date: Oct 2011
Location: Mississippi
Posts: 15
My Ride: 2004 M3
Quote:
Originally Posted by Prdquik View Post
I think Slyde hit the nail on the head. Same symptoms I was having. Vanos solenoid fixed it. Not cheap to say the least. Good luck.

You can get one rebuilt for 150 bucks plus core.
nick0780 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use