E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-20-2012, 02:04 PM   #1
reupgang
Registered User
 
Join Date: Feb 2011
Location: alameda
Posts: 46
My Ride: 2000 323i
Is it safe to say, if I don't have the CEL on, i'm good?

I've been doing maintenance on my car and followed many DYI on here, but I have yet to have a check engine light on in my 2.5 years of owner ship. should I not worry as much?
reupgang is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-20-2012, 02:11 PM   #2
Blueandwhite85
Registered User
 
Join Date: Aug 2011
Location: Texas
Posts: 1,346
My Ride: E46
It's definitely a good start, but bad VCGs, OFHGs etc don't throw codes. If you are unaware of what to look for, have a trusted E46-aware mechanic inspect the car.

Last edited by Blueandwhite85; 11-20-2012 at 02:11 PM.
Blueandwhite85 is offline   Reply With Quote
Old 11-20-2012, 02:20 PM   #3
FenderGuy05
OEM ///Member
 
FenderGuy05's Avatar
 
Join Date: Oct 2011
Location: Daly City
Posts: 944
My Ride: 2002 BMW 325i
Agreed, had my car for a little over a year, no CELs, *knock on wood*, but am always lining up the next set of DIY to keep things running perfect. VCG, Vanos, and new intake boots are on the list for the near future.
__________________
FenderGuy05 is offline   Reply With Quote
Old 11-20-2012, 02:38 PM   #4
Wolrab
Registered User
 
Join Date: Jan 2009
Location: Houston
Posts: 485
My Ride: 330Ci MT, 545i SMG
Send a message via Skype™ to Wolrab
My "quick" check list is:

No lights on
No puddles under car
No clunking noises going over bumps

It gets a more thorough going-over each weekend, but that's basically my daily check.
__________________
Engineers do it with a torque wrench
Wolrab is offline   Reply With Quote
Old 11-20-2012, 02:43 PM   #5
reupgang
Registered User
 
Join Date: Feb 2011
Location: alameda
Posts: 46
My Ride: 2000 323i
I drive my car 1x a week prolly about 30-50 miles max, that a good thing right?
reupgang is offline   Reply With Quote
Old 11-20-2012, 03:42 PM   #6
WDE46
Registered User
 
Join Date: Sep 2012
Location: Old Greg's Cavern
Posts: 9,464
My Ride: 2004 330Ci OBM
The CEL/SES light doesn't know everything. For example, I completely snapped my DISA flap off to fix a rattle and the car has no idea. That's a pretty big item. Filters won't throw codes either and neither will a fuel pump or old spark plugs until they misfire.
WDE46 is offline   Reply With Quote
Old 11-20-2012, 04:04 PM   #7
RayPooley
Registered User
 
Join Date: Jul 2012
Location: Liverpool
Posts: 1,460
My Ride: 320i SE Coupe
Quote:
Originally Posted by reupgang View Post
I drive my car 1x a week prolly about 30-50 miles max, that a good thing right?
Not a bad thing. Its enough to keep it healthy.
RayPooley is offline   Reply With Quote
Old 11-20-2012, 04:08 PM   #8
Zell
Registered User
 
Zell's Avatar
 
Join Date: Jun 2009
Location: wow such city
Posts: 5,787
My Ride: Has no throttle
I haven't either, except the first time I bought it and the secondary air pump hose wasn't connected. CEL doesn't detect things like brakes, oil leaks, worn out belts, etc., but it does detect a lot, and if it's off, your engine is running well. You're good, OP.
__________________
Zell is offline   Reply With Quote
Old 11-20-2012, 04:50 PM   #9
michalt95
Registered User
 
Join Date: Oct 2012
Location: NNJ
Posts: 177
My Ride: 02 325i MT

michalt95 is offline   Reply With Quote
Old 11-20-2012, 05:02 PM   #10
FenderGuy05
OEM ///Member
 
FenderGuy05's Avatar
 
Join Date: Oct 2011
Location: Daly City
Posts: 944
My Ride: 2002 BMW 325i
Quote:
Originally Posted by michalt95 View Post

It's funny, I have honestly thought this from time to time. Just paranoia I think, especially with all the CEL horror stories I've read here. Guess the PO took good care of the car
__________________
FenderGuy05 is offline   Reply With Quote
Old 11-20-2012, 05:03 PM   #11
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 7,442
My Ride: '94 325iC & '00 323i
Your Check Engine light says SERVICE ENGINE SOON. This light should come on with the key in the RUN position before Engine Start, and then go out with the key in the RUN position after Engine Start.

If the light comes on before engine start, and goes out after engine start, then all is well with the engine management and emissions control systems. There are lots of other things that might not be so well, but engine management and emission controls are all working well.
jdstrickland is offline   Reply With Quote
Old 11-20-2012, 05:54 PM   #12
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,858
My Ride: '99 328i 1.04646 mu
Quote:
Originally Posted by reupgang View Post
I've been doing maintenance on my car and followed many DYI on here, but I have yet to have a check engine light on in my 2.5 years of owner ship. should I not worry as much?
LOL

Not having any idea of what you've done, I have no idea. Personally, I think the car will give you warning signs often, which you shouldn't ignore.

Rub it behind the mirrors and it will tell you what's wrong.

Oh, your left rear is .2 psi low. (It's a blessing and a curse!)
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set Skip to 1:30
dmax is offline   Reply With Quote
Old 11-20-2012, 08:31 PM   #13
drivesacrj
Registered User
 
Join Date: Nov 2011
Location: houston
Posts: 119
My Ride: 2000 323i
Had my car a couple of years now, no CELs at all. At one time I unplugged the MAF just to trigger the light and make sure it was working, and even then it took damn near half an hour!!
The light comes on at startup and goes away as soon as the motor coughs to life...
I got lucky with this car: bought it at an auction without prior inspection (theft recovery), didn't know anything about subframe issues at the time, luckily it's intact, no leaks, interior (leatherette) is pristine, motor and trans both silky, no dings or dents, no airbag issues, great mpg, ice cold A/C....looks like PO took care of it before it got jacked...
I am, however, looking to upgrade next year...
drivesacrj is offline   Reply With Quote
Old 11-21-2012, 01:24 AM   #14
TerraPhantm
Registered User
 
Join Date: Feb 2008
Location: Mountain Top
Posts: 5,983
My Ride: 2005 M3 Coupe
The only time I ever got a CEL on my ZHP was when I unplugged the MAF. Even then, it took about 60 miles of driving for that light to get triggered.

On the M3 I've gotten one once due to mixed up O2s and once due to a bad TPS
__________________

Last edited by TerraPhantm; 11-21-2012 at 01:25 AM.
TerraPhantm is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use