E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 5 votes, 5.00 average. Display Modes
Old 05-09-2012, 07:32 PM   #41
steelheaderfishing
Registered User
 
Join Date: Mar 2012
Location: Vermillon Ohio
Posts: 35
My Ride: 23i 25i 28i x5
coils??

could the coils be braking down and getting weak ? I have 300000 miles on my 01 325i did all the stuff You did then changed the coils and that was it ,they were all oe. I even changed the fuel pump too .
steelheaderfishing is offline   Reply With Quote
Old 05-09-2012, 11:12 PM   #42
REKLESS ROB
Registered User
 
Join Date: Jul 2011
Location: Orange County CA
Posts: 143
My Ride: 2004 325ci
I am unfamiliar with the peak scan tool but you need to reset and clear all adaptations. When your car has a vac leak or multiple vac leaks and the o2s are at the limit only "clearing the fault code" will not set the fuel trims to 0. Your car may be slowly adapting but it may take multiple drive cycles to completely smooth out.

Has the ses light returned since you last reset it?
REKLESS ROB is offline   Reply With Quote
Old 05-10-2012, 08:28 AM   #43
pilotnbr1
Registered User
 
Join Date: Mar 2012
Location: Atlanta GA
Posts: 56
My Ride: 2001 325ci
Good point Rob. The peake tool will only clear codes. I have no way that I am aware of to reset the fuel trim. I have been just putting cycles on the car. The problem isn't even noticable unless you stare at the rpm gauge and know what to look for. I haven't checked recently to see if its throwing codes. Will report back.

To sum up what made a difference solving my problem for anyone interested- there was no single smoking gun. The disa had a worn o-ring and vacuum leak in the diaphragm. The icv was dirty. The tb got a cleaning but was fairly clean to begin with. The hose to the fuel filter had the worse vac leak. The vac caps to the rear of the disa were worn. The two hoses off the secondary air solenoid were shot (not sure if these were a factor). The final key was replacing the ccv and all associated hoses along with o-rings for the dipstick. All of these fixes incrimentally fixed the problem.

Last edited by pilotnbr1; 05-10-2012 at 10:53 AM.
pilotnbr1 is offline   Reply With Quote
Old 06-14-2012, 09:01 PM   #44
pilotnbr1
Registered User
 
Join Date: Mar 2012
Location: Atlanta GA
Posts: 56
My Ride: 2001 325ci
Problem solved

I have an update for anyone following this. After all the work I had done I still had a somewhat bouncing idle, lack of torque at low rpm, and somewhat uneven power transitions. I knew that with everything else neglected with this car the VANOS seals were probably in need of replacement. So I went ahead and ordered the kit from Beisian Systems. Sure enough the old seals were in poor shape with the one on the intake side even showing sign of disintigrating.

After replacing the seals everything runs perfect and as it should. On a side note I had a complication with the seal job. Initially my idle was rough like it was missing slightly and the car was throwing peake code 68 for vanos exhaust camshaft timing. Turned out the exhaust camshaft solenoid piston was sticking slightly. I just had to clean it out and reseat it.

So now I throw no codes. Car has much more torque especially at low rpm and the idle is rock steady. CASE CLOSED!
pilotnbr1 is offline   Reply With Quote
Old 10-13-2012, 04:51 PM   #45
pilotnbr1
Registered User
 
Join Date: Mar 2012
Location: Atlanta GA
Posts: 56
My Ride: 2001 325ci
For anyone still subscribed or interested the bouncing idle got better but never went away. I ended up getting INPA, what an eye opener. Anyone with a laptop and $20 has no excuse not to have it. Turned out my aftermarket MAF was over reporting the amount of air which in turn caused too much fuel to be injected which in turn caused the O2 sensors to detect a rich condition which the car tried to correct for but was outside of range. So I got an oe MAF sensor and that improved things but now I still have a small vacuum leak. So I still have a minor idle bounce. I am going to pull the intake manifold and replace the gasket along with a bunch of other components. I have an oil leak from the hose going from the valve cover gasket to the air oil separator. I am going to change that too.. I taking two steps forward and one back with this car...

BTW I had an alternator go out- don't put a duralast in your car, it created a huge idle bounce. Got one with OE internals and that solved that.

On a side note I have also had to change the radiator and hoses and the rear diff bushings- PITA... By the time I am done its going to be a new car
pilotnbr1 is offline   Reply With Quote
Old 10-13-2012, 05:07 PM   #46
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,834
My Ride: '99 328i 1.04646 mu
Yes it will be a new car!

If I may say, if you haven't removed the intake manifold before, I'd say it'd be a good thing not to bother with if you don't otherwise need to.

The intake mani gasket is undoubtedly fine. The vac hoses on back of intake that might crack are accessible by removing cabin air filter housing and the panel on firewall it screws into...covering the fan. That gives you extra room that helps.

If you haven't done so yet, you probably have...clean icv/tb and replace all the rubber things you find. In other words, jfoj your car! LOL
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set

dmax on the radio every Wednesday 7-9 p.m. NYC time. Call in! (661) 449-9340 watsonnwatson.com

Last edited by dmax; 10-13-2012 at 05:09 PM.
dmax is offline   Reply With Quote
Old 11-25-2012, 10:11 PM   #47
328iE46BMW
Registered User
 
Join Date: Nov 2012
Location: Jersey
Posts: 3
My Ride: 1999 328i
valuable info, i vote sticky
328iE46BMW is offline   Reply With Quote
Old 11-26-2012, 08:06 AM   #48
Brinkley
Registered User
 
Join Date: Dec 2006
Location: asheville NC
Posts: 1,502
My Ride: 99 328i, 07 z4 3.0
Yea, no one has ever suggested that bad vanos seals, cheap mafs, and leaky ccvs can cause hunting idles before.
Brinkley is offline   Reply With Quote
Old 08-03-2013, 07:21 PM   #49
pilotnbr1
Registered User
 
Join Date: Mar 2012
Location: Atlanta GA
Posts: 56
My Ride: 2001 325ci
UPDATE- after continuing my 325ci "restoration" one day after doing the front wheel hub/bearings I went to start the car and encountered a strange buzzing sound that would occur on a cycle and would coincide with rough running. After some poking around I determined it was the intake cam solenoid sticking. Ordered a new oe Solenoid and that problem was fixed as well as any idle bounce I still had after all my other repairs.

I think the solenoid was sticking the whole time just slightly. It never gave any codes and only presented itself as a problem when it hard failed and made noise.
pilotnbr1 is offline   Reply With Quote
Old 08-03-2013, 08:26 PM   #50
Importjunkie
Registered User
 
Join Date: Jun 2009
Location: Lexington, KY
Posts: 341
My Ride: 00 Prelude
325ci idle hunting when coming to stop

What a great thread.. Gonna check my disa and Sap vac hoses when I get home


Sent from BimmerApp mobile app
Importjunkie is offline   Reply With Quote
Reply

Tags
idle, problems, stall

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use