E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 11-28-2012, 06:39 PM   #1
TPLGT
Registered User
 
Join Date: Nov 2011
Location: Jacksonville Beach
Posts: 9
My Ride: 2003 M3
New Stereo system installed. Questions??

I decided it was stereo upgrade time. Double din was out of the question so I bought a JVC AVX-77 head unit, steering wheel control unit and the appropriate connectors.

I have on order a set of BSW stage 1 upgrade speakers. The fronts and rears are on back order so I currently have the stockers in.

I pick the car up tonight and it sounds like ****. The speakers are a definite problem but there is distortion from the 40 mark on the volume, up (it goes to 50). The unit itself has an amp (50wx4) so I believe the installer bypassed the factory one. The car came with the stock non-HK system.

Does anyone recognize what could be the issue? I am considering adding the BSW sub but will wait until the speakers are upgraded first. I need to get this straight. At this point, it sounds worse than the stock BMW system.

Thanks.
TPLGT is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use