E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-08-2012, 12:03 AM   #1
Steven747
Registered User
 
Join Date: Aug 2010
Location: Orange County, CA
Posts: 4,390
My Ride: 05 330ci
Non -m electrical issue possibly voltage regulator

So my front right headlight as well as my center dome light in the cabin flickers when the car is on.. I checked the obc voltage and when the car is off it's 12v and when it's on it's 14v volts sound about right so does that rule out the voltage regulator ? Thanks. Also not sure yet what brand alternator I have yet

Thanks in advance
Steven747 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-08-2012, 12:11 AM   #2
Stinger9
Registered User
 
Join Date: Sep 2011
Location: New York
Posts: 8,103
My Ride: '04 330Ci
If you get a good 14v with the engine running, your alternator probably is not at fault.
That battery voltage is kinda low tho. How old is that battery of yours?
Stinger9 is offline   Reply With Quote
Old 12-08-2012, 12:15 AM   #3
HacksawMark
OEM ///Member
 
HacksawMark's Avatar
 
Join Date: Oct 2012
Location: Portland, OR
Posts: 1,101
My Ride: 2014 Subaru XV
Quote:
Originally Posted by Stinger9 View Post
If you get a good 14v with the engine running, your alternator probably is not at fault.
That battery voltage is kinda low tho. How old is that battery of yours?
Would that actually cause the flicker? I noticed the same thing but with the lamp in the trunk.
HacksawMark is offline   Reply With Quote
Old 12-08-2012, 12:25 AM   #4
Stinger9
Registered User
 
Join Date: Sep 2011
Location: New York
Posts: 8,103
My Ride: '04 330Ci
Don't know for sure. Just know many report strange and varied problems with electrics when battery is old and started to fade.

How old battery?
Stinger9 is offline   Reply With Quote
Old 12-08-2012, 12:43 AM   #5
Steven747
Registered User
 
Join Date: Aug 2010
Location: Orange County, CA
Posts: 4,390
My Ride: 05 330ci
Battery is old but no issues overall with it besides this stuff .. I do have a aftermarket amp.. So anyway to check battery life ?
Steven747 is offline   Reply With Quote
Old 12-08-2012, 09:21 AM   #6
jgold47
Registered User
 
Join Date: Sep 2010
Location: Imported from Detroit
Posts: 1,262
My Ride: 2004 X5 3.0
Quote:
Originally Posted by Steven747 View Post
Battery is old but no issues overall with it besides this stuff .. I do have a aftermarket amp.. So anyway to check battery life ?
aftermarket amp and subs can cause havoc with your car's electrical. BMW's seem to have this obnoxiously sensitive electrical system. I would start with a new battery. $100 bucks at wal-mart.
__________________
Religion, Politics, and which oil is the best to use. Three things never to be discussed in polite company...

my about me link
http://forum.e46fanatics.com/showthread.php?t=791566

jgold47 is offline   Reply With Quote
Old 12-08-2012, 11:25 AM   #7
Stinger9
Registered User
 
Join Date: Sep 2011
Location: New York
Posts: 8,103
My Ride: '04 330Ci
Quote:
Originally Posted by jgold47 View Post
I would start with a new battery. $100 bucks at wal-mart.
Simply +1
No way to 100% check old battery for what ails you. Already your test is that you only have 12v. That is low.
Model 49DL at Autozone is your best bet for larger capacity battery for great price. Do not ask them what battery is right for your car as they do not list this one.
Stinger9 is offline   Reply With Quote
Old 12-08-2012, 08:25 PM   #8
Steven747
Registered User
 
Join Date: Aug 2010
Location: Orange County, CA
Posts: 4,390
My Ride: 05 330ci
Quote:
Originally Posted by Stinger9 View Post
Simply +1
No way to 100% check old battery for what ails you. Already your test is that you only have 12v. That is low.
Model 49DL at Autozone is your best bet for larger capacity battery for great price. Do not ask them what battery is right for your car as they do not list this one.
12v when the car is off is low? what should it be? for what ive read it seems about right

ill check for loose connections tomorrow but i would imagine there would be more apparent issues. ill look into the autozone battery fursure though
Steven747 is offline   Reply With Quote
Old 12-08-2012, 10:25 PM   #9
Stinger9
Registered User
 
Join Date: Sep 2011
Location: New York
Posts: 8,103
My Ride: '04 330Ci
Never seen anyone report voltage that had a good battery with less than a 12.4 or 12.6v reading.
Now 12v will get you by, but probably indicates that your battery is not the strongest, and has some age on it.
Stinger9 is offline   Reply With Quote
Old 12-08-2012, 10:52 PM   #10
pleiades
Registered User
 
Join Date: May 2012
Location: Oregon
Posts: 127
My Ride: M52TU
Quote:
Originally Posted by Steven747 View Post
12v when the car is off is low? what should it be? for what ive read it seems about right

ill check for loose connections tomorrow but i would imagine there would be more apparent issues. ill look into the autozone battery fursure though
If it's right at 12 V that's actually marginal, somewhere between 25-50% state of charge. You want the battery to read about 12.5-12.6 V. If you drive the car every day, a good battery should be in the ballpark (assuming you have no sources of parasitic drain).

Your 14 V reading when running the car shows that the alternator is generating within spec and has the margin to charge the battery while powering everything (engine spark, all electrical systems, etc.), but what does it read when you have headlights and stereo going as well? If that amp is drawing a lot of juice, the alt might not have enough leeway to keep the battery charged.
pleiades is offline   Reply With Quote
Old 12-08-2012, 10:55 PM   #11
FenderGuy05
OEM ///Member
 
FenderGuy05's Avatar
 
Join Date: Oct 2011
Location: Daly City
Posts: 944
My Ride: 2002 BMW 325i
I had the same issue after installing amp and sub. Changed battery and it helped, but was told i should get a capacitor to be sure to prevent issues in future.

Sent from my DROID RAZR using Bimmer App
__________________
FenderGuy05 is offline   Reply With Quote
Old 12-09-2012, 12:28 AM   #12
Steven747
Registered User
 
Join Date: Aug 2010
Location: Orange County, CA
Posts: 4,390
My Ride: 05 330ci
very interesting.

thanks to all who responded in this thread. all replys were very helpful..

so ignition in number 2 position voltage is a about 119 -120 with everything on .. if its not at the 12.5-12.6 could where its at now cause the smallest flicker and slight dullness of a headlight?
Steven747 is offline   Reply With Quote
Old 12-13-2012, 10:49 AM   #13
Steven747
Registered User
 
Join Date: Aug 2010
Location: Orange County, CA
Posts: 4,390
My Ride: 05 330ci
so guys new battery is in because mine died on me yesterday. dl49 or whatever it was from autozone.. no more cabin light flicker but my passenger angel eye still is dim and flickers....? found this other thread which sounds like the guy is having the same issue.. what do yall thing

http://forum.e46fanatics.com/showthr...ght=alternator
Steven747 is offline   Reply With Quote
Old 12-13-2012, 11:34 AM   #14
Stinger9
Registered User
 
Join Date: Sep 2011
Location: New York
Posts: 8,103
My Ride: '04 330Ci
I'd suspect the size of the wiring to the angel eyes. Is it tiny stuff supplied by the manufacturer?

Last edited by Stinger9; 12-13-2012 at 11:38 AM.
Stinger9 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use