E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 244 votes, 4.94 average.
Old 11-24-2012, 04:07 PM   #1201
Sshark
Registered User
 
Join Date: Oct 2005
Location: Ontario, Canada
Posts: 230
My Ride: 328i and Z3
Quote:
Originally Posted by SHOoff11 View Post
Do I need the 20pin adapter for my '99?

You need the rounded 20pin adaptor

Last edited by Sshark; 11-24-2012 at 04:08 PM.
Sshark is offline   Reply With Quote
Old 11-24-2012, 04:10 PM   #1202
SHOoff11
Registered User
 
Join Date: Apr 2011
Location: Mobile, AL
Posts: 261
My Ride: 1999 Lexus LS400
Quote:
Originally Posted by Sshark View Post
You need the rounded 20pin adaptor
Thanks! I plan on ordering both tonight.
__________________
Quote:
Originally Posted by SPDSKTR
You drive a BMW. That means you make $600,000 a year and date supermodels without pointy elbows or hairy arms. Need I say more?

1999 Lexus LS400 Pearl White/Tan
-RSR Black-i Coilovers
-Battle Version Toe/Camber/Traction Arms kit
-BBS Super RS Replicas (19x8.5 +20/19x9.5 +20)

1983 BMW 733i 5MT Schwarz/Cardinal

Sold: 1999 328i sedan Alpine White/Sand
SHOoff11 is offline   Reply With Quote
Old 12-07-2012, 08:26 AM   #1203
p0lar
Registered User
 
Join Date: Jul 2012
Location: Midwest
Posts: 32
My Ride: E46 ///M3
I've also got the dreaded 'No coding data retrieved' error on my '04 M3 (6MT) when trying to connect to the IKE module.

Was anyone able to figure this out apart from luthers and Terraphantm?

If not, there are a few options I would like to have investigated by someone who's familiar with NCSExpert and PA Soft and has an E46 325 or 330 using PA Soft version 1.4.0.9.

My thinking is this, that PA Soft isn't doing anything that NCS Expert can't; thus, if someone could read the NCS Expert config out, save it, then make a change with PA Soft, then read out the NCS Expert config again and run a diff against it, it wouldn't be an issue whatsoever.

Is anyone game to help a fellow coding enthusiast out?
p0lar is offline   Reply With Quote
Old 12-07-2012, 06:43 PM   #1204
SHOoff11
Registered User
 
Join Date: Apr 2011
Location: Mobile, AL
Posts: 261
My Ride: 1999 Lexus LS400
Can I code my '99 with halogens to xenons with aftermarket HIDs for a retrofit to get rid of the errors? I bought the error cancelers, but people say those don't always work. I've been told conflicting things when searching.
__________________
Quote:
Originally Posted by SPDSKTR
You drive a BMW. That means you make $600,000 a year and date supermodels without pointy elbows or hairy arms. Need I say more?

1999 Lexus LS400 Pearl White/Tan
-RSR Black-i Coilovers
-Battle Version Toe/Camber/Traction Arms kit
-BBS Super RS Replicas (19x8.5 +20/19x9.5 +20)

1983 BMW 733i 5MT Schwarz/Cardinal

Sold: 1999 328i sedan Alpine White/Sand

Last edited by SHOoff11; 12-07-2012 at 06:45 PM.
SHOoff11 is offline   Reply With Quote
Old 12-08-2012, 09:33 AM   #1205
spherehunter
Registered User
 
Join Date: Nov 2012
Location: Florida
Posts: 14
My Ride: 2001 BMW 325i
Running Lights/Auto Lock

I cant seem to get the running lights or the Auto locks using PA Soft on my 2001 BMW 325i. I have gotten everything else to work except this two items. Anyone have any ideas?
spherehunter is offline   Reply With Quote
Old 12-08-2012, 05:43 PM   #1206
SHOoff11
Registered User
 
Join Date: Apr 2011
Location: Mobile, AL
Posts: 261
My Ride: 1999 Lexus LS400
Quote:
Originally Posted by spherehunter View Post
I cant seem to get the running lights or the Auto locks using PA Soft on my 2001 BMW 325i. I have gotten everything else to work except this two items. Anyone have any ideas?
Are pins 7 & 8 bridged on your scanner?
__________________
Quote:
Originally Posted by SPDSKTR
You drive a BMW. That means you make $600,000 a year and date supermodels without pointy elbows or hairy arms. Need I say more?

1999 Lexus LS400 Pearl White/Tan
-RSR Black-i Coilovers
-Battle Version Toe/Camber/Traction Arms kit
-BBS Super RS Replicas (19x8.5 +20/19x9.5 +20)

1983 BMW 733i 5MT Schwarz/Cardinal

Sold: 1999 328i sedan Alpine White/Sand
SHOoff11 is offline   Reply With Quote
Old 12-08-2012, 06:57 PM   #1207
wildirish317
Registered User
 
Join Date: Sep 2012
Location: Louisville, KY
Posts: 2,856
My Ride: 2004 325Ci vert
Finally received my scan tool today. Ordered it on 11/19 via HK post, so it took less than the month I expected. I tried loading it on my Windows 7 laptop, but could not get it to load the driver. One forum suggests holding down the F8 key during computer boot, and selecting "Disable driver signature recognition". This didn't work on my Windows 7 laptop, but it did work on my Windows Vista laptop.

It's really nice being able to know what codes are actually being thrown, and which ones are still active.
__________________


“The test of the machine is the satisfaction it gives you. There isn't any other test. If the machine produces tranquility it's right. If it disturbs you it's wrong until either the machine or your mind is changed.”

Quote:
Originally Posted by Mike Miller
I just don't know what I'd do with 560 hp that doesn't involve getting arrested.
wildirish317 is offline   Reply With Quote
Old 12-08-2012, 07:50 PM   #1208
spherehunter
Registered User
 
Join Date: Nov 2012
Location: Florida
Posts: 14
My Ride: 2001 BMW 325i
Quote:
Originally Posted by SHOoff11 View Post
Are pins 7 & 8 bridged on your scanner?
I assume so I was able to enable the alarm and all convenience features.
spherehunter is offline   Reply With Quote
Old 12-08-2012, 09:59 PM   #1209
rwall
Registered User
 
Join Date: Jan 2010
Location: WA
Posts: 301
My Ride: 2004 325ci
My car is NOT beeping at 37 degrees. Thank you c-car 360!
rwall is offline   Reply With Quote
Old 12-10-2012, 01:32 AM   #1210
hassmaschine
Registered User
 
Join Date: Sep 2011
Location: Ferndale, WA
Posts: 198
My Ride: '91 325ix
Quote:
Originally Posted by p0lar View Post
I've also got the dreaded 'No coding data retrieved' error on my '04 M3 (6MT) when trying to connect to the IKE module.

Was anyone able to figure this out apart from luthers and Terraphantm?

If not, there are a few options I would like to have investigated by someone who's familiar with NCSExpert and PA Soft and has an E46 325 or 330 using PA Soft version 1.4.0.9.

My thinking is this, that PA Soft isn't doing anything that NCS Expert can't; thus, if someone could read the NCS Expert config out, save it, then make a change with PA Soft, then read out the NCS Expert config again and run a diff against it, it wouldn't be an issue whatsoever.

Is anyone game to help a fellow coding enthusiast out?
just use NCS dummy with NCSexpert. there's almost nothing really interesting you can do in PA soft to an E46 M3 cluster anyway.

also, there are things that you can't change in that particular cluster. I'm thinking that's the reason you're getting an error message.
hassmaschine is offline   Reply With Quote
Old 12-10-2012, 01:36 AM   #1211
scarede46er
Registered User
 
Join Date: Aug 2012
Location: Clemson, SC
Posts: 1,258
My Ride: 2001 BMW 325i ZSP
Quote:
Originally Posted by SHOoff11 View Post
Can I code my '99 with halogens to xenons with aftermarket HIDs for a retrofit to get rid of the errors? I bought the error cancelers, but people say those don't always work. I've been told conflicting things when searching.
yes. There is a section for that in Pa Soft under LCM.
scarede46er is offline   Reply With Quote
Old 12-10-2012, 01:38 AM   #1212
scarede46er
Registered User
 
Join Date: Aug 2012
Location: Clemson, SC
Posts: 1,258
My Ride: 2001 BMW 325i ZSP
Quote:
Originally Posted by spherehunter View Post
I cant seem to get the running lights or the Auto locks using PA Soft on my 2001 BMW 325i. I have gotten everything else to work except this two items. Anyone have any ideas?
The door locks are under ZKE under recoding.
DRLs are under LCM > reprogramming. You need to check both EU and US to have the DRLs else you will only have your parking lights on as DRL.
scarede46er is offline   Reply With Quote
Old 12-10-2012, 01:58 AM   #1213
p0lar
Registered User
 
Join Date: Jul 2012
Location: Midwest
Posts: 32
My Ride: E46 ///M3
Quote:
Originally Posted by hassmaschine View Post
just use NCS dummy with NCSexpert. there's almost nothing really interesting you can do in PA soft to an E46 M3 cluster anyway.

also, there are things that you can't change in that particular cluster. I'm thinking that's the reason you're getting an error message.
You can recode the mileage and/or VIN for replacement or to convert from SMG to 6MT. To my knowledge, that's not possible with NCS Expert/dummy.

There are quite a few of us who are trying to enable the E46 M3 CSL's oil level function in the standard 6MT/SMG E46 M3 cluster.
p0lar is offline   Reply With Quote
Old 12-10-2012, 02:10 AM   #1214
TerraPhantm
Registered User
 
Join Date: Feb 2008
Location: Mountain Top
Posts: 5,996
My Ride: 2005 M3 Coupe
Quote:
Originally Posted by p0lar View Post
You can recode the mileage and/or VIN for replacement or to convert from SMG to 6MT. To my knowledge, that's not possible with NCS Expert/dummy.

There are quite a few of us who are trying to enable the E46 M3 CSL's oil level function in the standard 6MT/SMG E46 M3 cluster.
Can't change mileage without an external programmer. I believe the same applies for the VIN.

The rest of the settings in the cluster page are found in NCS Expert
__________________
TerraPhantm is offline   Reply With Quote
Old 12-10-2012, 02:54 AM   #1215
p0lar
Registered User
 
Join Date: Jul 2012
Location: Midwest
Posts: 32
My Ride: E46 ///M3
Quote:
Originally Posted by TerraPhantm View Post
Can't change mileage without an external programmer. I believe the same applies for the VIN.

The rest of the settings in the cluster page are found in NCS Expert
You can't change the mileage/VIN of the AKMB (IKE) using PA Soft? Hrmn.. You can do it with the ALSZ (LCM).

I think it's just a string of bytes ordinarily grabbed by a specific request. I was going to do a serial dump some day to see how the communication protocol works, but there are just too many other interesting things to do on the MSS54HP at the moment.
p0lar is offline   Reply With Quote
Old 12-10-2012, 03:05 AM   #1216
TerraPhantm
Registered User
 
Join Date: Feb 2008
Location: Mountain Top
Posts: 5,996
My Ride: 2005 M3 Coupe
Quote:
Originally Posted by p0lar View Post
You can't change the mileage/VIN of the AKMB (IKE) using PA Soft? Hrmn.. You can do it with the ALSZ (LCM).

I think it's just a string of bytes ordinarily grabbed by a specific request. I was going to do a serial dump some day to see how the communication protocol works, but there are just too many other interesting things to do on the MSS54HP at the moment.
Yeah the mileage on the AKMB/IKE is protected.

Try for yourself. Backup an EEPROM, change the mileage, and upload. If you read it back, you'll find the mileage won't have changed

(it *may* allow you to increase the mileage, i haven't tested that)
__________________

Last edited by TerraPhantm; 12-10-2012 at 03:09 AM.
TerraPhantm is offline   Reply With Quote
Old 12-11-2012, 12:11 AM   #1217
hassmaschine
Registered User
 
Join Date: Sep 2011
Location: Ferndale, WA
Posts: 198
My Ride: '91 325ix
Quote:
Originally Posted by p0lar View Post
You can recode the mileage and/or VIN for replacement or to convert from SMG to 6MT. To my knowledge, that's not possible with NCS Expert/dummy.

There are quite a few of us who are trying to enable the E46 M3 CSL's oil level function in the standard 6MT/SMG E46 M3 cluster.
you can change it to 6mt and turn on the CSL oil level in NCSexpert but AFAIK you need a CSL coded DME to match it for the readout to work.

you can't change the mileage, up or down. you'd have to desolder the chip and do it the hard way.
hassmaschine is offline   Reply With Quote
Old 12-12-2012, 01:47 AM   #1218
fire730
Registered User
 
Join Date: Feb 2012
Location: Louisiana
Posts: 103
My Ride: 01 325iT - 04 Burb
Wasted an hour of my life and I can't figure out why this thing still says the adapter isn't plugged in. Any ideas? Removed and reinstalled the program 3 times and it still tells me the same thing.

2001 325iT.

Thanks for any help.
__________________
01 325iT ZSP - Koni - Hotchkis
01 525iT - stock for now
04 Chevy Suburban - Modded - My Daily
08 Chevy Suburban - Modded - Wife's Daily
fire730 is offline   Reply With Quote
Old 12-12-2012, 01:27 PM   #1219
spherehunter
Registered User
 
Join Date: Nov 2012
Location: Florida
Posts: 14
My Ride: 2001 BMW 325i
Quote:
Originally Posted by scarede46er View Post
The door locks are under ZKE under recoding.
DRLs are under LCM > reprogramming. You need to check both EU and US to have the DRLs else you will only have your parking lights on as DRL.
I have selected the door locks under ZKE for some reason still not working. I'll try selecting EU and US and see if it works right now I only have US selected.

Thanks
spherehunter is offline   Reply With Quote
Old 12-13-2012, 12:25 PM   #1220
fire730
Registered User
 
Join Date: Feb 2012
Location: Louisiana
Posts: 103
My Ride: 01 325iT - 04 Burb
Quote:
Originally Posted by fire730 View Post
Wasted an hour of my life and I can't figure out why this thing still says the adapter isn't plugged in. Any ideas? Removed and reinstalled the program 3 times and it still tells me the same thing.

2001 325iT.

Thanks for any help.
Anyone have any ideas??

Tried it again today and I noticed only the yellow light was working on the OBD adapter. I fiddled with the cable and the green light comes on now but it still tells me its not plugged in. What can I check? I dont have access to another Bmw and I havent really found any fixes by scanning through all these pages.
__________________
01 325iT ZSP - Koni - Hotchkis
01 525iT - stock for now
04 Chevy Suburban - Modded - My Daily
08 Chevy Suburban - Modded - Wife's Daily
fire730 is offline   Reply With Quote
Reply

Tags
bmw scanner, diagnostic tool, error message, pa soft

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use