E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-11-2012, 11:46 AM   #1
McDeshen
Registered User
 
Join Date: Sep 2012
Location: Arnold, Maryland
Posts: 93
My Ride: '99 323i
All Speakers Sound Bad

My speakers in my E46 all sound pretty bad, there's basically no bass or surrounding sound to it at all, but they still work. Does this sound like a speaker problem or something else like a fuse?
__________________

E46 165k
Ryan - 18
McDeshen is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-11-2012, 12:04 PM   #2
scarede46er
Registered User
 
Join Date: Aug 2012
Location: Clemson, SC
Posts: 1,246
My Ride: 2001 BMW 325i ZSP
Bad amplifier maybe.
scarede46er is offline   Reply With Quote
Old 12-11-2012, 12:32 PM   #3
Slapsys
Registered User
 
Join Date: Jun 2011
Location: Calgary, Alberta, Canada
Posts: 320
My Ride: 323Ci
Probably bad speakers. Take a close look at them by removing the grills and if the speaker is torn away from the frame, that would be your problem. You can buy new ones ($$$) or fix your old ones easily. Where the speaker paper cone is separated from the frame (or anywhere else, but usually there), just paint it with nail polish. this will glue the edges together without wrecking the cone. I've fixed tonnes of speakers this way and it will last for as long as it takes to save up money for new ones. I fixed my speakers in the back like this a year ago and it's still holding.
Slapsys is offline   Reply With Quote
Old 12-11-2012, 12:39 PM   #4
scarede46er
Registered User
 
Join Date: Aug 2012
Location: Clemson, SC
Posts: 1,246
My Ride: 2001 BMW 325i ZSP
How can all speakers simultaneously go bad? I am betting its the amp. Do you have the HK system, OP?
scarede46er is offline   Reply With Quote
Old 12-11-2012, 12:44 PM   #5
Ruthlessone3k
Registered User
 
Join Date: Dec 2012
Location: Germany
Posts: 128
My Ride: 323i
Do you happen to have a Kesha cd in it??? Because that will make any speaker sound like crap.
Ruthlessone3k is offline   Reply With Quote
Old 12-11-2012, 12:58 PM   #6
Slapsys
Registered User
 
Join Date: Jun 2011
Location: Calgary, Alberta, Canada
Posts: 320
My Ride: 323Ci
Quote:
Originally Posted by Ruthlessone3k View Post
Do you happen to have a Kesha cd in it??? Because that will make any speaker sound like crap.
Slapsys is offline   Reply With Quote
Old 12-11-2012, 01:02 PM   #7
Slapsys
Registered User
 
Join Date: Jun 2011
Location: Calgary, Alberta, Canada
Posts: 320
My Ride: 323Ci
Quote:
Originally Posted by scarede46er View Post
How can all speakers simultaneously go bad? I am betting its the amp. Do you have the HK system, OP?
The two main speakers in the back, when blown, will make all the speakers sound like Shite. I had an old Dakota truck that had the worst stereo ever. I replaced the stereo with an expensive one (I like my tunes) with no effect. I changed out the two back speakers and suddenly, all of the sound system sounded great. I think the reason the back speakers usually go first is the fact that they sit in the sun and cook all year long, year after year. Besides, a lot easier to "look at speakers" than buy a new amp.
Slapsys is offline   Reply With Quote
Old 12-11-2012, 01:03 PM   #8
scarede46er
Registered User
 
Join Date: Aug 2012
Location: Clemson, SC
Posts: 1,246
My Ride: 2001 BMW 325i ZSP
Ya, of course OP should check out his speakers first. As well as his amp before he buys new anything. I thought that went without saying.
scarede46er is offline   Reply With Quote
Old 12-11-2012, 01:09 PM   #9
TonyDiv
Registered User
 
Join Date: May 2012
Location: Ft. Myers Fl
Posts: 47
My Ride: 03 325Ci Convertible
I was actually quite amazed that BMW could find 10 speakers to put in to my car that all sounded like crap. The sourcing people must have had a hell of a time tracking down that many muddy sounding speakers..

BSW made it all better ( well as good as it's going to get without spending big bucks)
TonyDiv is offline   Reply With Quote
Old 12-11-2012, 01:10 PM   #10
scarede46er
Registered User
 
Join Date: Aug 2012
Location: Clemson, SC
Posts: 1,246
My Ride: 2001 BMW 325i ZSP
^ I agree. The stock system is crap. I replaced mine with an Alpine/Boston setup and it sounds like heaven. I also have the HK amplifier for sale if it turns out that is OP's issue.
scarede46er is offline   Reply With Quote
Old 12-12-2012, 06:31 PM   #11
ShookMasta
Registered User
 
Join Date: Dec 2012
Location: Kansas
Posts: 30
My Ride: 00 323ci
Quote:
Originally Posted by scarede46er View Post
^ I agree. The stock system is crap. I replaced mine with an Alpine/Boston setup and it sounds like heaven. I also have the HK amplifier for sale if it turns out that is OP's issue.
I think my amp just shot ****. I don't have the H/K sound system. Probably couldn't replace my amp with the H/K one huh?
__________________
ShookMasta is offline   Reply With Quote
Old 12-12-2012, 06:32 PM   #12
scarede46er
Registered User
 
Join Date: Aug 2012
Location: Clemson, SC
Posts: 1,246
My Ride: 2001 BMW 325i ZSP
Quote:
Originally Posted by ShookMasta View Post
I think my amp just shot ****. I don't have the H/K sound system. Probably couldn't replace my amp with the H/K one huh?
Nope. Check on Ebay. I am sure they have yours for sale.
scarede46er is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use